summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-02-01 15:38:22 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-02-01 15:38:22 +0000
commit16dd2565b6de6fa2f2ca7eb3d78b939330a9e383 (patch)
treeb2bdeba444afdd44af0afa4bbdeda03a79e62e6e /media-video/ttcut
parentlower evo, gstreamer and gst-plugins-good deps (diff)
downloadgentoo-2-16dd2565b6de6fa2f2ca7eb3d78b939330a9e383.tar.gz
gentoo-2-16dd2565b6de6fa2f2ca7eb3d78b939330a9e383.tar.bz2
gentoo-2-16dd2565b6de6fa2f2ca7eb3d78b939330a9e383.zip
Now using slot dependency/eapi-1 for qt4.
(Portage version: 2.1.4.1)
Diffstat (limited to 'media-video/ttcut')
-rw-r--r--media-video/ttcut/ChangeLog10
-rw-r--r--media-video/ttcut/ttcut-0.19.6-r1.ebuild47
2 files changed, 55 insertions, 2 deletions
diff --git a/media-video/ttcut/ChangeLog b/media-video/ttcut/ChangeLog
index 2a0ed05a4f2a..02ba0a78738a 100644
--- a/media-video/ttcut/ChangeLog
+++ b/media-video/ttcut/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/ttcut
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ttcut/ChangeLog,v 1.9 2007/09/02 14:26:11 zzam Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ttcut/ChangeLog,v 1.10 2008/02/01 15:38:22 zzam Exp $
+
+*ttcut-0.19.6-r1 (01 Feb 2008)
+
+ 01 Feb 2008; Matthias Schwarzott <zzam@gentoo.org>
+ +ttcut-0.19.6-r1.ebuild:
+ Now using slot dependency/eapi-1 for qt4.
*ttcut-0.19.6 (02 Sep 2007)
diff --git a/media-video/ttcut/ttcut-0.19.6-r1.ebuild b/media-video/ttcut/ttcut-0.19.6-r1.ebuild
new file mode 100644
index 000000000000..5fb95abc7a93
--- /dev/null
+++ b/media-video/ttcut/ttcut-0.19.6-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ttcut/ttcut-0.19.6-r1.ebuild,v 1.1 2008/02/01 15:38:22 zzam Exp $
+
+EAPI="1"
+inherit eutils qt4
+
+DESCRIPTION="Tool for removing advertisements from recorded MPEG files"
+HOMEPAGE="http://ttcut.tritime.org/"
+SRC_URI="mirror://berlios/${PN}/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-4.3:4
+ >=media-libs/libmpeg2-0.4.0
+ virtual/opengl"
+
+RDEPEND="${DEPEND}
+ media-video/mplayer
+ media-video/transcode"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ if ! built_with_use media-video/transcode mjpeg ; then
+ eerror "In order to have encoding mode working with ttcut"
+ eerror "you need to recompile transcode with mjpeg USE flag enabled."
+ die "Recompile transcode with mjpeg USE flag enabled"
+ fi
+}
+
+src_compile() {
+ eqmake4 ttcut.pro -o Makefile.ttcut
+ emake -f Makefile.ttcut || die "emake failed"
+}
+
+src_install() {
+ dobin ttcut || die "Couldn't install ttcut"
+ make_desktop_entry ttcut TTCut "" "AudioVideo;Video;AudioVideoEditing" || \
+ die "Couldn't make ttcut desktop entry"
+
+ dodoc AUTHORS BUGS CHANGELOG \
+ README.DE README.EN TODO || die "Couldn't install documentation"
+}