summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-20 13:04:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-20 13:04:55 +0000
commit196229eeaf30840d76978abff701a07c6650a1be (patch)
tree5d10a53f4f4c1389a2e5d53c75c578e5eac967d0 /media-video
parentx11-base/xorg-server: drop 3dfx USE flag from 1.6, there's no reason for the ... (diff)
downloadgentoo-2-196229eeaf30840d76978abff701a07c6650a1be.tar.gz
gentoo-2-196229eeaf30840d76978abff701a07c6650a1be.tar.bz2
gentoo-2-196229eeaf30840d76978abff701a07c6650a1be.zip
Force disable altivec support in ffmpeg wrt #252641.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpegthumbnailer/ChangeLog6
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.0.ebuild9
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.1.ebuild5
3 files changed, 12 insertions, 8 deletions
diff --git a/media-video/ffmpegthumbnailer/ChangeLog b/media-video/ffmpegthumbnailer/ChangeLog
index d3b9b371374a..69df5c93616e 100644
--- a/media-video/ffmpegthumbnailer/ChangeLog
+++ b/media-video/ffmpegthumbnailer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpegthumbnailer
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.68 2009/05/19 20:36:46 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.69 2009/05/20 13:04:55 ssuominen Exp $
+
+ 20 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ ffmpegthumbnailer-1.5.0.ebuild, ffmpegthumbnailer-1.5.1.ebuild:
+ Force disable altivec support in ffmpeg wrt #252641.
19 May 2009; Brent Baude <ranger@gentoo.org>
ffmpegthumbnailer-1.5.0.ebuild:
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.0.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.0.ebuild
index 15735cb58b0f..90b3e30c8f14 100644
--- a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.0.ebuild
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.0.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.0.ebuild,v 1.5 2009/05/19 20:36:46 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.0.ebuild,v 1.6 2009/05/20 13:04:55 ssuominen Exp $
EAPI=2
-inherit multilib
DESCRIPTION="Lightweight video thumbnailer that can be used by file managers"
HOMEPAGE="http://code.google.com/p/ffmpegthumbnailer"
@@ -16,16 +15,16 @@ IUSE=""
RDEPEND="media-libs/libpng
media-libs/jpeg
- >=media-video/ffmpeg-0.4.9_p20070330"
+ >=media-video/ffmpeg-0.4.9_p20070330[-altivec]"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_configure() {
- econf --disable-dependency-tracking --disable-static
+ econf \
+ --disable-dependency-tracking
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog README TODO
- rm -f "${D}"/usr/$(get_libdir)/libffmpegthumbnailer.la
}
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.1.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.1.ebuild
index e2c02af65b21..b6a2dfa838dd 100644
--- a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.1.ebuild
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.1.ebuild,v 1.1 2009/05/13 14:03:32 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.1.ebuild,v 1.2 2009/05/20 13:04:55 ssuominen Exp $
EAPI=2
@@ -13,7 +13,8 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="jpeg png"
-RDEPEND=">=media-video/ffmpeg-0.5
+# See bug 252641, please try to remove the -altivec soon as possible.
+RDEPEND=">=media-video/ffmpeg-0.5[-altivec]
png? ( media-libs/libpng )
jpeg? ( media-libs/jpeg )"
DEPEND="${RDEPEND}