summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2009-06-21 15:01:46 +0000
committerDaniel Pielmeier <billie@gentoo.org>2009-06-21 15:01:46 +0000
commitb4d59ee9623f9d0fe7e958f9ef04311b2866646d (patch)
treeba697362ee3a828e6e5818696c5a63d9f9745ba1 /media-video
parentVersion bump, change name to follow Debian, and drop old files (diff)
downloadgentoo-2-b4d59ee9623f9d0fe7e958f9ef04311b2866646d.tar.gz
gentoo-2-b4d59ee9623f9d0fe7e958f9ef04311b2866646d.tar.bz2
gentoo-2-b4d59ee9623f9d0fe7e958f9ef04311b2866646d.zip
Adding a patch which fixes parallel installation
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/dvbcut/ChangeLog6
-rw-r--r--media-video/dvbcut/dvbcut-0.6.0.ebuild10
-rw-r--r--media-video/dvbcut/files/dvbcut-0.6.0-parallel-install.patch11
3 files changed, 22 insertions, 5 deletions
diff --git a/media-video/dvbcut/ChangeLog b/media-video/dvbcut/ChangeLog
index 9a53701e6531..8ccbd6f56e9b 100644
--- a/media-video/dvbcut/ChangeLog
+++ b/media-video/dvbcut/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/dvbcut
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/ChangeLog,v 1.18 2009/06/19 20:06:13 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/ChangeLog,v 1.19 2009/06/21 15:01:46 billie Exp $
+
+ 21 Jun 2009; Pielmeier Daniel <billie@gentoo.org>
+ +files/dvbcut-0.6.0-parallel-install.patch, dvbcut-0.6.0.ebuild:
+ Adding a patch which fixes parallel installation
*dvbcut-0.6.0 (19 Jun 2009)
diff --git a/media-video/dvbcut/dvbcut-0.6.0.ebuild b/media-video/dvbcut/dvbcut-0.6.0.ebuild
index b91e6f1a1b45..e4cd5d703b19 100644
--- a/media-video/dvbcut/dvbcut-0.6.0.ebuild
+++ b/media-video/dvbcut/dvbcut-0.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/dvbcut-0.6.0.ebuild,v 1.1 2009/06/19 20:06:13 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/dvbcut-0.6.0.ebuild,v 1.2 2009/06/21 15:01:46 billie Exp $
EAPI=2
@@ -24,14 +24,16 @@ RDEPEND="x11-libs/qt:3
DEPEND="${RDEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}"/dvbcut-0.6.0-parallel-install.patch
+}
+
src_configure() {
econf --with-ffmpeg=/usr
}
src_install() {
- # disable parallel build
- # already created MANDIR causes the build to fail
- emake -j1 DESTDIR="${D}" install \
+ emake DESTDIR="${D}" install \
|| die "Emake install failed"
make_desktop_entry dvbcut DVBcut
dodoc ChangeLog CREDITS README README.ffmpeg README.icons
diff --git a/media-video/dvbcut/files/dvbcut-0.6.0-parallel-install.patch b/media-video/dvbcut/files/dvbcut-0.6.0-parallel-install.patch
new file mode 100644
index 000000000000..ac4dfe5ea958
--- /dev/null
+++ b/media-video/dvbcut/files/dvbcut-0.6.0-parallel-install.patch
@@ -0,0 +1,11 @@
+--- makefile.in.old 2009-01-24 15:51:07.000000000 +0100
++++ makefile.in 2009-06-21 16:05:23.000000000 +0200
+@@ -27,7 +27,7 @@
+ mandir = @mandir@
+ man1dir = $(mandir)/man1
+
+-installdirs = $(DESTDIR)$(mandir) $(DESTDIR)$(man1dir)
++installdirs = $(DESTDIR)$(man1dir)
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@