summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-29 21:37:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-29 21:37:50 +0000
commitf6d04b7bee1737447e620552cfe7c25b9cc4cb6b (patch)
treebea457b0f04a4ee50ace78b08443954144f30aa2 /media-video
parentbump a new snapshot (diff)
downloadgentoo-2-f6d04b7bee1737447e620552cfe7c25b9cc4cb6b.tar.gz
gentoo-2-f6d04b7bee1737447e620552cfe7c25b9cc4cb6b.tar.bz2
gentoo-2-f6d04b7bee1737447e620552cfe7c25b9cc4cb6b.zip
bump a new snapshot
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/x264-encoder/ChangeLog8
-rw-r--r--media-video/x264-encoder/x264-encoder-0.0.20090629.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/media-video/x264-encoder/ChangeLog b/media-video/x264-encoder/ChangeLog
index 88a21a78899f..9a21a03df9c9 100644
--- a/media-video/x264-encoder/ChangeLog
+++ b/media-video/x264-encoder/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/x264-encoder
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/x264-encoder/ChangeLog,v 1.20 2009/06/29 21:21:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/x264-encoder/ChangeLog,v 1.21 2009/06/29 21:37:50 aballier Exp $
+
+*x264-encoder-0.0.20090629 (29 Jun 2009)
+
+ 29 Jun 2009; Alexis Ballier <aballier@gentoo.org>
+ +x264-encoder-0.0.20090629.ebuild:
+ bump a new snapshot
29 Jun 2009; Alexis Ballier <aballier@gentoo.org>
-x264-encoder-0.0.20081218.ebuild:
diff --git a/media-video/x264-encoder/x264-encoder-0.0.20090629.ebuild b/media-video/x264-encoder/x264-encoder-0.0.20090629.ebuild
new file mode 100644
index 000000000000..e88a77a36fe1
--- /dev/null
+++ b/media-video/x264-encoder/x264-encoder-0.0.20090629.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/x264-encoder/x264-encoder-0.0.20090629.ebuild,v 1.1 2009/06/29 21:37:50 aballier Exp $
+
+EAPI="1"
+inherit multilib eutils toolchain-funcs versionator
+
+MY_P="x264-snapshot-$(get_version_component_range 3)-2245"
+
+DESCRIPTION="A free commandline encoder for X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +mp4 +threads"
+
+RDEPEND="mp4? ( >=media-video/gpac-0.4.1_pre20060122 )
+ ~media-libs/x264-${PV}"
+
+DEPEND="${RDEPEND}
+ amd64? ( >=dev-lang/yasm-0.6.1 )
+ x86? ( || ( >=dev-lang/yasm-0.6.2 dev-lang/nasm ) )
+ x86-fbsd? ( >=dev-lang/yasm-0.6.2 )
+ dev-util/pkgconfig"
+
+# Block older than 0.6.2 versions of yasm
+# It generates incorect pic code and will cause segfaults
+# See http://www.tortall.net/projects/yasm/ticket/114
+DEPEND="${DEPEND}
+ x86? ( !<dev-lang/yasm-0.6.2 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-nostrip.patch"
+ epatch "${FILESDIR}/${PN}-nolib-20090408.patch"
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+ ./configure --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --enable-pic --enable-shared \
+ "--extra-cflags=${CFLAGS}" \
+ "--extra-ldflags=${LDFLAGS}" \
+ "--extra-asflags=${ASFLAGS}" \
+ "--host=${CHOST}" \
+ ${myconf} \
+ $(use_enable threads pthread) \
+ $(use_enable mp4 mp4-output) \
+ || die "configure failed"
+ emake CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS doc/*.txt
+}