summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-08-19 03:49:31 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-08-19 03:49:31 +0000
commite4978bfa949ca937d21d05473dbf3cc48801fdbb (patch)
treea9b91fb559b0bac09faf4ed70d255d7757de38f5 /net-analyzer/bigeye
parentFixes #6645. init.d bug (diff)
downloadgentoo-2-e4978bfa949ca937d21d05473dbf3cc48801fdbb.tar.gz
gentoo-2-e4978bfa949ca937d21d05473dbf3cc48801fdbb.tar.bz2
gentoo-2-e4978bfa949ca937d21d05473dbf3cc48801fdbb.zip
initial import
Diffstat (limited to 'net-analyzer/bigeye')
-rw-r--r--net-analyzer/bigeye/ChangeLog10
-rw-r--r--net-analyzer/bigeye/bigeye-0.3.ebuild44
-rw-r--r--net-analyzer/bigeye/files/digest-bigeye-0.31
3 files changed, 55 insertions, 0 deletions
diff --git a/net-analyzer/bigeye/ChangeLog b/net-analyzer/bigeye/ChangeLog
new file mode 100644
index 000000000000..77eacbcc97c2
--- /dev/null
+++ b/net-analyzer/bigeye/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-analyzer/bigeye
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bigeye/ChangeLog,v 1.1 2002/08/19 03:49:31 blocke Exp $
+
+*bigeye-0.3 (18 Aug 2002)
+
+ 18 Aug 2002; Bruce A. Locke <blocke@shivan.org> bigeye-0.3.ebuild:
+ Initial import.
+
+
diff --git a/net-analyzer/bigeye/bigeye-0.3.ebuild b/net-analyzer/bigeye/bigeye-0.3.ebuild
new file mode 100644
index 000000000000..3ea53bdb9678
--- /dev/null
+++ b/net-analyzer/bigeye/bigeye-0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bigeye/bigeye-0.3.ebuild,v 1.1 2002/08/19 03:49:31 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Bigeye is a network utility dump and simple honeypot utility"
+HOMEPAGE="http://violating.us/projects/bigeye/"
+SRC_URI="http://violating.us/projects/bigeye/download/${P}.tgz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ cd ${S}/src
+ gcc ${CFLAGS} bigeye.c emulate.c -o bigeye -W
+
+}
+
+src_install() {
+
+ dobin src/bigeye
+
+ dodir /usr/share/bigeye/messages
+ insinto /usr/share/bigeye
+ doins sig.file
+
+ cp -r messages/* ${D}/usr/share/bigeye/messages
+
+ dodoc README
+
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo The service emulation files mentioned in the README are located in
+ einfo /usr/share/bigeye/messages.
+ einfo
+
+}
+
diff --git a/net-analyzer/bigeye/files/digest-bigeye-0.3 b/net-analyzer/bigeye/files/digest-bigeye-0.3
new file mode 100644
index 000000000000..0cae043a9fce
--- /dev/null
+++ b/net-analyzer/bigeye/files/digest-bigeye-0.3
@@ -0,0 +1 @@
+MD5 51c38aea3258273cc97d759f82218655 bigeye-0.3.tgz 32462