summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2014-06-06 02:38:43 +0000
committerRick Farina <zerochaos@gentoo.org>2014-06-06 02:38:43 +0000
commitd3f8a084ec4504d88b201289050b95a430d0b0f7 (patch)
tree50f7ece77c6cfa00d8049a4b6387f88d8488bacc /net-analyzer/cloudshark
parentVersion bump. (diff)
downloadgentoo-2-d3f8a084ec4504d88b201289050b95a430d0b0f7.tar.gz
gentoo-2-d3f8a084ec4504d88b201289050b95a430d0b0f7.tar.bz2
gentoo-2-d3f8a084ec4504d88b201289050b95a430d0b0f7.zip
bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-analyzer/cloudshark')
-rw-r--r--net-analyzer/cloudshark/ChangeLog9
-rw-r--r--net-analyzer/cloudshark/cloudshark-1.0.3.180.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/net-analyzer/cloudshark/ChangeLog b/net-analyzer/cloudshark/ChangeLog
index 052602c65c5f..8b77edaa6db0 100644
--- a/net-analyzer/cloudshark/ChangeLog
+++ b/net-analyzer/cloudshark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/cloudshark
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cloudshark/ChangeLog,v 1.4 2013/06/03 13:54:17 zerochaos Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cloudshark/ChangeLog,v 1.5 2014/06/06 02:38:43 zerochaos Exp $
+
+*cloudshark-1.0.3.180 (06 Jun 2014)
+
+ 06 Jun 2014; Rick Farina <zerochaos@gentoo.org> +cloudshark-1.0.3.180.ebuild:
+ bump
03 Jun 2013; Rick Farina <zerochaos@gentoo.org> cloudshark-1.0.2.174.ebuild:
adjusting some line lengths down for readability
diff --git a/net-analyzer/cloudshark/cloudshark-1.0.3.180.ebuild b/net-analyzer/cloudshark/cloudshark-1.0.3.180.ebuild
new file mode 100644
index 000000000000..3be4ea9be1ad
--- /dev/null
+++ b/net-analyzer/cloudshark/cloudshark-1.0.3.180.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cloudshark/cloudshark-1.0.3.180.ebuild,v 1.1 2014/06/06 02:38:43 zerochaos Exp $
+
+EAPI=5
+
+inherit eutils multilib
+
+SV="1.0.3-180"
+
+DESCRIPTION="Easily upload your wireshark captures to CloudShark"
+HOMEPAGE="http://appliance.cloudshark.org/plug-ins-wireshark.html"
+SRC_URI="http://appliance.cloudshark.org/plugin/${PN}-plugin-${SV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+PDEPEND="net-analyzer/wireshark:=[lua]
+ net-misc/curl"
+
+S="${WORKDIR}/${PN}-${SV}"
+
+get_PV() {
+ local pv=$(best_version $1)
+ pv=${pv#$1-}; pv=${pv%-r*}
+ pv=${pv//_}; echo ${pv}
+}
+
+src_prepare() {
+ #cloudshark isn't meant to be installed systemwide, we fix that
+ epatch "${FILESDIR}"/cs_log_dir.patch
+
+ sed -i "s#%s/cloudshark_init.lua#/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/cloudshark_init.lua#" cloudshark.lua
+ #causes errors, looks like it expects windows paths only
+ #echo "CLOUDSHARK_CABUNDLE = /usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/curl-ca-bundle.crt" >> cloudshark_init.default
+ sed -i "s#%s/curl-ca-bundle.crt#/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/curl-ca-bundle.crt#" cloudshark.lua
+
+ #stuff to fix cloudshark_init.default to be more sane
+ #sed -i 's#CLOUDSHARK_TSHARK = "n"#CLOUDSHARK_TSHARK = "y"#' cloudshark_init.default (tshark support doesn't seem to work)
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)
+ doins cloudshark.lua json.lua version.lua curl-ca-bundle.crt
+ newins cloudshark_init.default cloudshark_init.lua
+ dodoc CLOUDSHARK_README.txt
+}