summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-06-25 18:40:41 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-06-25 18:40:41 +0000
commit970b0894b34d1c875028c95dc794b70d1dc0430a (patch)
treef76a5114a4156a3b34f67b0ee2a670ff4d88d28d /net-analyzer/nagios
parentVersion bump (diff)
downloadgentoo-2-970b0894b34d1c875028c95dc794b70d1dc0430a.tar.gz
gentoo-2-970b0894b34d1c875028c95dc794b70d1dc0430a.tar.bz2
gentoo-2-970b0894b34d1c875028c95dc794b70d1dc0430a.zip
Version bump
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r5 x86_64)
Diffstat (limited to 'net-analyzer/nagios')
-rw-r--r--net-analyzer/nagios/ChangeLog8
-rw-r--r--net-analyzer/nagios/nagios-3.0.3.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/net-analyzer/nagios/ChangeLog b/net-analyzer/nagios/ChangeLog
index b18a9cf19908..a00f8df2e22a 100644
--- a/net-analyzer/nagios/ChangeLog
+++ b/net-analyzer/nagios/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nagios
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/ChangeLog,v 1.70 2008/06/08 16:31:25 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/ChangeLog,v 1.71 2008/06/25 18:40:41 dertobi123 Exp $
+
+*nagios-3.0.3 (25 Jun 2008)
+
+ 25 Jun 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +nagios-3.0.3.ebuild:
+ Version bump
08 Jun 2008; Tobias Scherbaum <dertobi123@gentoo.org> nagios-3.0.2.ebuild:
Add check if we are upgrading from <nagios-3.
diff --git a/net-analyzer/nagios/nagios-3.0.3.ebuild b/net-analyzer/nagios/nagios-3.0.3.ebuild
new file mode 100644
index 000000000000..593820611a73
--- /dev/null
+++ b/net-analyzer/nagios/nagios-3.0.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/nagios-3.0.3.ebuild,v 1.1 2008/06/25 18:40:41 dertobi123 Exp $
+
+DESCRIPTION="The Nagios metapackage - merge this to pull install all of the
+nagios packages"
+HOMEPAGE="http://www.nagios.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="~net-analyzer/nagios-core-${PV}
+ >=net-analyzer/nagios-plugins-1.4.12-r100
+ >=net-analyzer/nagios-imagepack-1.0-r100"
+
+pkg_setup() {
+ # Avoid upgrading from Nagios <3 as the directory structure has changed
+ if [[ -f /var/lib/init.d/started/nagios ]] ; then
+ if has_version '<net-analyzer/nagios-3.0' ; then
+ if [[ "${FORCE_UPGRADE}" ]] ; then
+ echo
+ ewarn "you are upgrading from an incompatible version and have"
+ ewarn "FORCE_UPGRADE set, will build this package while Nagios is running."
+ echo
+ else
+ echo
+ eerror "You are upgrading from an incompatible version."
+ eerror "Please be advised that installation paths have changed to a more FHS"
+ eerror "compliant structure and you won't be able to easily upgrade to"
+ eerror "Nagios 3 therefore. You will have to change your configuration"
+ eerror "to reflect this change, for example Nagios plugins are now installed"
+ eerror "into /usr/$(get_libdir)/nagios/plugins/ instead of /usr/nagios/libexec."
+ echo
+ eerror "If you want to upgrade now, emerge nagios with:"
+ eerror " FORCE_UPGRADE=1 emerge nagios"
+ die "Upgrading from an incompatible version!"
+ echo
+ fi
+ fi
+ fi
+}
+
+pkg_postrm() {
+ elog "Note: this is a META ebuild for ${P}."
+ elog "to remove it completely or before re-emerging"
+ elog "either use 'depclean', or remove/re-emerge these packages:"
+ elog
+ for dep in ${RDEPEND}; do
+ elog " ${dep}"
+ done
+ echo
+}