summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-12-25 10:40:22 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-12-25 10:40:22 +0000
commit5a3335b067df3da3b163bdbb6cb76a120c365342 (patch)
tree7b3df77de2877ad540165449ea5978bd771e1315 /net-analyzer/nmapsi
parentVersion bump. (diff)
downloadgentoo-2-5a3335b067df3da3b163bdbb6cb76a120c365342.tar.gz
gentoo-2-5a3335b067df3da3b163bdbb6cb76a120c365342.tar.bz2
gentoo-2-5a3335b067df3da3b163bdbb6cb76a120c365342.zip
Version bump, remove old.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 17A85C72)
Diffstat (limited to 'net-analyzer/nmapsi')
-rw-r--r--net-analyzer/nmapsi/ChangeLog8
-rw-r--r--net-analyzer/nmapsi/nmapsi-0.3.1.ebuild32
-rw-r--r--net-analyzer/nmapsi/nmapsi-0.4.ebuild44
3 files changed, 51 insertions, 33 deletions
diff --git a/net-analyzer/nmapsi/ChangeLog b/net-analyzer/nmapsi/ChangeLog
index f859840a5bab..a3941ed9d1be 100644
--- a/net-analyzer/nmapsi/ChangeLog
+++ b/net-analyzer/nmapsi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nmapsi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmapsi/ChangeLog,v 1.7 2012/08/31 17:59:02 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmapsi/ChangeLog,v 1.8 2012/12/25 10:40:22 pesa Exp $
+
+*nmapsi-0.4 (25 Dec 2012)
+
+ 25 Dec 2012; Davide Pesavento <pesa@gentoo.org> +nmapsi-0.4.ebuild,
+ -nmapsi-0.3.1.ebuild:
+ Version bump, remove old.
*nmapsi-0.3.2 (31 Aug 2012)
diff --git a/net-analyzer/nmapsi/nmapsi-0.3.1.ebuild b/net-analyzer/nmapsi/nmapsi-0.3.1.ebuild
deleted file mode 100644
index f317365607e1..000000000000
--- a/net-analyzer/nmapsi/nmapsi-0.3.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmapsi/nmapsi-0.3.1.ebuild,v 1.1 2012/05/07 21:13:54 kensington Exp $
-
-EAPI=4
-inherit base cmake-utils
-
-MY_P=${PN}4-${PV/_/-}
-
-DESCRIPTION="A Qt4 frontend to nmap"
-HOMEPAGE="http://www.nmapsi4.org/"
-SRC_URI="http://nmapsi4.googlecode.com/files/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-DEPEND="x11-libs/qt-core:4
- x11-libs/qt-dbus:4
- x11-libs/qt-gui:4
- x11-libs/qt-webkit:4"
-RDEPEND="${DEPEND}
- net-analyzer/nmap"
-
-S=${WORKDIR}/${MY_P}
-
-DOCS=( AUTHORS NEWS README TODO Translation )
-
-PATCHES=(
- "${FILESDIR}/${P}-gcc-4.7.patch"
-)
diff --git a/net-analyzer/nmapsi/nmapsi-0.4.ebuild b/net-analyzer/nmapsi/nmapsi-0.4.ebuild
new file mode 100644
index 000000000000..4b77358373b4
--- /dev/null
+++ b/net-analyzer/nmapsi/nmapsi-0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmapsi/nmapsi-0.4.ebuild,v 1.1 2012/12/25 10:40:22 pesa Exp $
+
+EAPI=5
+
+PLOCALES="ca cs de es fr it ru"
+
+inherit cmake-utils l10n
+
+MY_P=${PN}4-${PV}
+
+DESCRIPTION="A Qt4 frontend to nmap"
+HOMEPAGE="http://www.nmapsi4.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kde"
+
+DEPEND="
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-webkit:4
+ kde? ( kde-base/kdelibs:4 )
+"
+RDEPEND="${DEPEND}
+ >=net-analyzer/nmap-6.00
+ net-dns/bind-tools
+"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=(AUTHORS HACKING NEWS TODO Translation)
+
+src_prepare() {
+ l10n_for_each_disabled_locale_do nmapsi_disable_locale
+}
+
+nmapsi_disable_locale() {
+ sed -i -e "/ts\/${PN}4_${1}\.ts/d" src/CMakeLists.txt || die
+}