summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-22 07:37:52 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-22 07:37:52 +0000
commit3baa566ba8856cd3f84d1506298a3c4f359e8523 (patch)
tree4cc873b13ed5ac9d476256a5381e56df722438b4 /net-analyzer/openvas
parentapp-misc/devtodo: Correctly install bashcompletions, #526250 (diff)
downloadgentoo-2-3baa566ba8856cd3f84d1506298a3c4f359e8523.tar.gz
gentoo-2-3baa566ba8856cd3f84d1506298a3c4f359e8523.tar.bz2
gentoo-2-3baa566ba8856cd3f84d1506298a3c4f359e8523.zip
net-analyzer/openvas: Add postinst suggestions and add beta version
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'net-analyzer/openvas')
-rw-r--r--net-analyzer/openvas/ChangeLog9
-rw-r--r--net-analyzer/openvas/openvas-7-r2.ebuild44
-rw-r--r--net-analyzer/openvas/openvas-8_beta3.ebuild44
3 files changed, 96 insertions, 1 deletions
diff --git a/net-analyzer/openvas/ChangeLog b/net-analyzer/openvas/ChangeLog
index cb73a28fb887..088f377ac9d7 100644
--- a/net-analyzer/openvas/ChangeLog
+++ b/net-analyzer/openvas/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/openvas
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas/ChangeLog,v 1.19 2014/10/17 09:09:08 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas/ChangeLog,v 1.20 2014/10/22 07:37:52 jlec Exp $
+
+*openvas-8_beta3 (22 Oct 2014)
+*openvas-7-r2 (22 Oct 2014)
+
+ 22 Oct 2014; Justin Lecher <jlec@gentoo.org> +openvas-7-r2.ebuild,
+ +openvas-8_beta3.ebuild:
+ Add postinst suggestions and add beta version
17 Oct 2014; Justin Lecher <jlec@gentoo.org> openvas-7-r1.ebuild:
Add missing dependency on dev-texlive/texlive-latexextra, #525498
diff --git a/net-analyzer/openvas/openvas-7-r2.ebuild b/net-analyzer/openvas/openvas-7-r2.ebuild
new file mode 100644
index 000000000000..77e6e482e3e8
--- /dev/null
+++ b/net-analyzer/openvas/openvas-7-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas/openvas-7-r2.ebuild,v 1.1 2014/10/22 07:37:52 jlec Exp $
+
+EAPI=5
+
+inherit readme.gentoo
+
+DESCRIPTION="A remote security scanner"
+HOMEPAGE="http://www.openvas.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pdf"
+
+DEPEND="
+ >=net-analyzer/openvas-libraries-7.0.4-r1
+ >=net-analyzer/openvas-scanner-4.0.3-r2
+ >=net-analyzer/openvas-manager-5.0.4-r2
+ >=net-analyzer/openvas-cli-1.3.0-r1
+ net-analyzer/openvas-tools
+ >=net-analyzer/greenbone-security-assistant-5.0.3-r1
+ pdf? (
+ app-text/htmldoc
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ )"
+# greenbone-security-desktop is broken and unsupported upstream
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+pkg_postinst() {
+ elog "Additional support for extra checks can be get from"
+ optfeature "Nikto — a web server scanning and testing tool" net-analyzer/nikto
+ optfeature "NMAP — a portscanner" net-analyzer/nmap
+ optfeature "ike-scan - an IPsec VPN scanning, fingerprinting and testing tool" net-analyzer/ike-scan
+ optfeature "amap — an application protocol detection tool" net-analyzer/amap
+ optfeature "ldapsearch from OpenLDAP utilities — retrieves information from LDAP dictionaries" net-nds/openldap
+ optfeature "ovaldi (OVAL) — an OVAL Interpreter" app-forensics/ovaldi
+ optfeature "portbunny — a Linux-kernel-based portscanner" net-analyzer/portbunny
+ optfeature "w3af — a web application attack and audit framework" net-analyzer/w3af
+}
diff --git a/net-analyzer/openvas/openvas-8_beta3.ebuild b/net-analyzer/openvas/openvas-8_beta3.ebuild
new file mode 100644
index 000000000000..603b7b9cbe55
--- /dev/null
+++ b/net-analyzer/openvas/openvas-8_beta3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas/openvas-8_beta3.ebuild,v 1.1 2014/10/22 07:37:52 jlec Exp $
+
+EAPI=5
+
+inherit readme.gentoo
+
+DESCRIPTION="A remote security scanner"
+HOMEPAGE="http://www.openvas.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS=""
+IUSE="+pdf"
+
+DEPEND="
+ >=net-analyzer/openvas-libraries-8
+ >=net-analyzer/openvas-scanner-5
+ >=net-analyzer/openvas-manager-6
+ >=net-analyzer/openvas-cli-1.4
+ net-analyzer/openvas-tools
+ >=net-analyzer/greenbone-security-assistant-6
+ pdf? (
+ app-text/htmldoc
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ )"
+# greenbone-security-desktop is broken and unsupported upstream
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+pkg_postinst() {
+ elog "Additional support for extra checks can be get from"
+ optfeature "Nikto — a web server scanning and testing tool" net-analyzer/nikto
+ optfeature "NMAP — a portscanner" net-analyzer/nmap
+ optfeature "ike-scan - an IPsec VPN scanning, fingerprinting and testing tool" net-analyzer/ike-scan
+ optfeature "amap — an application protocol detection tool" net-analyzer/amap
+ optfeature "ldapsearch from OpenLDAP utilities — retrieves information from LDAP dictionaries" net-nds/openldap
+ optfeature "ovaldi (OVAL) — an OVAL Interpreter" app-forensics/ovaldi
+ optfeature "portbunny — a Linux-kernel-based portscanner" net-analyzer/portbunny
+ optfeature "w3af — a web application attack and audit framework" net-analyzer/w3af
+}