summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2011-04-11 18:41:28 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2011-04-11 18:41:28 +0000
commit33eb1895a26a1e2f0455b2fb9a153f471799ae58 (patch)
tree583c92ae4e9bc8d7cd8d7228d6aad9ceea32c6c9 /net-analyzer/pnp4nagios
parentversion bump (diff)
downloadgentoo-2-33eb1895a26a1e2f0455b2fb9a153f471799ae58.tar.gz
gentoo-2-33eb1895a26a1e2f0455b2fb9a153f471799ae58.tar.bz2
gentoo-2-33eb1895a26a1e2f0455b2fb9a153f471799ae58.zip
Version bump
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/pnp4nagios')
-rw-r--r--net-analyzer/pnp4nagios/ChangeLog11
-rw-r--r--net-analyzer/pnp4nagios/pnp4nagios-0.6.11.ebuild66
2 files changed, 75 insertions, 2 deletions
diff --git a/net-analyzer/pnp4nagios/ChangeLog b/net-analyzer/pnp4nagios/ChangeLog
index 5924f1048d84..55ceddd96e0c 100644
--- a/net-analyzer/pnp4nagios/ChangeLog
+++ b/net-analyzer/pnp4nagios/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/pnp4nagios
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.31 2010/10/31 15:15:30 dertobi123 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.32 2011/04/11 18:41:27 dertobi123 Exp $
+
+*pnp4nagios-0.6.11 (11 Apr 2011)
+
+ 11 Apr 2011; Tobias Scherbaum <dertobi123@gentoo.org>
+ +pnp4nagios-0.6.11.ebuild:
+ Version bump
+
31 Oct 2010; Tobias Scherbaum <dertobi123@gentoo.org>
pnp4nagios-0.6.7.ebuild:
diff --git a/net-analyzer/pnp4nagios/pnp4nagios-0.6.11.ebuild b/net-analyzer/pnp4nagios/pnp4nagios-0.6.11.ebuild
new file mode 100644
index 000000000000..40940d79794b
--- /dev/null
+++ b/net-analyzer/pnp4nagios/pnp4nagios-0.6.11.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/pnp4nagios-0.6.11.ebuild,v 1.1 2011/04/11 18:41:28 dertobi123 Exp $
+
+EAPI="2"
+
+inherit depend.apache eutils
+
+DESCRIPTION="A performance data analyzer for nagios"
+HOMEPAGE="http://www.pnp4nagios.org"
+
+SRC_URI="mirror://sourceforge/${PN}/PNP-0.6/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-lang/php[json,simplexml,zlib,xml,filter]
+ || ( <dev-lang/php-5.3[pcre,reflection,spl] >=dev-lang/php-5.3 )
+ || ( >=dev-lang/php-4.3[gd-external] >=dev-lang/php-4.3[gd] )
+ >=net-analyzer/rrdtool-1.2
+ net-analyzer/nagios-core"
+RDEPEND="${DEPEND}
+ virtual/perl-Getopt-Long
+ virtual/perl-Time-HiRes
+ media-fonts/dejavu
+ apache2? ( www-servers/apache[apache2_modules_rewrite] )"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.6.7-makefile.patch
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/pnp \
+ --datarootdir=/usr/share/pnp \
+ --with-perfdata-dir=/var/nagios/perfdata \
+ --with-perfdata-spool-dir=/var/spool/pnp || die "econf failed"
+}
+
+src_compile() {
+ emake all || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-unstripped install-config || die "emake install failed"
+ doinitd "${FILESDIR}/npcd"
+ rm "${D}/usr/share/pnp/install.php"
+
+ if use apache2 ; then
+ insinto "${APACHE_MODULES_CONFDIR}"
+ doins "${FILESDIR}"/98_pnp4nagios.conf
+ fi
+}
+
+pkg_postinst() {
+ elog "Please make sure to enable URL rewriting in Apache or any other"
+ elog "webserver you're using, to get pnp4nagios running!"
+}