summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Fitzgerald <gregf@gentoo.org>2003-07-29 01:36:52 +0000
committerGreg Fitzgerald <gregf@gentoo.org>2003-07-29 01:36:52 +0000
commitea4efa19e45b586a4af68216d04c8d5ddf115926 (patch)
treef88508af04abee1223ef85543f041b4ded8571e4 /net-analyzer/portmon
parentInitial Release. (diff)
downloadgentoo-2-ea4efa19e45b586a4af68216d04c8d5ddf115926.tar.gz
gentoo-2-ea4efa19e45b586a4af68216d04c8d5ddf115926.tar.bz2
gentoo-2-ea4efa19e45b586a4af68216d04c8d5ddf115926.zip
Initial Release.
Diffstat (limited to 'net-analyzer/portmon')
-rw-r--r--net-analyzer/portmon/ChangeLog11
-rw-r--r--net-analyzer/portmon/Manifest6
-rw-r--r--net-analyzer/portmon/files/digest-portmon-1.91
-rw-r--r--net-analyzer/portmon/files/portmon.init30
-rw-r--r--net-analyzer/portmon/portmon-1.9.ebuild34
5 files changed, 79 insertions, 3 deletions
diff --git a/net-analyzer/portmon/ChangeLog b/net-analyzer/portmon/ChangeLog
new file mode 100644
index 000000000000..78933c40f0ac
--- /dev/null
+++ b/net-analyzer/portmon/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-analyzer/portmon
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portmon/ChangeLog,v 1.1 2003/07/29 01:36:45 gregf Exp $
+
+*portmon-1.9 (28 Jul 2003)
+
+ 28 Jul 2003; Greg Fitzgerald <gregf@gentoo.org> portmon-1.9.ebuild,
+ files/portmon.init:
+ Initial Release. Closes bug #23475 Reported by Chuck Short
+ <chuck_short@rogers.com>
+
diff --git a/net-analyzer/portmon/Manifest b/net-analyzer/portmon/Manifest
index dbf00b2aad73..be71d4790c9f 100644
--- a/net-analyzer/portmon/Manifest
+++ b/net-analyzer/portmon/Manifest
@@ -1,4 +1,4 @@
-MD5 181f5111f329189984931c89573e7b02 portmon-1.9.ebuild 734
-MD5 d0c16937058c732535c6d12e32329c15 ChangeLog 338
+MD5 f7702ec668473a6ee69851f365768380 portmon-1.9.ebuild 835
+MD5 c0f3579368a2f23a18c438ed2088db6f ChangeLog 430
MD5 52e3317349da2a915781b132dba91d9f files/digest-portmon-1.9 63
-MD5 53879e94df6060abe23c7bab8ef63a05 files/portmon.init 699
+MD5 812c26d0945ff1608d35efefe7196442 files/portmon.init 801
diff --git a/net-analyzer/portmon/files/digest-portmon-1.9 b/net-analyzer/portmon/files/digest-portmon-1.9
new file mode 100644
index 000000000000..5c5b29947bb7
--- /dev/null
+++ b/net-analyzer/portmon/files/digest-portmon-1.9
@@ -0,0 +1 @@
+MD5 95ae1352fb6d877b36839a1f90fc2b81 portmon-1.9.tar.gz 143698
diff --git a/net-analyzer/portmon/files/portmon.init b/net-analyzer/portmon/files/portmon.init
new file mode 100644
index 000000000000..0cedcfc67536
--- /dev/null
+++ b/net-analyzer/portmon/files/portmon.init
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portmon/files/portmon.init,v 1.1 2003/07/29 01:36:45 gregf Exp $
+
+# configuration is done in /etc/pormon.sh
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -e /etc/portmon/portmon.hosts ]; then
+ error " You need /etc/portmon/portmaon.hosts to run portmon."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting portmon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/portmon -- -d -c /etc/portmon/portmon.hosts
+ eend $?
+}
+
+stop() {
+ checkconfig || return 1
+ ebegin "Staring portmon"
+ start-stop-daemon --stopt --quiet --exec /usr/sbin/portmon
+}
diff --git a/net-analyzer/portmon/portmon-1.9.ebuild b/net-analyzer/portmon/portmon-1.9.ebuild
new file mode 100644
index 000000000000..bb9347083ae0
--- /dev/null
+++ b/net-analyzer/portmon/portmon-1.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portmon/portmon-1.9.ebuild,v 1.1 2003/07/29 01:36:45 gregf Exp $
+
+DESCRIPTION="Portmon is a netwok service monitoring daemon."
+SRC_URI="http://aboleo.net/software/portmon/downloads/${P}.tar.gz"
+HOMEPAGE="http://aboleo.net/software/portmon/"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="virtual/glibc"
+RDEPEND="${RDEPEND}"
+
+src_compile() {
+ econf --sysconfdir=/etc/portmon || die "Configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ dosbin src/portmon
+ doman extras/portmon.8
+
+
+ insinto /etc/portmon
+ doins extras/portmon.hosts.sample
+ dodoc AUTHORS BUGS README
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/portmon.init portmon
+}