summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-06-19 20:27:01 +0000
committerJeroen Roovers <jer@gentoo.org>2012-06-19 20:27:01 +0000
commitcc48717ed111355f1b67a710e1e24f8f51577eb3 (patch)
treecdbb1b8f49f7e899628ad3ae6ca5d1eff2d74c28 /net-analyzer/sflowtool
parentPatch is upstreamed (diff)
downloadgentoo-2-cc48717ed111355f1b67a710e1e24f8f51577eb3.tar.gz
gentoo-2-cc48717ed111355f1b67a710e1e24f8f51577eb3.tar.bz2
gentoo-2-cc48717ed111355f1b67a710e1e24f8f51577eb3.zip
Version bump. Use append-cppflags not append-flags.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/sflowtool')
-rw-r--r--net-analyzer/sflowtool/ChangeLog8
-rw-r--r--net-analyzer/sflowtool/sflowtool-3.24.ebuild6
-rw-r--r--net-analyzer/sflowtool/sflowtool-3.25.ebuild6
-rw-r--r--net-analyzer/sflowtool/sflowtool-3.26.ebuild27
4 files changed, 40 insertions, 7 deletions
diff --git a/net-analyzer/sflowtool/ChangeLog b/net-analyzer/sflowtool/ChangeLog
index d9ff0fc617a1..8d9732f522e6 100644
--- a/net-analyzer/sflowtool/ChangeLog
+++ b/net-analyzer/sflowtool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/sflowtool
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sflowtool/ChangeLog,v 1.28 2012/06/12 03:01:23 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sflowtool/ChangeLog,v 1.29 2012/06/19 20:27:01 jer Exp $
+
+*sflowtool-3.26 (19 Jun 2012)
+
+ 19 Jun 2012; Jeroen Roovers <jer@gentoo.org> sflowtool-3.24.ebuild,
+ sflowtool-3.25.ebuild, +sflowtool-3.26.ebuild:
+ Version bump. Use append-cppflags not append-flags.
12 Jun 2012; Zac Medico <zmedico@gentoo.org> sflowtool-3.24.ebuild,
sflowtool-3.25.ebuild:
diff --git a/net-analyzer/sflowtool/sflowtool-3.24.ebuild b/net-analyzer/sflowtool/sflowtool-3.24.ebuild
index c2a71120ab0b..027af30c3b4c 100644
--- a/net-analyzer/sflowtool/sflowtool-3.24.ebuild
+++ b/net-analyzer/sflowtool/sflowtool-3.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sflowtool/sflowtool-3.24.ebuild,v 1.4 2012/06/12 03:01:23 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sflowtool/sflowtool-3.24.ebuild,v 1.5 2012/06/19 20:27:01 jer Exp $
EAPI=4
inherit autotools eutils flag-o-matic
@@ -22,6 +22,6 @@ src_prepare() {
}
src_configure() {
- append-flags -DSPOOFSOURCE
- econf
+ append-cppflags -DSPOOFSOURCE
+ default
}
diff --git a/net-analyzer/sflowtool/sflowtool-3.25.ebuild b/net-analyzer/sflowtool/sflowtool-3.25.ebuild
index 197b1bee3f97..558e85b8fcc9 100644
--- a/net-analyzer/sflowtool/sflowtool-3.25.ebuild
+++ b/net-analyzer/sflowtool/sflowtool-3.25.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sflowtool/sflowtool-3.25.ebuild,v 1.2 2012/06/12 03:01:23 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sflowtool/sflowtool-3.25.ebuild,v 1.3 2012/06/19 20:27:01 jer Exp $
EAPI=4
inherit autotools eutils flag-o-matic
@@ -22,6 +22,6 @@ src_prepare() {
}
src_configure() {
- append-flags -DSPOOFSOURCE
- econf
+ append-cppflags -DSPOOFSOURCE
+ default
}
diff --git a/net-analyzer/sflowtool/sflowtool-3.26.ebuild b/net-analyzer/sflowtool/sflowtool-3.26.ebuild
new file mode 100644
index 000000000000..77d6bfed3aa2
--- /dev/null
+++ b/net-analyzer/sflowtool/sflowtool-3.26.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sflowtool/sflowtool-3.26.ebuild,v 1.1 2012/06/19 20:27:01 jer Exp $
+
+EAPI=4
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="sflowtool is a utility for collecting and processing sFlow data"
+HOMEPAGE="http://www.inmon.com/technology/sflowTools.php"
+SRC_URI="http://www.inmon.com/bin/${P}.tar.gz"
+
+LICENSE="inmon-sflow"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.20-ctype-header.patch
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -DSPOOFSOURCE
+ default
+}