summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-07-17 15:07:44 +0000
committerJeroen Roovers <jer@gentoo.org>2014-07-17 15:07:44 +0000
commit6abfab8d500228cab705f1d5f5bcacb78161b03b (patch)
tree6314a99abb5d76dae47f4b4c4cf34206bf0e6e15 /net-analyzer/sqlninja
parentEAPI bump. Fix implicit declarations of setresgid, setresuid. (diff)
downloadgentoo-2-6abfab8d500228cab705f1d5f5bcacb78161b03b.tar.gz
gentoo-2-6abfab8d500228cab705f1d5f5bcacb78161b03b.tar.bz2
gentoo-2-6abfab8d500228cab705f1d5f5bcacb78161b03b.zip
EAPI bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/sqlninja')
-rw-r--r--net-analyzer/sqlninja/ChangeLog8
-rw-r--r--net-analyzer/sqlninja/sqlninja-0.2.6_p1-r1.ebuild29
-rw-r--r--net-analyzer/sqlninja/sqlninja-0.2.6_p1.ebuild52
3 files changed, 22 insertions, 67 deletions
diff --git a/net-analyzer/sqlninja/ChangeLog b/net-analyzer/sqlninja/ChangeLog
index 3d824b8c8317..47bdd4d7c0fd 100644
--- a/net-analyzer/sqlninja/ChangeLog
+++ b/net-analyzer/sqlninja/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/sqlninja
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sqlninja/ChangeLog,v 1.2 2012/12/09 00:39:50 zerochaos Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sqlninja/ChangeLog,v 1.3 2014/07/17 15:07:43 jer Exp $
+
+ 17 Jul 2014; Jeroen Roovers <jer@gentoo.org> -sqlninja-0.2.6_p1.ebuild,
+ sqlninja-0.2.6_p1-r1.ebuild:
+ EAPI bump.
*sqlninja-0.2.6_p1-r1 (09 Dec 2012)
diff --git a/net-analyzer/sqlninja/sqlninja-0.2.6_p1-r1.ebuild b/net-analyzer/sqlninja/sqlninja-0.2.6_p1-r1.ebuild
index 1406936b42d2..201b0a6115ce 100644
--- a/net-analyzer/sqlninja/sqlninja-0.2.6_p1-r1.ebuild
+++ b/net-analyzer/sqlninja/sqlninja-0.2.6_p1-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sqlninja/sqlninja-0.2.6_p1-r1.ebuild,v 1.1 2012/12/09 00:39:50 zerochaos Exp $
-
-EAPI=4
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sqlninja/sqlninja-0.2.6_p1-r1.ebuild,v 1.2 2014/07/17 15:07:43 jer Exp $
+EAPI=5
inherit versionator
MY_PV="$(replace_version_separator 3 '-')"
@@ -18,34 +17,38 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
-DEPEND=""
-RDEPEND="dev-lang/perl
- dev-perl/NetPacket
- dev-perl/Net-Pcap
+RDEPEND="
+ dev-lang/perl
+ dev-perl/IO-Socket-SSL
+ dev-perl/List-MoreUtils
dev-perl/Net-DNS
+ dev-perl/Net-Pcap
dev-perl/Net-RawIP
- dev-perl/IO-Socket-SSL
- dev-perl/List-MoreUtils"
+ dev-perl/NetPacket
+"
S="${WORKDIR}/${MY_P}"
src_install () {
dodoc sqlninja-howto.html ChangeLog README
+
if use doc; then
dodoc -r sources
docompress -x /usr/share/doc/"${P}"/sources
fi
+
insinto /etc/"${PN}"
doins sqlninja.conf.example
- rm -r sources sqlninja-howto.html ChangeLog README LICENSE || die 'removing docs failed'
- rm -r apps || die 'removing bundles apps failed'
- rm sqlninja.conf.example || die 'removing config failed'
+ rm -r sources sqlninja-howto.html ChangeLog README LICENSE || die
+ rm -r apps || die
+ rm sqlninja.conf.example || die
dodir /usr/lib/"${PN}"
insinto /usr/lib/"${PN}"
exeinto /usr/lib/"${PN}"
doins -r *
+
doexe sqlninja
dosbin "${FILESDIR}"/"${PN}"
}
diff --git a/net-analyzer/sqlninja/sqlninja-0.2.6_p1.ebuild b/net-analyzer/sqlninja/sqlninja-0.2.6_p1.ebuild
deleted file mode 100644
index f70c95bba019..000000000000
--- a/net-analyzer/sqlninja/sqlninja-0.2.6_p1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sqlninja/sqlninja-0.2.6_p1.ebuild,v 1.1 2012/10/06 13:13:46 pinkbyte Exp $
-
-EAPI=4
-
-inherit versionator
-
-MY_PV="$(replace_version_separator 3 '-')"
-MY_PV="${MY_PV/p/r}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="A SQL Server injection & takeover tool"
-HOMEPAGE="http://sqlninja.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND=""
-RDEPEND="dev-lang/perl
- dev-perl/NetPacket
- dev-perl/Net-Pcap
- dev-perl/Net-DNS
- dev-perl/Net-RawIP
- dev-perl/IO-Socket-SSL
- dev-perl/List-MoreUtils"
-
-S="${WORKDIR}/${MY_P}"
-
-src_install () {
- dodoc sqlninja-howto.html ChangeLog README
- if use doc; then
- dodoc -r sources
- docompress -x /usr/share/doc/"${P}"/sources
- fi
- insinto /etc/"${PN}"
- doins sqlninja.conf.example
-
- rm -r sources sqlninja-howto.html ChangeLog README LICENSE || die 'removing docs failed'
- rm -r apps || die 'removing bundles apps failed'
- rm sqlninja.conf.example || die 'removing config failed'
-
- dodir /usr/lib/"${PN}"
- insinto /usr/lib/"${PN}"
- exeinto /usr/lib/"${PN}"
- doins -r *
- doexe sqlninja
- dosbin "${FILESDIR}"/"${PN}"
- dosym /usr/lib/"${PN}"/makescr.pl /usr/sbin/makescr.pl
-}