summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-01-04 02:43:23 +0000
committerTim Harder <radhermit@gentoo.org>2012-01-04 02:43:23 +0000
commit80e9ed1e24d2906e5f51cf0093af17d182f8bd7d (patch)
tree30d4ee7e7f886583201bc9c877faad4c877a5973 /net-analyzer/tcpdump
parentVersion bump. (diff)
downloadgentoo-2-80e9ed1e24d2906e5f51cf0093af17d182f8bd7d.tar.gz
gentoo-2-80e9ed1e24d2906e5f51cf0093af17d182f8bd7d.tar.bz2
gentoo-2-80e9ed1e24d2906e5f51cf0093af17d182f8bd7d.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/tcpdump')
-rw-r--r--net-analyzer/tcpdump/ChangeLog9
-rw-r--r--net-analyzer/tcpdump/tcpdump-4.2.1.ebuild87
2 files changed, 94 insertions, 2 deletions
diff --git a/net-analyzer/tcpdump/ChangeLog b/net-analyzer/tcpdump/ChangeLog
index d4aa10471fec..3448d4efbbb2 100644
--- a/net-analyzer/tcpdump/ChangeLog
+++ b/net-analyzer/tcpdump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/tcpdump
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/ChangeLog,v 1.148 2011/12/17 14:22:46 jer Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/ChangeLog,v 1.149 2012/01/04 02:43:23 radhermit Exp $
+
+*tcpdump-4.2.1 (04 Jan 2012)
+
+ 04 Jan 2012; Tim Harder <radhermit@gentoo.org> +tcpdump-4.2.1.ebuild:
+ Version bump.
17 Dec 2011; Jeroen Roovers <jer@gentoo.org> tcpdump-4.2.0.ebuild,
+files/tcpdump-4.2.0-ipv6.patch:
diff --git a/net-analyzer/tcpdump/tcpdump-4.2.1.ebuild b/net-analyzer/tcpdump/tcpdump-4.2.1.ebuild
new file mode 100644
index 000000000000..36ddd503cf40
--- /dev/null
+++ b/net-analyzer/tcpdump/tcpdump-4.2.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-4.2.1.ebuild,v 1.1 2012/01/04 02:43:23 radhermit Exp $
+
+EAPI="4"
+inherit flag-o-matic
+
+DESCRIPTION="A Tool for network monitoring and data acquisition"
+HOMEPAGE="http://www.tcpdump.org/"
+SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
+ http://www.jp.tcpdump.org/release/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="+chroot smi ssl ipv6 -samba suid test"
+
+RDEPEND="
+ net-libs/libpcap
+ smi? ( net-libs/libsmi )
+ ssl? ( >=dev-libs/openssl-0.9.6m )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ || ( app-arch/sharutils sys-freebsd/freebsd-ubin )
+ dev-lang/perl
+ )
+"
+
+pkg_setup() {
+ if use samba ; then
+ ewarn
+ ewarn "CAUTION !!! CAUTION !!! CAUTION"
+ ewarn
+ ewarn "You're about to compile tcpdump with samba printing support"
+ ewarn "Upstream tags it as 'possibly-buggy SMB printer'"
+ ewarn "So think twice whether this is fine with you"
+ ewarn
+ ewarn "CAUTION !!! CAUTION !!! CAUTION"
+ ewarn
+ fi
+ enewgroup tcpdump
+ enewuser tcpdump -1 -1 -1 tcpdump
+}
+
+src_configure() {
+ # tcpdump needs some optymalization. see bug #108391
+ ( ! is-flag -O? || is-flag -O0 ) && append-flags -O2
+
+ replace-flags -O[3-9] -O2
+ filter-flags -finline-functions
+
+ econf \
+ --with-user=tcpdump \
+ $(use_with ssl crypto) \
+ $(use_with smi) \
+ $(use_enable ipv6) \
+ $(use_enable samba smb) \
+ $(use_with chroot chroot /var/lib/tcpdump)
+}
+
+src_test() {
+ sed '/^\(espudp1\|eapon1\)/d;' -i tests/TESTLIST
+ emake check
+}
+
+src_install() {
+ dosbin tcpdump
+ doman tcpdump.1
+ dodoc *.awk
+ dodoc CHANGES CREDITS README
+
+ if use chroot; then
+ keepdir /var/lib/tcpdump
+ fperms 700 /var/lib/tcpdump
+ fowners tcpdump:tcpdump /var/lib/tcpdump
+ fi
+ if use suid; then
+ fowners root:tcpdump /usr/sbin/tcpdump
+ fperms 4110 /usr/sbin/tcpdump
+ fi
+}
+
+pkg_postinst() {
+ use suid && elog "To let normal users run tcpdump add them into tcpdump group."
+}