summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-09-24 11:57:15 +0000
committerJeroen Roovers <jer@gentoo.org>2012-09-24 11:57:15 +0000
commitefeb07a9307edb5b5bacc9bfaf4009cfbf694820 (patch)
tree891a6df4f5389d5f792b171f3853e8c2de984a06 /net-analyzer
parentx86 stable, see bug 409541 (diff)
downloadgentoo-2-efeb07a9307edb5b5bacc9bfaf4009cfbf694820.tar.gz
gentoo-2-efeb07a9307edb5b5bacc9bfaf4009cfbf694820.tar.bz2
gentoo-2-efeb07a9307edb5b5bacc9bfaf4009cfbf694820.zip
Fix building with python3 (bug #435460 by Lars Wendler).
(Portage version: 2.2.0_alpha131/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/ChangeLog6
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.8.2-python3.patch62
-rw-r--r--net-analyzer/wireshark/wireshark-1.8.2-r2.ebuild3
-rw-r--r--net-analyzer/wireshark/wireshark-1.8.2-r3.ebuild3
4 files changed, 71 insertions, 3 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index fad5ab693c06..a46fde0d5a27 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.396 2012/09/23 17:31:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.397 2012/09/24 11:57:15 jer Exp $
+
+ 24 Sep 2012; Jeroen Roovers <jer@gentoo.org> wireshark-1.8.2-r2.ebuild,
+ wireshark-1.8.2-r3.ebuild, +files/wireshark-1.8.2-python3.patch:
+ Fix building with python3 (bug #435460 by Lars Wendler).
23 Sep 2012; Raúl Porcel <armin76@gentoo.org> wireshark-1.6.10-r2.ebuild,
wireshark-1.8.2-r2.ebuild:
diff --git a/net-analyzer/wireshark/files/wireshark-1.8.2-python3.patch b/net-analyzer/wireshark/files/wireshark-1.8.2-python3.patch
new file mode 100644
index 000000000000..380580e0216b
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.8.2-python3.patch
@@ -0,0 +1,62 @@
+------------------------------------------------------------------------
+r43940 | morriss | 2012-07-23 13:04:37 -0400 (Mon, 23 Jul 2012) | 1 line
+
+Get rid of non-ASCII chars. Also replace tabs with spaces and remove trailing white space.
+
+Index: epan/dissectors/packet-gtpv2.c
+===================================================================
+--- epan/dissectors/packet-gtpv2.c (revision 43939)
++++ epan/dissectors/packet-gtpv2.c (revision 43940)
+@@ -2233,7 +2233,7 @@
+ static void
+ dissect_gtpv2_bearer_ctx(tvbuff_t *tvb, packet_info *pinfo, proto_tree *tree _U_, proto_item *item, guint16 length _U_, guint8 message_type _U_, guint8 instance _U_)
+ {
+- int offset = 0;
++ int offset = 0;
+ tvbuff_t *new_tvb;
+ proto_tree *grouped_tree;
+
+@@ -5884,13 +5884,13 @@
+ FT_BYTES, BASE_NONE, NULL, 0x0,
+ NULL, HFILL}
+ },
+- /* Bit 1 – PVI (Pre-emption Vulnerability): See 3GPP TS 29.212[29],
+- * clause 5.3.47 Pre-emption-Vulnerability AVP.
+- * 5.3.47 Pre-emption-Vulnerability AVP
+- * The following values are defined:
+- * PRE-EMPTION_VULNERABILITY_ENABLED (0)
+- * PRE-EMPTION_VULNERABILITY_DISABLED (1)
+- */
++ /* Bit 1 - PVI (Pre-emption Vulnerability): See 3GPP TS 29.212[29],
++ * clause 5.3.47 Pre-emption-Vulnerability AVP.
++ * 5.3.47 Pre-emption-Vulnerability AVP
++ * The following values are defined:
++ * PRE-EMPTION_VULNERABILITY_ENABLED (0)
++ * PRE-EMPTION_VULNERABILITY_DISABLED (1)
++ */
+ {&hf_gtpv2_bearer_qos_pvi,
+ {"PVI (Pre-emption Vulnerability)", "gtpv2.bearer_qos_pvi",
+ FT_BOOLEAN, 8, TFS(&tfs_disabled_enabled), 0x01,
+@@ -5901,13 +5901,13 @@
+ FT_UINT8, BASE_DEC, NULL, 0x3c,
+ NULL, HFILL}
+ },
+- /* Bit 7 – PCI (Pre-emption Capability): See 3GPP TS 29.212[29], clause 5.3.46 Pre-emption-Capability AVP.
+- * clause 5.3.46 Pre-emption-Capability AVP.
+- * 5.3.46 Pre-emption-Capability AVP
+- * The following values are defined:
+- * PRE-EMPTION_CAPABILITY_ENABLED (0)
+- * PRE-EMPTION_CAPABILITY_DISABLED (1)
+- */
++ /* Bit 7 - PCI (Pre-emption Capability): See 3GPP TS 29.212[29], clause 5.3.46 Pre-emption-Capability AVP.
++ * clause 5.3.46 Pre-emption-Capability AVP.
++ * 5.3.46 Pre-emption-Capability AVP
++ * The following values are defined:
++ * PRE-EMPTION_CAPABILITY_ENABLED (0)
++ * PRE-EMPTION_CAPABILITY_DISABLED (1)
++ */
+ {&hf_gtpv2_bearer_qos_pci,
+ {"PCI (Pre-emption Capability)", "gtpv2.bearer_qos_pci",
+ FT_BOOLEAN, 8, TFS(&tfs_disabled_enabled), 0x40,
+
+------------------------------------------------------------------------
diff --git a/net-analyzer/wireshark/wireshark-1.8.2-r2.ebuild b/net-analyzer/wireshark/wireshark-1.8.2-r2.ebuild
index d2d7fc358d2a..04ca44c0cc85 100644
--- a/net-analyzer/wireshark/wireshark-1.8.2-r2.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.8.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.8.2-r2.ebuild,v 1.5 2012/09/23 17:31:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.8.2-r2.ebuild,v 1.6 2012/09/24 11:57:15 jer Exp $
EAPI="4"
PYTHON_DEPEND="python? 2"
@@ -108,6 +108,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.8.1-ldflags.patch
epatch "${FILESDIR}"/${PN}-1.8.2-CVE-2012-3548.patch
+ epatch "${FILESDIR}"/${PN}-1.8.2-python3.patch
sed -i -e 's|.png||g' ${PN}.desktop || die
eautoreconf
}
diff --git a/net-analyzer/wireshark/wireshark-1.8.2-r3.ebuild b/net-analyzer/wireshark/wireshark-1.8.2-r3.ebuild
index d50746ae8c1b..dc3154fd36f9 100644
--- a/net-analyzer/wireshark/wireshark-1.8.2-r3.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.8.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.8.2-r3.ebuild,v 1.1 2012/09/22 02:41:02 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.8.2-r3.ebuild,v 1.2 2012/09/24 11:57:15 jer Exp $
EAPI="4"
PYTHON_DEPEND="python? 2"
@@ -108,6 +108,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.8.1-ldflags.patch
epatch "${FILESDIR}"/${PN}-1.8.2-CVE-2012-3548.patch
+ epatch "${FILESDIR}"/${PN}-1.8.2-python3.patch
sed -i -e 's|.png||g' ${PN}.desktop || die
eautoreconf
}