summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-12 18:01:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-12 18:01:30 +0000
commit6bdfad91ae8108b6d32d592f6117543f4af3c7f3 (patch)
treed3383d2d494bc7c76bf9cc7f41fa2063ca26846b /net-dialup/capisuite
parentRemove hardcoded gst-plugins-gconf dep wrt #269594, if it's missing it will p... (diff)
downloadgentoo-2-6bdfad91ae8108b6d32d592f6117543f4af3c7f3.tar.gz
gentoo-2-6bdfad91ae8108b6d32d592f6117543f4af3c7f3.tar.bz2
gentoo-2-6bdfad91ae8108b6d32d592f6117543f4af3c7f3.zip
Fix from friendly administrator, use -2 instead of -w in SOX parameters wrt #250320.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup/capisuite')
-rw-r--r--net-dialup/capisuite/ChangeLog11
-rw-r--r--net-dialup/capisuite/capisuite-0.4.5-r6.ebuild95
-rw-r--r--net-dialup/capisuite/files/capisuite-0.4.5-sox.patch12
3 files changed, 116 insertions, 2 deletions
diff --git a/net-dialup/capisuite/ChangeLog b/net-dialup/capisuite/ChangeLog
index 516cfdb97a7e..77fce6448100 100644
--- a/net-dialup/capisuite/ChangeLog
+++ b/net-dialup/capisuite/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/capisuite
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capisuite/ChangeLog,v 1.34 2009/02/14 23:27:19 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capisuite/ChangeLog,v 1.35 2009/05/12 18:01:29 ssuominen Exp $
+
+*capisuite-0.4.5-r6 (12 May 2009)
+
+ 12 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +capisuite-0.4.5-r6.ebuild, +files/capisuite-0.4.5-sox.patch:
+ Fix from friendly administrator, use -2 instead of -w in SOX parameters
+ wrt #250320.
14 Feb 2009; Markus Meier <maekke@gentoo.org> capisuite-0.4.5-r5.ebuild:
amd64/x86 stable, bug #245571
diff --git a/net-dialup/capisuite/capisuite-0.4.5-r6.ebuild b/net-dialup/capisuite/capisuite-0.4.5-r6.ebuild
new file mode 100644
index 000000000000..e34a05c9c48a
--- /dev/null
+++ b/net-dialup/capisuite/capisuite-0.4.5-r6.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capisuite/capisuite-0.4.5-r6.ebuild,v 1.1 2009/05/12 18:01:29 ssuominen Exp $
+
+inherit eutils autotools flag-o-matic multilib python
+
+DESCRIPTION="ISDN telecommunication suite providing fax and voice services"
+HOMEPAGE="http://www.capisuite.de"
+SRC_URI="http://www.capisuite.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/python
+ media-sound/sox
+ >=media-libs/tiff-3.7.1
+ media-gfx/jpeg2ps
+ media-gfx/sfftobmp
+ virtual/ghostscript
+ net-dialup/capi4k-utils"
+RDEPEND="${DEPEND}
+ virtual/mta"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+
+ # taken from capisuite-0.4.5-5.src.rpm (SuSE-9.3)
+ epatch "${FILESDIR}/${P}-capi4linux_v3.diff"
+
+ # patched scripts/cs_helpers.pyin (bug #96540)
+ epatch "${FILESDIR}/${P}-date-header.patch"
+
+ # patched src/backend/connection.cpp (bug #69522)
+ epatch "${FILESDIR}/${PN}-fax-compatibility.patch"
+
+ # patched scripts/{incoming,idle}.py (bug #147854)
+ epatch "${FILESDIR}/${P}-syntax.patch"
+
+ # GCC 4.3 patches (bug #236777)
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+
+ # Python 2.5 patches (bug #232734)
+ epatch "${FILESDIR}/${P}-python25.patch"
+
+ # Compability with current SOX (bug #250320)
+ epatch "${FILESDIR}/${P}-sox.patch"
+
+ # run autotools
+ eautoreconf
+}
+
+src_compile() {
+ strip-flags # see bug #90901
+
+ econf --localstatedir=/var \
+ --with-docdir="/usr/share/doc/${PF}" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed."
+
+ rm -f "${D}"/usr/{lib,share}/capisuite/README
+ rmdir -p --ignore-fail-on-non-empty "${D}/var/log"
+ rm -f "${D}/usr/share/doc/${PF}"/{COPYING,manual.pdf}
+ keepdir /var/spool/capisuite/{done,failed,sendq,users}
+
+ dodir /etc/init.d
+ newinitd "${FILESDIR}/capisuite.initd" capisuite
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/capisuite.logrotated" capisuite
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ exeinto /etc/cron.daily
+ doexe capisuite.cron
+
+ insinto /etc/capisuite
+ doins cronjob.conf
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/cs_helpers.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}
diff --git a/net-dialup/capisuite/files/capisuite-0.4.5-sox.patch b/net-dialup/capisuite/files/capisuite-0.4.5-sox.patch
new file mode 100644
index 000000000000..ef58325ff6e9
--- /dev/null
+++ b/net-dialup/capisuite/files/capisuite-0.4.5-sox.patch
@@ -0,0 +1,12 @@
+diff -ur capisuite-0.4.5.orig/scripts/cs_helpers.pyin capisuite-0.4.5/scripts/cs_helpers.pyin
+--- capisuite-0.4.5.orig/scripts/cs_helpers.pyin 2004-11-28 15:35:23.000000000 +0200
++++ capisuite-0.4.5/scripts/cs_helpers.pyin 2009-05-12 20:58:34.000000000 +0300
+@@ -227,7 +227,7 @@
+ elif (mail_type=="la"): # voice file
+ # la -> wav
+ # don't use stdout as sox needs a file to be able to seek in it otherwise the header will be incomplete
+- ret = os.spawnlp(os.P_WAIT,"sox","sox",attachment,"-w",basename+"wav")
++ ret = os.spawnlp(os.P_WAIT,"sox","sox",attachment,"-2",basename+"wav")
+ if (ret or not os.access(basename+"wav",os.R_OK)):
+ raise "conv-error","Error while calling sox. Not installed?"
+ filepart = email.MIMEAudio.MIMEAudio(open(basename+"wav").read(),"x-wav",email.Encoders.encode_base64,name=os.path.basename(basename)+"wav")