summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-30 01:27:42 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-30 01:27:42 +0000
commite360bdd9f8601d3cc700921acf8ef5a000ee5c7d (patch)
treeaa8d249813887c6d7adb134c241e798f73d56bb2 /net-dialup/fcdsl
parentfixing string.h problem (see bug #202385). (diff)
downloadgentoo-2-e360bdd9f8601d3cc700921acf8ef5a000ee5c7d.tar.gz
gentoo-2-e360bdd9f8601d3cc700921acf8ef5a000ee5c7d.tar.bz2
gentoo-2-e360bdd9f8601d3cc700921acf8ef5a000ee5c7d.zip
fixing string.h problem (see bug #202385) + patches for kernel 2.6.24 (thanks to Arnd Feldmueller <arnd.feldmueller@web.de>).
(Portage version: 2.1.4)
Diffstat (limited to 'net-dialup/fcdsl')
-rw-r--r--net-dialup/fcdsl/ChangeLog9
-rw-r--r--net-dialup/fcdsl/fcdsl-0.1-r1.ebuild55
-rw-r--r--net-dialup/fcdsl/files/digest-fcdsl-0.1-r13
-rw-r--r--net-dialup/fcdsl/files/fcdsl_kernel-2.6.24.diff35
4 files changed, 101 insertions, 1 deletions
diff --git a/net-dialup/fcdsl/ChangeLog b/net-dialup/fcdsl/ChangeLog
index 9d3c96a3717d..6774298280bd 100644
--- a/net-dialup/fcdsl/ChangeLog
+++ b/net-dialup/fcdsl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/fcdsl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdsl/ChangeLog,v 1.35 2008/01/06 01:35:57 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdsl/ChangeLog,v 1.36 2008/01/30 01:27:42 sbriesen Exp $
+
+*fcdsl-0.1-r1 (30 Jan 2008)
+
+ 30 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/fcdsl_kernel-2.6.24.diff, +fcdsl-0.1-r1.ebuild:
+ fixing string.h problem (see bug #202385) + patches for kernel 2.6.24
+ (thanks to Arnd Feldmueller <arnd.feldmueller@web.de>).
06 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org>
-files/fcdsl-2.6.20.diff, -files/fcdslslusb-2.6.20.diff,
diff --git a/net-dialup/fcdsl/fcdsl-0.1-r1.ebuild b/net-dialup/fcdsl/fcdsl-0.1-r1.ebuild
new file mode 100644
index 000000000000..6da9492f68f2
--- /dev/null
+++ b/net-dialup/fcdsl/fcdsl-0.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdsl/fcdsl-0.1-r1.ebuild,v 1.1 2008/01/30 01:27:42 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Fritz!Card DSL PCI"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="net-dialup/capi4k-utils"
+
+S="${WORKDIR}/fritz"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack ${PN}-suse[0-9][0-9]-[0-9].[0-9]*-[0-9]*.tar.gz
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[01234]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+ epatch "${FILESDIR}/${PN}_kernel-2.6.24.diff"
+ convert_to_m src/Makefile
+
+ for i in lib/*-lib.o; do
+ einfo "Localize symbols in ${i##*/} ..."
+ objcopy -L memcmp -L memcpy -L memmove -L memset -L strcat \
+ -L strcmp -L strcpy -L strlen -L strncmp -L strncpy "${i}"
+ done
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /lib/firmware/isdn
+ doins *.bin
+ dodoc CAPI*.txt
+ dohtml *.html
+}
diff --git a/net-dialup/fcdsl/files/digest-fcdsl-0.1-r1 b/net-dialup/fcdsl/files/digest-fcdsl-0.1-r1
new file mode 100644
index 000000000000..2a62b5c51d8d
--- /dev/null
+++ b/net-dialup/fcdsl/files/digest-fcdsl-0.1-r1
@@ -0,0 +1,3 @@
+MD5 efb65ee7a21571155219e3896579378a fcdsl-0.1-0.src.rpm 1792277
+RMD160 16cb511dffe8e9d773b382713da8fcca2b2be0b8 fcdsl-0.1-0.src.rpm 1792277
+SHA256 00f2a5b3abb072edc00447308b4680b044efbcbd9d8844060a36509c9cc3064c fcdsl-0.1-0.src.rpm 1792277
diff --git a/net-dialup/fcdsl/files/fcdsl_kernel-2.6.24.diff b/net-dialup/fcdsl/files/fcdsl_kernel-2.6.24.diff
new file mode 100644
index 000000000000..2e619365e360
--- /dev/null
+++ b/net-dialup/fcdsl/files/fcdsl_kernel-2.6.24.diff
@@ -0,0 +1,35 @@
+--- src/driver.c.orig 2008-01-27 05:30:34.000000000 +0100
++++ src/driver.c 2008-01-27 05:30:34.000000000 +0100
+@@ -111,7 +111,10 @@
+
+ static DECLARE_WAIT_QUEUE_HEAD(wait);
+ static DECLARE_WAIT_QUEUE_HEAD(capi_wait);
++static DECLARE_COMPLETION(thread_sync); /* New DECLARE, <arnd.feldmueller@web.de> */
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ static DECLARE_MUTEX_LOCKED(hotplug);
++#endif
+
+ #define SCHED_WAKEUP_CAPI { atomic_set (&thread_capi_flag, 1); wake_up_interruptible (&capi_wait); }
+ #define SCHED_WAKEUP { atomic_set (&got_kicked, 1); wake_up_interruptible (&wait); }
+@@ -1367,7 +1371,10 @@
+ }
+ }
+ LOG("Scheduler thread stopped.\n");
++ complete(&thread_sync); /* Complete Thread Sync here <arnd.feldmueller@web.de> */
++ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ up (&hotplug);
++ #endif
+ return 0;
+ } /* sched_thread */
+
+@@ -1401,7 +1410,10 @@
+ SCHED_WAKEUP;
+ }
+ LOG("Thread signalled, waiting for termination...\n");
++ wait_for_completion(&thread_sync); /* Wait for complete Thread Sync <arnd.feldmueller@web.de> */
++ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ down (&hotplug);
++ #endif
+ LOG("Thread[%d] terminated.\n", thread_pid);
+ }
+ thread_pid = -1;