summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-05-28 18:35:25 +0000
committerAlin Năstac <mrness@gentoo.org>2007-05-28 18:35:25 +0000
commite467428bfb9ba699fcc570c324ed91312f37ede9 (patch)
treef08bfb651a2c2f6345f331617cc8030349eabc50 /net-dialup/minicom
parentStable on alpha wrt security #175847 (diff)
downloadgentoo-2-e467428bfb9ba699fcc570c324ed91312f37ede9.tar.gz
gentoo-2-e467428bfb9ba699fcc570c324ed91312f37ede9.tar.bz2
gentoo-2-e467428bfb9ba699fcc570c324ed91312f37ede9.zip
Remove sgid bit and uucp group from minicom executable (#180120).
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-dialup/minicom')
-rw-r--r--net-dialup/minicom/ChangeLog7
-rw-r--r--net-dialup/minicom/files/digest-minicom-2.2-r13
-rw-r--r--net-dialup/minicom/minicom-2.2-r1.ebuild47
3 files changed, 56 insertions, 1 deletions
diff --git a/net-dialup/minicom/ChangeLog b/net-dialup/minicom/ChangeLog
index af1cab18aa66..502d1b0567b4 100644
--- a/net-dialup/minicom/ChangeLog
+++ b/net-dialup/minicom/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/minicom
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/ChangeLog,v 1.48 2007/05/12 08:03:45 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/ChangeLog,v 1.49 2007/05/28 18:35:25 mrness Exp $
+
+*minicom-2.2-r1 (28 May 2007)
+
+ 28 May 2007; Alin Năstac <mrness@gentoo.org> +minicom-2.2-r1.ebuild:
+ Remove sgid bit and uucp group from minicom executable (#180120).
12 May 2007; Joshua Kinard <kumba@gentoo.org> minicom-2.2.ebuild:
Stable on mips.
diff --git a/net-dialup/minicom/files/digest-minicom-2.2-r1 b/net-dialup/minicom/files/digest-minicom-2.2-r1
new file mode 100644
index 000000000000..958a4ac5684f
--- /dev/null
+++ b/net-dialup/minicom/files/digest-minicom-2.2-r1
@@ -0,0 +1,3 @@
+MD5 13933c8777839f00e3730df23599dc93 minicom-2.2.tar.gz 720536
+RMD160 2796e731078507160c466e952f3c9f6144b9c3f4 minicom-2.2.tar.gz 720536
+SHA256 cc0406714ece77f5b1b1cb9e85e937531de556a72f962a3532c02da41b154d64 minicom-2.2.tar.gz 720536
diff --git a/net-dialup/minicom/minicom-2.2-r1.ebuild b/net-dialup/minicom/minicom-2.2-r1.ebuild
new file mode 100644
index 000000000000..fc670e8b3f57
--- /dev/null
+++ b/net-dialup/minicom/minicom-2.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/minicom-2.2-r1.ebuild,v 1.1 2007/05/28 18:35:25 mrness Exp $
+
+inherit eutils flag-o-matic
+
+STUPID_NUM="1806"
+
+DESCRIPTION="Serial Communication Program"
+HOMEPAGE="http://alioth.debian.org/projects/minicom"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2-r3"
+RDEPEND="${DEPEND}
+ net-dialup/lrzsz"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo-runscript.patch
+ epatch "${FILESDIR}"/${P}-one-off.patch
+}
+
+src_compile() {
+ # avoid lazy binding (minicom is sgided)
+ append-ldflags $(bindnow-flags)
+ econf --sysconfdir=/etc/${PN} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "einstall failed"
+
+ dodoc AUTHORS ChangeLog NEWS README doc/minicom.FAQ
+ insinto /etc/minicom
+ doins "${FILESDIR}"/minirc.dfl
+}
+
+pkg_preinst() {
+ [[ -s /etc/minicom/minirc.dfl ]] \
+ && rm -f "${D}"/etc/minicom/minirc.dfl
+}