summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-11-07 16:05:25 +0000
committerSven Wegener <swegener@gentoo.org>2005-11-07 16:05:25 +0000
commit21c1921a2f03c846b71c168774b4f53c02740d6f (patch)
tree8d687bb4e2843c7f226ec69cd4af82722855a6be /net-dns
parentRemoved COPYING and INSTALL from dodoc. (diff)
downloadgentoo-2-21c1921a2f03c846b71c168774b4f53c02740d6f.tar.gz
gentoo-2-21c1921a2f03c846b71c168774b4f53c02740d6f.tar.bz2
gentoo-2-21c1921a2f03c846b71c168774b4f53c02740d6f.zip
Make the pygtk support dependant on the gtk USE flag in addition to the python USE flag.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/avahi/ChangeLog7
-rw-r--r--net-dns/avahi/avahi-0.5.2-r1.ebuild10
-rw-r--r--net-dns/avahi/avahi-0.5.2.ebuild10
3 files changed, 22 insertions, 5 deletions
diff --git a/net-dns/avahi/ChangeLog b/net-dns/avahi/ChangeLog
index c12d8f371467..3441c686d179 100644
--- a/net-dns/avahi/ChangeLog
+++ b/net-dns/avahi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/avahi
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.16 2005/11/04 07:33:32 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.17 2005/11/07 16:05:25 swegener Exp $
+
+ 07 Nov 2005; Sven Wegener <swegener@gentoo.org> avahi-0.5.2.ebuild,
+ avahi-0.5.2-r1.ebuild:
+ Make the pygtk support dependant on the gtk USE flag in addition to the
+ python USE flag.
*avahi-0.5.2-r1 (04 Nov 2005)
diff --git a/net-dns/avahi/avahi-0.5.2-r1.ebuild b/net-dns/avahi/avahi-0.5.2-r1.ebuild
index a4ba37740066..3d6c9518ddf9 100644
--- a/net-dns/avahi/avahi-0.5.2-r1.ebuild
+++ b/net-dns/avahi/avahi-0.5.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.5.2-r1.ebuild,v 1.1 2005/11/04 07:33:32 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.5.2-r1.ebuild,v 1.2 2005/11/07 16:05:25 swegener Exp $
inherit eutils qt3 mono
@@ -26,7 +26,7 @@ RDEPEND="dev-libs/libdaemon
>=sys-apps/dbus-0.30
python? (
>=virtual/python-2.4
- >=dev-python/pygtk-2
+ gtk? ( >=dev-python/pygtk-2 )
)
)"
DEPEND="${RDEPEND}
@@ -53,6 +53,11 @@ src_compile() {
if use python && use dbus
then
myconf="${myconf} --enable-python"
+
+ if use gtk
+ then
+ myconf="${myconf} --enable-pygtk"
+ fi
fi
if use mono && use doc
@@ -64,6 +69,7 @@ src_compile() {
--localstatedir=/var \
--with-distro=gentoo \
--disable-python \
+ --disable-pygtk \
--disable-qt4 \
--disable-xmltoman \
--disable-mono-docs \
diff --git a/net-dns/avahi/avahi-0.5.2.ebuild b/net-dns/avahi/avahi-0.5.2.ebuild
index 3334514689d1..f7db6162a72f 100644
--- a/net-dns/avahi/avahi-0.5.2.ebuild
+++ b/net-dns/avahi/avahi-0.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.5.2.ebuild,v 1.2 2005/11/04 07:23:58 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.5.2.ebuild,v 1.3 2005/11/07 16:05:25 swegener Exp $
inherit eutils qt3 mono
@@ -26,7 +26,7 @@ RDEPEND="dev-libs/libdaemon
>=sys-apps/dbus-0.30
python? (
>=virtual/python-2.4
- >=dev-python/pygtk-2
+ gtk? ( >=dev-python/pygtk-2 )
)
)"
DEPEND="${RDEPEND}
@@ -53,12 +53,18 @@ src_compile() {
if use python && use dbus
then
myconf="${myconf} --enable-python"
+
+ if use gtk
+ then
+ myconf="${myconf} --enable-pygtk"
+ fi
fi
econf \
--localstatedir=/var \
--with-distro=gentoo \
--disable-python \
+ --disable-pygtk \
--disable-qt4 \
--disable-xmltoman \
--disable-mono-docs \