summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-01-07 14:36:59 +0000
committerMichael Weber <xmw@gentoo.org>2015-01-07 14:36:59 +0000
commite98f557c2bf2a766ec5124b13a4ee2ca83c10734 (patch)
treefea927f4406c2bf9ef6923c7efd5e605185f8e10 /net-dns
parentRemove old, install localizations properly (bug #535760) (diff)
downloadgentoo-2-e98f557c2bf2a766ec5124b13a4ee2ca83c10734.tar.gz
gentoo-2-e98f557c2bf2a766ec5124b13a4ee2ca83c10734.tar.bz2
gentoo-2-e98f557c2bf2a766ec5124b13a4ee2ca83c10734.zip
Version bump by Hendrik v. Raven.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnstop/ChangeLog9
-rw-r--r--net-dns/dnstop/dnstop-20140915.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/net-dns/dnstop/ChangeLog b/net-dns/dnstop/ChangeLog
index ff7e127ae338..f19c48164f7e 100644
--- a/net-dns/dnstop/ChangeLog
+++ b/net-dns/dnstop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/dnstop
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnstop/ChangeLog,v 1.42 2014/08/10 20:42:23 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnstop/ChangeLog,v 1.43 2015/01/07 14:36:59 xmw Exp $
+
+*dnstop-20140915 (07 Jan 2015)
+
+ 07 Jan 2015; Michael Weber <xmw@gentoo.org> +dnstop-20140915.ebuild:
+ Version bump by Hendrik v. Raven.
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> dnstop-20110502.ebuild,
dnstop-20121017.ebuild:
diff --git a/net-dns/dnstop/dnstop-20140915.ebuild b/net-dns/dnstop/dnstop-20140915.ebuild
new file mode 100644
index 000000000000..c4c2d0fb3d81
--- /dev/null
+++ b/net-dns/dnstop/dnstop-20140915.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnstop/dnstop-20140915.ebuild,v 1.1 2015/01/07 14:36:59 xmw Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Displays various tables of DNS traffic on your network"
+HOMEPAGE="http://dnstop.measurement-factory.com/"
+SRC_URI="http://dnstop.measurement-factory.com/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE="ipv6"
+
+RDEPEND="sys-libs/ncurses
+ net-libs/libpcap[ipv6?]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ $(use_enable ipv6)
+}
+
+src_install() {
+ dobin dnstop
+ doman dnstop.8
+ dodoc CHANGES
+}