summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-01-27 19:21:01 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-01-27 19:21:01 +0000
commit5afe2050618f4a35ee9a0c2b6715d0597bf1b7a1 (patch)
tree3328d3bfe9e71d2a1fecc690cbe0ef5131a9cb5d /net-firewall/shorewall-perl
parentVersion bump, thanks to Vieri for the notification in bug #196695 (diff)
downloadgentoo-2-5afe2050618f4a35ee9a0c2b6715d0597bf1b7a1.tar.gz
gentoo-2-5afe2050618f4a35ee9a0c2b6715d0597bf1b7a1.tar.bz2
gentoo-2-5afe2050618f4a35ee9a0c2b6715d0597bf1b7a1.zip
Version bump, thanks to Vieri for the notification in bug #196695
(Portage version: 2.1.4)
Diffstat (limited to 'net-firewall/shorewall-perl')
-rw-r--r--net-firewall/shorewall-perl/ChangeLog10
-rw-r--r--net-firewall/shorewall-perl/files/digest-shorewall-perl-4.0.83
-rw-r--r--net-firewall/shorewall-perl/shorewall-perl-4.0.8.ebuild53
3 files changed, 64 insertions, 2 deletions
diff --git a/net-firewall/shorewall-perl/ChangeLog b/net-firewall/shorewall-perl/ChangeLog
index 964d5a143b45..afc89845ada2 100644
--- a/net-firewall/shorewall-perl/ChangeLog
+++ b/net-firewall/shorewall-perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall-perl
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/ChangeLog,v 1.9 2007/09/14 12:07:53 fmccor Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/ChangeLog,v 1.10 2008/01/27 19:21:00 jokey Exp $
+
+*shorewall-perl-4.0.8 (27 Jan 2008)
+
+ 27 Jan 2008; Markus Ullmann <jokey@gentoo.org>
+ +shorewall-perl-4.0.8.ebuild:
+ Version bump, thanks to Vieri for the notification in bug #196695
14 Sep 2007; Ferris McCormick <fmccor@gentoo.org>
shorewall-perl-4.0.3.ebuild:
diff --git a/net-firewall/shorewall-perl/files/digest-shorewall-perl-4.0.8 b/net-firewall/shorewall-perl/files/digest-shorewall-perl-4.0.8
new file mode 100644
index 000000000000..d600ab1b533c
--- /dev/null
+++ b/net-firewall/shorewall-perl/files/digest-shorewall-perl-4.0.8
@@ -0,0 +1,3 @@
+MD5 803fc822644ff7b7788050ebb1a2ee63 shorewall-perl-4.0.8.tar.bz2 101852
+RMD160 f9b00b2286f9bc5a22851df4cfe3439297d96ad2 shorewall-perl-4.0.8.tar.bz2 101852
+SHA256 047328b79d62ac7e7da3bc2b43c5348174fd61c2db5b1154f0a8dd1179f811e8 shorewall-perl-4.0.8.tar.bz2 101852
diff --git a/net-firewall/shorewall-perl/shorewall-perl-4.0.8.ebuild b/net-firewall/shorewall-perl/shorewall-perl-4.0.8.ebuild
new file mode 100644
index 000000000000..a8f4c258c41e
--- /dev/null
+++ b/net-firewall/shorewall-perl/shorewall-perl-4.0.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/shorewall-perl-4.0.8.ebuild,v 1.1 2008/01/27 19:21:00 jokey Exp $
+
+# Choose between experimental, stable and beta:
+#MY_P_TREE="development/4.0" # experimental and beta
+MY_P_TREE="4.0" # stable
+#MY_P_BETA="-Beta7" # only beta
+MY_P_BETA="" # stable or experimental
+
+MY_P="shorewall-${PV}"
+
+DESCRIPTION="Shoreline Firewall Perl-based compiler that allows faster compilation and execution."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2
+ dev-lang/perl
+ !<net-firewall/shorewall-4.0"
+
+PDEPEND="~net-firewall/shorewall-common-${PV}"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ dodoc releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo
+ einfo "In order to use the Perl compiler you need to add"
+ einfo "SHOREWALL_COMPILER=perl"
+ einfo "to shorewall.conf"
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/known_problems.txt"
+ einfo
+}