summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-06-28 08:15:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-06-28 08:15:58 +0000
commit8095c80454c152edd7781ea26fe35d0241e435da (patch)
tree7ae822f74a655c0e0bf3a9fc662024c977f57606 /net-fs
parentmarked x86 per bug 423895 (diff)
downloadgentoo-2-8095c80454c152edd7781ea26fe35d0241e435da.tar.gz
gentoo-2-8095c80454c152edd7781ea26fe35d0241e435da.tar.bz2
gentoo-2-8095c80454c152edd7781ea26fe35d0241e435da.zip
Bump
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/cifs-utils/ChangeLog8
-rw-r--r--net-fs/cifs-utils/cifs-utils-5.5.ebuild85
2 files changed, 91 insertions, 2 deletions
diff --git a/net-fs/cifs-utils/ChangeLog b/net-fs/cifs-utils/ChangeLog
index c7b51b8fbed6..ddffa8adc59a 100644
--- a/net-fs/cifs-utils/ChangeLog
+++ b/net-fs/cifs-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/cifs-utils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/ChangeLog,v 1.23 2012/06/20 20:17:40 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/ChangeLog,v 1.24 2012/06/28 08:15:58 patrick Exp $
+
+*cifs-utils-5.5 (28 Jun 2012)
+
+ 28 Jun 2012; Patrick Lauer <patrick@gentoo.org> +cifs-utils-5.5.ebuild:
+ Bump
20 Jun 2012; Markus Meier <maekke@gentoo.org> cifs-utils-5.4.ebuild:
arm stable, bug #420895
@@ -94,4 +99,3 @@
Initial import, ebuild based on work from Ewoud Kohl van Wijngaarden
<gentoo@kohlvanwijngaarden.nl> and Sebastiaan <s.breedveld@erasmusmc.nl>
bug 308655
-
diff --git a/net-fs/cifs-utils/cifs-utils-5.5.ebuild b/net-fs/cifs-utils/cifs-utils-5.5.ebuild
new file mode 100644
index 000000000000..54124210a8ec
--- /dev/null
+++ b/net-fs/cifs-utils/cifs-utils-5.5.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/cifs-utils-5.5.ebuild,v 1.1 2012/06/28 08:15:58 patrick Exp $
+
+EAPI=4
+
+inherit eutils confutils linux-info
+
+DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
+HOMEPAGE="http://www.samba.org/linux-cifs/cifs-utils/"
+SRC_URI="ftp://ftp.samba.org/pub/linux-cifs/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ads +caps caps-ng creds upcall"
+
+DEPEND="!net-fs/mount-cifs
+ !<net-fs/samba-3.6_rc1
+ ads? ( sys-libs/talloc virtual/krb5 sys-apps/keyutils )
+ caps? ( sys-libs/libcap )
+ caps-ng? ( sys-libs/libcap-ng )
+ creds? ( sys-apps/keyutils )
+ upcall? ( sys-apps/keyutils sys-libs/talloc virtual/krb5 )"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="^^ ( caps caps-ng )"
+
+pkg_setup() {
+ confutils_use_conflict caps caps-ng
+ if ! linux_config_exists || ! linux_chkconfig_present CIFS; then
+ ewarn "You must enable CIFS support in your kernel config, "
+ ewarn "to be able to mount samba shares. You can find it at"
+ ewarn
+ ewarn " File systems"
+ ewarn " Network File Systems"
+ ewarn " CIFS support"
+ ewarn
+ ewarn "and recompile your kernel ..."
+ fi
+}
+
+src_prepare() {
+ #Getting rid of -Werror
+ sed -e "s/-Werror//" -i Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ local myconf=''
+ if use "caps-ng"; then
+ myconf="${myconf} --with-libcap-ng=yes "
+ else
+ myconf="${myconf} --with-libcap-ng=no "
+ fi
+ myconf="${myconf} \
+ $(use_enable ads cifsupcall) \
+ $(use_with caps libcap) \
+ $(use_with caps-ng libcap-ng) \
+ $(use_enable creds cifscreds) \
+ $(use_enable upcall cifsupcall) \
+ --disable-cifsidmap \
+ --disable-cifsacl"
+ econf ${myconf}
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc doc/linux-cifs-client-guide.odt
+}
+
+pkg_postinst() {
+ # Inform about set-user-ID bit of mount.cifs
+ ewarn "setuid use flag was dropped due to multiple security implications"
+ ewarn "such as CVE-2009-2948, CVE-2011-3585 and CVE-2012-1586"
+ ewarn "You are free to set setuid flags by yourself"
+
+ # Inform about upcall usage
+ if use ads ; then
+ ewarn "Using mount.cifs in combination with keyutils"
+ ewarn "in order to mount DFS shares, you need to add"
+ ewarn "the following line to /etc/request-key.conf:"
+ ewarn " create dns_resolver * * /usr/sbin/cifs.upcall %k"
+ ewarn "Otherwise, your DFS shares will not work properly."
+ fi
+}