summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-31 07:46:45 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-31 07:46:45 +0000
commitf4138be9b9a1f51df44a836c367ec60ba936de23 (patch)
tree9b396b93da84455406c5cc5d191051de0ae9e1ec /net-im/psimedia
parentMove back to versioned virtuals as discussed on dev ml. So chop chop with mig... (diff)
downloadgentoo-2-f4138be9b9a1f51df44a836c367ec60ba936de23.tar.gz
gentoo-2-f4138be9b9a1f51df44a836c367ec60ba936de23.tar.bz2
gentoo-2-f4138be9b9a1f51df44a836c367ec60ba936de23.zip
Remove support for V4L v1 because linux-headers-2.6.38 stopped shipping linux/videodev.h.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'net-im/psimedia')
-rw-r--r--net-im/psimedia/ChangeLog7
-rw-r--r--net-im/psimedia/files/psimedia-1.0.3-linux-headers-2.6.38.patch86
-rw-r--r--net-im/psimedia/psimedia-1.0.3-r1.ebuild5
-rw-r--r--net-im/psimedia/psimedia-1.0.3.ebuild5
4 files changed, 97 insertions, 6 deletions
diff --git a/net-im/psimedia/ChangeLog b/net-im/psimedia/ChangeLog
index 1f3998f51c15..dc42f62b5446 100644
--- a/net-im/psimedia/ChangeLog
+++ b/net-im/psimedia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/psimedia
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psimedia/ChangeLog,v 1.15 2011/02/01 06:34:35 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psimedia/ChangeLog,v 1.16 2011/03/31 07:46:45 ssuominen Exp $
+
+ 31 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> psimedia-1.0.3-r1.ebuild,
+ +files/psimedia-1.0.3-linux-headers-2.6.38.patch:
+ Remove support for V4L v1 because linux-headers-2.6.38 stopped shipping
+ linux/videodev.h.
*psimedia-1.0.3-r1 (01 Feb 2011)
diff --git a/net-im/psimedia/files/psimedia-1.0.3-linux-headers-2.6.38.patch b/net-im/psimedia/files/psimedia-1.0.3-linux-headers-2.6.38.patch
new file mode 100644
index 000000000000..b6076d12cbf2
--- /dev/null
+++ b/net-im/psimedia/files/psimedia-1.0.3-linux-headers-2.6.38.patch
@@ -0,0 +1,86 @@
+http://pkgs.fedoraproject.org/gitweb/?p=psimedia.git;a=blob_plain;f=psimedia-remove-v4l.patch;hb=HEAD
+
+--- gstprovider/deviceenum/deviceenum_unix.cpp
++++ gstprovider/deviceenum/deviceenum_unix.cpp
+@@ -35,7 +35,7 @@
+ # include <sys/stat.h>
+ # include <dirent.h>
+ # include <sys/ioctl.h>
+-# include <linux/videodev.h>
++# include <linux/videodev2.h>
+ #endif
+
+ namespace DeviceEnum {
+@@ -478,72 +478,7 @@
+ // v4l detection scheme adapted from PWLib (used by Ekiga/Gnomemeeting)
+ static QList<Item> get_v4l_items()
+ {
+-#ifdef Q_OS_LINUX
+- QList<Item> out;
+-
+- QList<V4LName> list = get_v4l_names("/sys/class/video4linux", true);
+- if(list.isEmpty())
+- list = get_v4l_names("/proc/video/dev", false);
+-
+- // if we can't find anything, then do a raw scan for possibilities
+- if(list.isEmpty())
+- {
+- QStringList possible = scan_for_videodevs("/dev");
+- foreach(QString str, possible)
+- {
+- V4LName v;
+- v.dev = str;
+- list += v;
+- }
+- }
+-
+- for(int n = 0; n < list.count(); ++n)
+- {
+- V4LName &v = list[n];
+-
+- // if we already have a friendly name then we'll skip the confirm
+- // in order to save resources. the only real drawback here that
+- // I can think of is if the device isn't a capture type. but
+- // what does it mean to have a V4L device that isn't capture??
+- if(v.friendlyName.isEmpty())
+- {
+- int fd = open(QFile::encodeName(v.dev).data(), O_RDONLY | O_NONBLOCK);
+- if(fd == -1)
+- continue;
+-
+- // get video capabilities and close
+- struct video_capability caps;
+- memset(&caps, 0, sizeof(caps));
+- int ret = ioctl(fd, VIDIOCGCAP, &caps);
+- close(fd);
+- if(ret == -1)
+- continue;
+-
+- if(!(caps.type & VID_TYPE_CAPTURE))
+- continue;
+-
+- v.friendlyName = caps.name;
+- }
+-
+- Item i;
+- i.type = Item::Video;
+- i.dir = Item::Input;
+- i.name = v.friendlyName;
+- i.driver = "v4l";
+- i.id = v.dev;
+-
+- // HACK
+- if(v.friendlyName == "Labtec Webcam Notebook")
+- i.explicitCaptureSize = QSize(640, 480);
+-
+- out += i;
+- }
+-
+- return out;
+-#else
+- // return empty list if non-linux
+ return QList<Item>();
+-#endif
+ }
+
+ static QList<Item> get_v4l2_items()
diff --git a/net-im/psimedia/psimedia-1.0.3-r1.ebuild b/net-im/psimedia/psimedia-1.0.3-r1.ebuild
index 563c8ac70f5e..5379f9a07cc4 100644
--- a/net-im/psimedia/psimedia-1.0.3-r1.ebuild
+++ b/net-im/psimedia/psimedia-1.0.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psimedia/psimedia-1.0.3-r1.ebuild,v 1.2 2011/02/04 21:23:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psimedia/psimedia-1.0.3-r1.ebuild,v 1.3 2011/03/31 07:46:45 ssuominen Exp $
EAPI="2"
@@ -29,7 +29,6 @@ RDEPEND="${COMMON_DEPEND}
>=media-plugins/gst-plugins-theora-0.10.22
>=media-plugins/gst-plugins-alsa-0.10.22
>=media-plugins/gst-plugins-ogg-0.10.22
- >=media-plugins/gst-plugins-v4l-0.10.22
media-plugins/gst-plugins-v4l2
media-plugins/gst-plugins-jpeg
!<net-im/psi-0.13_rc1
@@ -42,6 +41,8 @@ src_prepare() {
sed -e '/^TEMPLATE/a CONFIG += ordered' -i psimedia.pro || die
# Don't build demo if we don't need that.
use demo || { sed -e '/^SUBDIRS[[:space:]]*+=[[:space:]]*demo[[:space:]]*$/d;' -i psimedia.pro || die; }
+ # Remove support for V4L v1 because linux-headers-2.6.38 stopped shipping linux/videodev.h.
+ epatch "${FILESDIR}"/${P}-linux-headers-2.6.38.patch
}
src_configure() {
diff --git a/net-im/psimedia/psimedia-1.0.3.ebuild b/net-im/psimedia/psimedia-1.0.3.ebuild
index a0ec97187b86..c5a357c5bb11 100644
--- a/net-im/psimedia/psimedia-1.0.3.ebuild
+++ b/net-im/psimedia/psimedia-1.0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psimedia/psimedia-1.0.3.ebuild,v 1.10 2010/11/06 19:04:49 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psimedia/psimedia-1.0.3.ebuild,v 1.11 2011/03/31 07:46:45 ssuominen Exp $
EAPI="2"
@@ -30,7 +30,6 @@ RDEPEND="${DEPEND}
>=media-plugins/gst-plugins-theora-0.10.22
>=media-plugins/gst-plugins-alsa-0.10.22
>=media-plugins/gst-plugins-ogg-0.10.22
- >=media-plugins/gst-plugins-v4l-0.10.22
media-plugins/gst-plugins-v4l2
media-plugins/gst-plugins-jpeg
!<net-im/psi-0.13_rc1