summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-31 19:13:48 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-31 19:13:48 +0000
commitefc79e45d6219d1ce2a03b019968bd1e7042706c (patch)
tree01c1eb6d27e276572a30b3e982613c3b79f1de7d /net-irc
parentAdded a version that supports minor version slotting (diff)
downloadgentoo-2-efc79e45d6219d1ce2a03b019968bd1e7042706c.tar.gz
gentoo-2-efc79e45d6219d1ce2a03b019968bd1e7042706c.tar.bz2
gentoo-2-efc79e45d6219d1ce2a03b019968bd1e7042706c.zip
Disable support for pysqlite.
(Portage version: 2.2.0_alpha2_p3/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/supybot/ChangeLog6
-rw-r--r--net-irc/supybot/supybot-0.83.4.1-r1.ebuild35
2 files changed, 22 insertions, 19 deletions
diff --git a/net-irc/supybot/ChangeLog b/net-irc/supybot/ChangeLog
index 1be7a3b083e5..5168d664af29 100644
--- a/net-irc/supybot/ChangeLog
+++ b/net-irc/supybot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/supybot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot/ChangeLog,v 1.36 2010/04/04 21:01:51 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot/ChangeLog,v 1.37 2010/10/31 19:13:48 arfrever Exp $
+
+ 31 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ supybot-0.83.4.1-r1.ebuild:
+ Disable support for pysqlite.
04 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
supybot-0.83.4.1-r1.ebuild:
diff --git a/net-irc/supybot/supybot-0.83.4.1-r1.ebuild b/net-irc/supybot/supybot-0.83.4.1-r1.ebuild
index 90aca5a25a11..a5caa5980008 100644
--- a/net-irc/supybot/supybot-0.83.4.1-r1.ebuild
+++ b/net-irc/supybot/supybot-0.83.4.1-r1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot/supybot-0.83.4.1-r1.ebuild,v 1.6 2010/04/04 21:01:51 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot/supybot-0.83.4.1-r1.ebuild,v 1.7 2010/10/31 19:13:48 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
@@ -18,35 +19,33 @@ SRC_URI="mirror://sourceforge/supybot/${MY_P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
-IUSE="sqlite twisted"
+IUSE="twisted"
-DEPEND="twisted? ( >=dev-python/twisted-8.1.0[crypt]
- >=dev-python/twisted-names-8.1.0 )
- sqlite? ( <dev-python/pysqlite-1.1 )
+DEPEND="twisted? (
+ >=dev-python/twisted-8.1.0[crypt]
+ >=dev-python/twisted-names-8.1.0
+ )
!<net-irc/supybot-plugins-20060723-r1"
RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="3.*"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
DOCS="ACKS RELNOTES docs/*"
src_install() {
distutils_src_install
- doman docs/man/*
+ doman docs/man/* || die "doman failed"
}
pkg_postinst() {
distutils_pkg_postinst
- elog "Use supybot-wizard to create a configuration file"
- use sqlite || \
- elog "Some plugins may require emerge with USE=\"sqlite\" to work."
- use twisted && \
- elog "If you want to use Twisted as your supybot.driver, add it to your"
- elog "config file: supybot.drivers.module = Twisted."
- elog "You will need this for SSL connections"
- use twisted || \
- elog "To allow supybot to use Twisted as driver, re-emerge with"
- elog "USE=\"twisted\" flag. You will need this for SSL Connections"
+ elog "Use supybot-wizard to create a configuration file."
+ if use twisted; then
+ elog "If you want to use Twisted as your supybot.driver, add it to your config file:"
+ elog "supybot.drivers.module = Twisted"
+ else
+ elog "To allow supybot to use Twisted as driver, reinstall supybot with \"twisted\" USE flag enabled."
+ fi
+ elog "You will need this for SSL connections."
}