summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2014-05-13 12:31:24 +0000
committerTony Vroon <chainsaw@gentoo.org>2014-05-13 12:31:24 +0000
commit1d8704ebc89655752bab7a75fa80a784574105cc (patch)
tree9ebf523a7de531f09f0f85e01428c9920d5082be /net-libs/iax
parentStop trying to tiptoe around the autotools eclass and just use it correctly. ... (diff)
downloadgentoo-2-1d8704ebc89655752bab7a75fa80a784574105cc.tar.gz
gentoo-2-1d8704ebc89655752bab7a75fa80a784574105cc.tar.bz2
gentoo-2-1d8704ebc89655752bab7a75fa80a784574105cc.zip
Squelch debugging in a slightly cleaner way. Fix MD5 memset as per GCC warning.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'net-libs/iax')
-rw-r--r--net-libs/iax/ChangeLog9
-rw-r--r--net-libs/iax/files/0.2.2-debug.patch21
-rw-r--r--net-libs/iax/files/0.2.2-memset.patch12
-rw-r--r--net-libs/iax/iax-0.2.2-r3.ebuild (renamed from net-libs/iax/iax-0.2.2-r2.ebuild)4
4 files changed, 44 insertions, 2 deletions
diff --git a/net-libs/iax/ChangeLog b/net-libs/iax/ChangeLog
index f80c1240196d..951466a9973a 100644
--- a/net-libs/iax/ChangeLog
+++ b/net-libs/iax/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/iax
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/iax/ChangeLog,v 1.13 2014/05/13 11:55:30 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/iax/ChangeLog,v 1.14 2014/05/13 12:31:24 chainsaw Exp $
+
+*iax-0.2.2-r3 (13 May 2014)
+
+ 13 May 2014; Tony Vroon <chainsaw@gentoo.org> -iax-0.2.2-r2.ebuild,
+ +iax-0.2.2-r3.ebuild, +files/0.2.2-debug.patch, +files/0.2.2-memset.patch:
+ Squelch debugging in a slightly cleaner way. Fix MD5 memset as per GCC
+ warning.
*iax-0.2.2-r2 (13 May 2014)
diff --git a/net-libs/iax/files/0.2.2-debug.patch b/net-libs/iax/files/0.2.2-debug.patch
new file mode 100644
index 000000000000..68efdfdd237a
--- /dev/null
+++ b/net-libs/iax/files/0.2.2-debug.patch
@@ -0,0 +1,21 @@
+diff -uNr iax-0.2.2.ORIG/configure.in iax-0.2.2/configure.in
+--- iax-0.2.2.ORIG/configure.in 2014-05-13 13:23:35.083867921 +0100
++++ iax-0.2.2/configure.in 2014-05-13 13:24:25.879870451 +0100
+@@ -25,6 +25,8 @@
+ fi
+
+ if test "$enable_extreme_debug" = yes ; then
++ AC_DEFINE(DEBUG_SUPPORT)
++ AC_DEFINE(DEBUG_DEFAULT)
+ AC_DEFINE(EXTREME_DEBUG)
+ fi
+
+diff -uNr iax-0.2.2.ORIG/src/Makefile.am iax-0.2.2/src/Makefile.am
+--- iax-0.2.2.ORIG/src/Makefile.am 2014-05-13 13:23:35.082867921 +0100
++++ iax-0.2.2/src/Makefile.am 2014-05-13 13:24:32.439870777 +0100
+@@ -1,5 +1,4 @@
+ CFLAGS += -g -Wall -Wstrict-prototypes -I .
+-CFLAGS += -DDEBUG_SUPPORT -DDEBUG_DEFAULT
+ CFLAGS += $(UCFLAGS)
+
+
diff --git a/net-libs/iax/files/0.2.2-memset.patch b/net-libs/iax/files/0.2.2-memset.patch
new file mode 100644
index 000000000000..08408eef98f7
--- /dev/null
+++ b/net-libs/iax/files/0.2.2-memset.patch
@@ -0,0 +1,12 @@
+diff -uNr iax-0.2.2.ORIG/src/md5.c iax-0.2.2/src/md5.c
+--- iax-0.2.2.ORIG/src/md5.c 2014-05-13 13:26:51.570877706 +0100
++++ iax-0.2.2/src/md5.c 2014-05-13 13:27:08.567878553 +0100
+@@ -165,7 +165,7 @@
+ MD5Transform(ctx->buf, (uint32 *) ctx->in);
+ byteReverse((unsigned char *) ctx->buf, 4);
+ memcpy(digest, ctx->buf, 16);
+- memset(ctx, 0, sizeof(ctx)); /* In case it's sensitive */
++ memset(ctx, 0, sizeof(*ctx)); /* In case it's sensitive */
+ }
+
+ #ifndef ASM_MD5
diff --git a/net-libs/iax/iax-0.2.2-r2.ebuild b/net-libs/iax/iax-0.2.2-r3.ebuild
index 4e4442fab705..15d9a3ece7db 100644
--- a/net-libs/iax/iax-0.2.2-r2.ebuild
+++ b/net-libs/iax/iax-0.2.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/iax/iax-0.2.2-r2.ebuild,v 1.1 2014/05/13 11:55:30 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/iax/iax-0.2.2-r3.ebuild,v 1.1 2014/05/13 12:31:24 chainsaw Exp $
EAPI="5"
@@ -16,6 +16,8 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug snomhack"
src_prepare() {
+ epatch "${FILESDIR}/${PV}-debug.patch"
+ epatch "${FILESDIR}/${PV}-memset.patch"
epatch "${FILESDIR}/${PV}-sandbox.patch"
eautoreconf
}