summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-08-27 00:41:25 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-08-27 00:41:25 +0000
commit6d3a259964da8c7a8cd6ca188b50aef7867f8f3d (patch)
tree564da3264b9bb2596ef201a19ec04631e08d828a /net-libs/libnatpmp
parentMask scsign for removal. (diff)
downloadgentoo-2-6d3a259964da8c7a8cd6ca188b50aef7867f8f3d.tar.gz
gentoo-2-6d3a259964da8c7a8cd6ca188b50aef7867f8f3d.tar.bz2
gentoo-2-6d3a259964da8c7a8cd6ca188b50aef7867f8f3d.zip
Version bump
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libnatpmp')
-rw-r--r--net-libs/libnatpmp/ChangeLog8
-rw-r--r--net-libs/libnatpmp/files/remove-static-lib-20120821.patch73
-rw-r--r--net-libs/libnatpmp/files/respect-FLAGS-20120821.patch51
-rw-r--r--net-libs/libnatpmp/files/respect-libdir-20120821.patch20
-rw-r--r--net-libs/libnatpmp/libnatpmp-20120821.ebuild29
5 files changed, 181 insertions, 0 deletions
diff --git a/net-libs/libnatpmp/ChangeLog b/net-libs/libnatpmp/ChangeLog
index a5441c01c0ef..39206bfafe1c 100644
--- a/net-libs/libnatpmp/ChangeLog
+++ b/net-libs/libnatpmp/ChangeLog
@@ -1,4 +1,12 @@
+
+*libnatpmp-20120821 (27 Aug 2012)
+
+ 27 Aug 2012; Anthony G. Basile <blueness@gentoo.org>
+ +libnatpmp-20120821.ebuild, +files/remove-static-lib-20120821.patch,
+ +files/respect-FLAGS-20120821.patch, +files/respect-libdir-20120821.patch:
+ Version bump
+
25 Mar 2012; Naohiro Aota <naota@gentoo.org> libnatpmp-20110808-r1.ebuild:
Add ~x86-fbsd. #400929
diff --git a/net-libs/libnatpmp/files/remove-static-lib-20120821.patch b/net-libs/libnatpmp/files/remove-static-lib-20120821.patch
new file mode 100644
index 000000000000..89be32d6c414
--- /dev/null
+++ b/net-libs/libnatpmp/files/remove-static-lib-20120821.patch
@@ -0,0 +1,73 @@
+diff -Naur libnatpmp-20120821.orig/Makefile libnatpmp-20120821/Makefile
+--- libnatpmp-20120821.orig/Makefile 2012-08-26 20:33:51.000000000 -0400
++++ libnatpmp-20120821/Makefile 2012-08-26 20:36:53.000000000 -0400
+@@ -24,7 +24,6 @@
+
+ OBJS = $(LIBOBJS) testgetgateway.o natpmpc.o
+
+-STATICLIB = libnatpmp.a
+ ifeq ($(OS), Darwin)
+ SHAREDLIB = libnatpmp.dylib
+ SONAME = $(basename $(SHAREDLIB)).$(APIVERSION).dylib
+@@ -38,7 +37,7 @@
+
+ HEADERS = natpmp.h
+
+-EXECUTABLES = testgetgateway natpmpc-shared natpmpc-static
++EXECUTABLES = testgetgateway natpmpc-shared
+
+ INSTALLPREFIX ?= $(PREFIX)/usr
+ INSTALLDIRINC = $(INSTALLPREFIX)/include
+@@ -47,9 +46,9 @@
+
+ .PHONY: all clean depend install cleaninstall installpythonmodule
+
+-all: $(STATICLIB) $(SHAREDLIB) $(EXECUTABLES)
++all: $(SHAREDLIB) $(EXECUTABLES)
+
+-pythonmodule: $(STATICLIB) libnatpmpmodule.c setup.py
++pythonmodule: libnatpmpmodule.c setup.py
+ python setup.py build
+ touch $@
+
+@@ -57,18 +56,17 @@
+ python setup.py install
+
+ clean:
+- $(RM) $(OBJS) $(EXECUTABLES) $(STATICLIB) $(SHAREDLIB)
++ $(RM) $(OBJS) $(EXECUTABLES) $(SHAREDLIB)
+ $(RM) pythonmodule
+ $(RM) -r build/ dist/
+
+ depend:
+ makedepend -f$(MAKEFILE_LIST) -Y $(OBJS:.o=.c) 2>/dev/null
+
+-install: $(HEADERS) $(STATICLIB) $(SHAREDLIB) natpmpc-shared
++install: $(HEADERS) $(SHAREDLIB) natpmpc-shared
+ $(INSTALL) -d $(INSTALLDIRINC)
+ $(INSTALL) -m 644 $(HEADERS) $(INSTALLDIRINC)
+ $(INSTALL) -d $(INSTALLDIRLIB)
+- $(INSTALL) -m 644 $(STATICLIB) $(INSTALLDIRLIB)
+ $(INSTALL) -m 644 $(SHAREDLIB) $(INSTALLDIRLIB)/$(SONAME)
+ $(INSTALL) -d $(INSTALLDIRBIN)
+ $(INSTALL) -m 755 natpmpc-shared $(INSTALLDIRBIN)/natpmpc
+@@ -78,19 +76,12 @@
+ $(RM) $(addprefix $(INSTALLDIRINC), $(HEADERS))
+ $(RM) $(INSTALLDIRLIB)/$(SONAME)
+ $(RM) $(INSTALLDIRLIB)/$(SHAREDLIB)
+- $(RM) $(INSTALLDIRLIB)/$(STATICLIB)
+
+ testgetgateway: testgetgateway.o getgateway.o
+
+-natpmpc-static: natpmpc.o $(STATICLIB)
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+-
+ natpmpc-shared: natpmpc.o $(SHAREDLIB)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+-$(STATICLIB): $(LIBOBJS)
+- $(AR) crs $@ $?
+-
+ $(SHAREDLIB): $(LIBOBJS)
+ ifeq ($(OS), Darwin)
+ $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
diff --git a/net-libs/libnatpmp/files/respect-FLAGS-20120821.patch b/net-libs/libnatpmp/files/respect-FLAGS-20120821.patch
new file mode 100644
index 000000000000..7c7dc8607d2c
--- /dev/null
+++ b/net-libs/libnatpmp/files/respect-FLAGS-20120821.patch
@@ -0,0 +1,51 @@
+diff -Naur libnatpmp-20120821.orig/Makefile libnatpmp-20120821/Makefile
+--- libnatpmp-20120821.orig/Makefile 2012-08-21 13:24:15.000000000 -0400
++++ libnatpmp-20120821/Makefile 2012-08-26 20:22:40.000000000 -0400
+@@ -5,12 +5,13 @@
+ # http://miniupnp.free.fr/libnatpmp.html
+
+ OS = $(shell uname -s)
+-CC = gcc
++CC ?= gcc
+ INSTALL = install
+
+ # APIVERSION is used in soname
+ APIVERSION = 1
+ #LDFLAGS = -Wl,--no-undefined
++GENTOO_CFLAGS := $(CFLAGS)
+ CFLAGS = -Os
+ #CFLAGS = -g -O0
+ CFLAGS += -fPIC
+@@ -32,6 +33,8 @@
+ SONAME = $(SHAREDLIB).$(APIVERSION)
+ endif
+
++CFLAGS := $(CFLAGS) $(GENTOO_CFLAGS)
++
+ HEADERS = natpmp.h
+
+ EXECUTABLES = testgetgateway natpmpc-shared natpmpc-static
+@@ -79,19 +82,19 @@
+ testgetgateway: testgetgateway.o getgateway.o
+
+ natpmpc-static: natpmpc.o $(STATICLIB)
+- $(CC) $(LDFLAGS) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+ natpmpc-shared: natpmpc.o $(SHAREDLIB)
+- $(CC) $(LDFLAGS) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+ $(STATICLIB): $(LIBOBJS)
+ $(AR) crs $@ $?
+
+ $(SHAREDLIB): $(LIBOBJS)
+ ifeq ($(OS), Darwin)
+- $(CC) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
+ else
+- $(CC) -shared -Wl,-soname,$(SONAME) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(SONAME) -o $@ $^
+ endif
+
+ # DO NOT DELETE
diff --git a/net-libs/libnatpmp/files/respect-libdir-20120821.patch b/net-libs/libnatpmp/files/respect-libdir-20120821.patch
new file mode 100644
index 000000000000..90b7167a1d4f
--- /dev/null
+++ b/net-libs/libnatpmp/files/respect-libdir-20120821.patch
@@ -0,0 +1,20 @@
+diff -Naur libnatpmp-20120821.orig/Makefile libnatpmp-20120821/Makefile
+--- libnatpmp-20120821.orig/Makefile 2012-08-26 20:26:27.000000000 -0400
++++ libnatpmp-20120821/Makefile 2012-08-26 20:27:07.000000000 -0400
+@@ -4,6 +4,7 @@
+ # (c) 2007-2011 Thomas Bernard
+ # http://miniupnp.free.fr/libnatpmp.html
+
++GENTOO_LIBDIR ?= lib
+ OS = $(shell uname -s)
+ CC ?= gcc
+ INSTALL = install
+@@ -41,7 +42,7 @@
+
+ INSTALLPREFIX ?= $(PREFIX)/usr
+ INSTALLDIRINC = $(INSTALLPREFIX)/include
+-INSTALLDIRLIB = $(INSTALLPREFIX)/lib
++INSTALLDIRLIB = $(INSTALLPREFIX)/$(GENTOO_LIBDIR)
+ INSTALLDIRBIN = $(INSTALLPREFIX)/bin
+
+ .PHONY: all clean depend install cleaninstall installpythonmodule
diff --git a/net-libs/libnatpmp/libnatpmp-20120821.ebuild b/net-libs/libnatpmp/libnatpmp-20120821.ebuild
new file mode 100644
index 000000000000..1cfea26abf8b
--- /dev/null
+++ b/net-libs/libnatpmp/libnatpmp-20120821.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnatpmp/libnatpmp-20120821.ebuild,v 1.1 2012/08/27 00:41:25 blueness Exp $
+
+EAPI="4"
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="An alternative protocol to UPnP IGD specification"
+HOMEPAGE="http://miniupnp.free.fr/libnatpmp.html"
+SRC_URI="http://miniupnp.free.fr/files/download.php?file=${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/respect-FLAGS-${PV}.patch
+ epatch "${FILESDIR}"/respect-libdir-${PV}.patch
+ use static-libs || epatch "${FILESDIR}"/remove-static-lib-${PV}.patch
+ tc-export CC
+}
+
+src_install() {
+ emake PREFIX="${D}" GENTOO_LIBDIR="$(get_libdir)" install
+
+ dodoc Changelog.txt README
+ doman natpmpc.1
+}