summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-08-01 06:07:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-08-01 06:07:32 +0000
commit42b3676b5b95aeb8df5ab4d4818553db5a5a72fc (patch)
tree5ab96b4170746162b7eba7b59d3be79a74fe0735 /net-libs/nodejs
parentBump (diff)
downloadgentoo-2-42b3676b5b95aeb8df5ab4d4818553db5a5a72fc.tar.gz
gentoo-2-42b3676b5b95aeb8df5ab4d4818553db5a5a72fc.tar.bz2
gentoo-2-42b3676b5b95aeb8df5ab4d4818553db5a5a72fc.zip
Remove old
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/ChangeLog7
-rw-r--r--net-libs/nodejs/nodejs-0.10.28.ebuild68
-rw-r--r--net-libs/nodejs/nodejs-0.10.29-r1.ebuild73
-rw-r--r--net-libs/nodejs/nodejs-0.10.29.ebuild69
-rw-r--r--net-libs/nodejs/nodejs-0.8.26.ebuild71
-rw-r--r--net-libs/nodejs/nodejs-0.8.27.ebuild72
6 files changed, 6 insertions, 354 deletions
diff --git a/net-libs/nodejs/ChangeLog b/net-libs/nodejs/ChangeLog
index 5ee1a35db7ef..3ae6e7b87459 100644
--- a/net-libs/nodejs/ChangeLog
+++ b/net-libs/nodejs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/nodejs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.124 2014/08/01 06:02:08 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.125 2014/08/01 06:07:32 patrick Exp $
+
+ 01 Aug 2014; Patrick Lauer <patrick@gentoo.org> -nodejs-0.10.28.ebuild,
+ -nodejs-0.10.29-r1.ebuild, -nodejs-0.10.29.ebuild, -nodejs-0.8.26.ebuild,
+ -nodejs-0.8.27.ebuild:
+ Remove old
*nodejs-0.10.30 (01 Aug 2014)
*nodejs-0.8.28 (01 Aug 2014)
diff --git a/net-libs/nodejs/nodejs-0.10.28.ebuild b/net-libs/nodejs/nodejs-0.10.28.ebuild
deleted file mode 100644
index 254137e717f6..000000000000
--- a/net-libs/nodejs/nodejs-0.10.28.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.28.ebuild,v 1.1 2014/05/09 03:42:10 patrick Exp $
-
-EAPI=5
-
-# has known failures. sigh.
-RESTRICT="test"
-
-PYTHON_COMPAT=( python2_{6,7} )
-
-inherit python-any-r1 pax-utils
-
-DESCRIPTION="Evented IO for V8 Javascript"
-HOMEPAGE="http://nodejs.org/"
-SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
-
-LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
-IUSE="+npm +snapshot"
-
-RDEPEND="dev-libs/openssl"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/node-v${PV}
-
-src_prepare() {
- # fix compilation on Darwin
- # http://code.google.com/p/gyp/issues/detail?id=260
- sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
-
- # make sure we use python2.* while using gyp
- sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
-
- # less verbose install output (stating the same as portage, basically)
- sed -i -e "/print/d" tools/install.py || die
-}
-
-src_configure() {
- local myconf=""
- ! use npm && myconf="--without-npm"
- ! use snapshot && myconf="${myconf} --without-snapshot"
-
- "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
- --openssl-use-sys --shared-zlib --without-dtrace ${myconf} || die
-}
-
-src_compile() {
- emake out/Makefile
- emake -C out mksnapshot
- pax-mark m out/Release/mksnapshot
- emake
-}
-
-src_install() {
- "${PYTHON}" tools/install.py install "${D}"
-
- use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
- rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
- rm -rf "${ED}"/usr/lib/dtrace
-
- pax-mark -m "${ED}"/usr/bin/node
-}
-
-src_test() {
- "${PYTHON}" tools/test.py --mode=release simple message || die
-}
diff --git a/net-libs/nodejs/nodejs-0.10.29-r1.ebuild b/net-libs/nodejs/nodejs-0.10.29-r1.ebuild
deleted file mode 100644
index 5b4fe6197c09..000000000000
--- a/net-libs/nodejs/nodejs-0.10.29-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.29-r1.ebuild,v 1.1 2014/07/23 03:41:43 patrick Exp $
-
-EAPI=5
-
-# has known failures. sigh.
-RESTRICT="test"
-
-PYTHON_COMPAT=( python2_{6,7} )
-
-inherit python-any-r1 pax-utils toolchain-funcs
-
-DESCRIPTION="Evented IO for V8 Javascript"
-HOMEPAGE="http://nodejs.org/"
-SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
-
-LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
-IUSE="+npm +snapshot"
-
-RDEPEND="dev-libs/openssl"
-DEPEND="${PYTHON_DEPS}
- ${RDEPEND}"
-
-S=${WORKDIR}/node-v${PV}
-
-src_prepare() {
- # fix compilation on Darwin
- # http://code.google.com/p/gyp/issues/detail?id=260
- sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
-
- # make sure we use python2.* while using gyp
- sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
-
- # less verbose install output (stating the same as portage, basically)
- sed -i -e "/print/d" tools/install.py || die
-
- tc-export CC CXX
-}
-
-src_configure() {
- local myconf=""
- ! use npm && myconf="--without-npm"
- ! use snapshot && myconf="${myconf} --without-snapshot"
-
- "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
- --shared-openssl --shared-zlib --without-dtrace ${myconf} || die
-}
-
-src_compile() {
- local V=1
- export V
- emake out/Makefile
- emake -C out mksnapshot
- pax-mark m out/Release/mksnapshot
- emake
-}
-
-src_install() {
- "${PYTHON}" tools/install.py install "${D}"
-
- use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
- rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
- rm -rf "${ED}"/usr/lib/dtrace
-
- pax-mark -m "${ED}"/usr/bin/node
-}
-
-src_test() {
- "${PYTHON}" tools/test.py --mode=release simple message || die
-}
diff --git a/net-libs/nodejs/nodejs-0.10.29.ebuild b/net-libs/nodejs/nodejs-0.10.29.ebuild
deleted file mode 100644
index 99440bb4e14b..000000000000
--- a/net-libs/nodejs/nodejs-0.10.29.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.29.ebuild,v 1.2 2014/07/23 03:28:49 patrick Exp $
-
-EAPI=5
-
-# has known failures. sigh.
-RESTRICT="test"
-
-PYTHON_COMPAT=( python2_{6,7} )
-
-inherit python-any-r1 pax-utils
-
-DESCRIPTION="Evented IO for V8 Javascript"
-HOMEPAGE="http://nodejs.org/"
-SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
-
-LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
-IUSE="+npm +snapshot"
-
-RDEPEND="dev-libs/openssl"
-DEPEND="${PYTHON_DEPS}
- ${RDEPEND}"
-
-S=${WORKDIR}/node-v${PV}
-
-src_prepare() {
- # fix compilation on Darwin
- # http://code.google.com/p/gyp/issues/detail?id=260
- sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
-
- # make sure we use python2.* while using gyp
- sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
-
- # less verbose install output (stating the same as portage, basically)
- sed -i -e "/print/d" tools/install.py || die
-}
-
-src_configure() {
- local myconf=""
- ! use npm && myconf="--without-npm"
- ! use snapshot && myconf="${myconf} --without-snapshot"
-
- "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
- --openssl-use-sys --shared-zlib --without-dtrace ${myconf} || die
-}
-
-src_compile() {
- emake out/Makefile
- emake -C out mksnapshot
- pax-mark m out/Release/mksnapshot
- emake
-}
-
-src_install() {
- "${PYTHON}" tools/install.py install "${D}"
-
- use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
- rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
- rm -rf "${ED}"/usr/lib/dtrace
-
- pax-mark -m "${ED}"/usr/bin/node
-}
-
-src_test() {
- "${PYTHON}" tools/test.py --mode=release simple message || die
-}
diff --git a/net-libs/nodejs/nodejs-0.8.26.ebuild b/net-libs/nodejs/nodejs-0.8.26.ebuild
deleted file mode 100644
index 03cd8fc328ad..000000000000
--- a/net-libs/nodejs/nodejs-0.8.26.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.8.26.ebuild,v 1.1 2013/10/21 02:55:43 patrick Exp $
-
-EAPI=5
-
-PYTHON_DEPEND="2"
-
-inherit python eutils multilib pax-utils
-
-# omgwtf
-RESTRICT="test"
-
-DESCRIPTION="Evented IO for V8 Javascript"
-HOMEPAGE="http://nodejs.org/"
-SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
-IUSE=""
-
-DEPEND="dev-libs/openssl"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/node-v${PV}
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- # fix compilation on Darwin
- # http://code.google.com/p/gyp/issues/detail?id=260
- sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
- python_convert_shebangs 2 tools/node-waf || die
-}
-
-src_configure() {
- # this is an autotools lookalike confuserator
- ./configure --prefix="${EPREFIX}"/usr --openssl-use-sys --shared-zlib || die
-}
-
-src_compile() {
- emake || die
-}
-
-src_install() {
- local MYLIB=$(get_libdir)
- mkdir -p "${ED}"/usr/include/node
- mkdir -p "${ED}"/usr/bin
- mkdir -p "${ED}"/usr/"${MYLIB}"/node_modules/npm
- mkdir -p "${ED}"/usr/"${MYLIB}"/node
- cp 'src/eio-emul.h' 'src/ev-emul.h' 'src/node.h' 'src/node_buffer.h' 'src/node_object_wrap.h' 'src/node_version.h' "${ED}"/usr/include/node || die "Failed to copy stuff"
- cp -R deps/uv/include/* "${ED}"/usr/include/node || die "Failed to copy stuff"
- cp -R deps/v8/include/* "${ED}"/usr/include/node || die "Failed to copy stuff"
- cp 'out/Release/node' "${ED}"/usr/bin/node || die "Failed to copy stuff"
- cp -R deps/npm/* "${ED}"/usr/"${MYLIB}"/node_modules/npm || die "Failed to copy stuff"
- cp -R tools/wafadmin "${ED}"/usr/"${MYLIB}"/node/ || die "Failed to copy stuff"
- cp 'tools/node-waf' "${ED}"/usr/bin/ || die "Failed to copy stuff"
-
- # now add some extra stupid just because we can
- # needs to be a symlink because of hardcoded paths ... no es bueno!
- dosym /usr/"${MYLIB}"/node_modules/npm/bin/npm-cli.js /usr/bin/npm
- pax-mark -m "${ED}"/usr/bin/node
-}
-
-src_test() {
- emake test || die
-}
diff --git a/net-libs/nodejs/nodejs-0.8.27.ebuild b/net-libs/nodejs/nodejs-0.8.27.ebuild
deleted file mode 100644
index 126ae92bb590..000000000000
--- a/net-libs/nodejs/nodejs-0.8.27.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.8.27.ebuild,v 1.2 2014/07/23 03:28:49 patrick Exp $
-
-EAPI=5
-
-PYTHON_DEPEND="2"
-
-inherit python eutils multilib pax-utils
-
-# omgwtf
-RESTRICT="test"
-
-DESCRIPTION="Evented IO for V8 Javascript"
-HOMEPAGE="http://nodejs.org/"
-SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
-IUSE=""
-
-DEPEND="dev-libs/openssl"
-RDEPEND="${PYTHON_DEPS}
- ${DEPEND}"
-
-S=${WORKDIR}/node-v${PV}
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- # fix compilation on Darwin
- # http://code.google.com/p/gyp/issues/detail?id=260
- sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
- python_convert_shebangs 2 tools/node-waf || die
-}
-
-src_configure() {
- # this is an autotools lookalike confuserator
- ./configure --prefix="${EPREFIX}"/usr --openssl-use-sys --shared-zlib || die
-}
-
-src_compile() {
- emake || die
-}
-
-src_install() {
- local MYLIB=$(get_libdir)
- mkdir -p "${ED}"/usr/include/node
- mkdir -p "${ED}"/usr/bin
- mkdir -p "${ED}"/usr/"${MYLIB}"/node_modules/npm
- mkdir -p "${ED}"/usr/"${MYLIB}"/node
- cp 'src/eio-emul.h' 'src/ev-emul.h' 'src/node.h' 'src/node_buffer.h' 'src/node_object_wrap.h' 'src/node_version.h' "${ED}"/usr/include/node || die "Failed to copy stuff"
- cp -R deps/uv/include/* "${ED}"/usr/include/node || die "Failed to copy stuff"
- cp -R deps/v8/include/* "${ED}"/usr/include/node || die "Failed to copy stuff"
- cp 'out/Release/node' "${ED}"/usr/bin/node || die "Failed to copy stuff"
- cp -R deps/npm/* "${ED}"/usr/"${MYLIB}"/node_modules/npm || die "Failed to copy stuff"
- cp -R tools/wafadmin "${ED}"/usr/"${MYLIB}"/node/ || die "Failed to copy stuff"
- cp 'tools/node-waf' "${ED}"/usr/bin/ || die "Failed to copy stuff"
-
- # now add some extra stupid just because we can
- # needs to be a symlink because of hardcoded paths ... no es bueno!
- dosym /usr/"${MYLIB}"/node_modules/npm/bin/npm-cli.js /usr/bin/npm
- pax-mark -m "${ED}"/usr/bin/node
-}
-
-src_test() {
- emake test || die
-}