summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2014-05-04 13:55:55 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2014-05-04 13:55:55 +0000
commit4562432f7c8627d040cfecc7a2ba269b5e31d2f7 (patch)
tree58f5ef8182d914b383e03768a5b6b0f4991d0dd4 /net-libs/rabbitmq-c
parentMarked ~hppa (bug #487206). (diff)
downloadgentoo-2-4562432f7c8627d040cfecc7a2ba269b5e31d2f7.tar.gz
gentoo-2-4562432f7c8627d040cfecc7a2ba269b5e31d2f7.tar.bz2
gentoo-2-4562432f7c8627d040cfecc7a2ba269b5e31d2f7.zip
version bump fix #480962 thx to Matt Whitlock
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'net-libs/rabbitmq-c')
-rw-r--r--net-libs/rabbitmq-c/ChangeLog9
-rw-r--r--net-libs/rabbitmq-c/rabbitmq-c-0.5.0.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/net-libs/rabbitmq-c/ChangeLog b/net-libs/rabbitmq-c/ChangeLog
index 99d2440e2ca2..d0faa821b47a 100644
--- a/net-libs/rabbitmq-c/ChangeLog
+++ b/net-libs/rabbitmq-c/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/rabbitmq-c
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rabbitmq-c/ChangeLog,v 1.1 2013/03/14 18:50:36 olemarkus Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rabbitmq-c/ChangeLog,v 1.2 2014/05/04 13:55:55 ultrabug Exp $
+
+*rabbitmq-c-0.5.0 (04 May 2014)
+
+ 04 May 2014; Ultrabug <ultrabug@gentoo.org> +rabbitmq-c-0.5.0.ebuild:
+ version bump fix #480962 thx to Matt Whitlock
*rabbitmq-c-0.3.0 (14 Mar 2013)
diff --git a/net-libs/rabbitmq-c/rabbitmq-c-0.5.0.ebuild b/net-libs/rabbitmq-c/rabbitmq-c-0.5.0.ebuild
new file mode 100644
index 000000000000..a10e839c2f57
--- /dev/null
+++ b/net-libs/rabbitmq-c/rabbitmq-c-0.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rabbitmq-c/rabbitmq-c-0.5.0.ebuild,v 1.1 2014/05/04 13:55:55 ultrabug Exp $
+
+EAPI="5"
+
+inherit cmake-utils eutils multilib
+
+DESCRIPTION="RabbitMQ C client"
+HOMEPAGE="https://github.com/alanxz/rabbitmq-c"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/alanxz/rabbitmq-c.git"
+ KEYWORDS="-*"
+else
+ SRC_URI="https://github.com/alanxz/rabbitmq-c/archive/v${PV}.zip -> ${PN}-v${PV}.zip"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="tools"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+DOCS=( "AUTHORS" "README.md" "THANKS" "TODO" )
+
+src_unpack() {
+ if [[ ${PV} == *9999* ]]; then
+ git-2_src_unpack
+ else
+ unpack ${A}
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=ON
+ $(cmake-utils_use tools BUILD_TOOLS)
+ $(cmake-utils_use tools BUILD_TOOLS_DOCS)
+ )
+ cmake-utils_src_configure
+}