summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-29 04:15:06 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-29 04:15:06 +0000
commit8f465bc65351f153b3796dcffb609f3abe9b5e64 (patch)
tree4a3ca417c535d56932d787217a42f451ddd20b91 /net-mail/getmail
parentRemove old. (diff)
downloadgentoo-2-8f465bc65351f153b3796dcffb609f3abe9b5e64.tar.gz
gentoo-2-8f465bc65351f153b3796dcffb609f3abe9b5e64.tar.bz2
gentoo-2-8f465bc65351f153b3796dcffb609f3abe9b5e64.zip
Add conditional dep on ssl enabled python (bug #488472).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'net-mail/getmail')
-rw-r--r--net-mail/getmail/ChangeLog9
-rw-r--r--net-mail/getmail/getmail-4.43.0-r1.ebuild25
2 files changed, 32 insertions, 2 deletions
diff --git a/net-mail/getmail/ChangeLog b/net-mail/getmail/ChangeLog
index 1731da894840..02aac1fcb334 100644
--- a/net-mail/getmail/ChangeLog
+++ b/net-mail/getmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/getmail
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.232 2013/09/27 08:22:06 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.233 2014/01/29 04:15:06 radhermit Exp $
+
+*getmail-4.43.0-r1 (29 Jan 2014)
+
+ 29 Jan 2014; Tim Harder <radhermit@gentoo.org> +getmail-4.43.0-r1.ebuild:
+ Add conditional dep on ssl enabled python (bug #488472).
27 Sep 2013; Tim Harder <radhermit@gentoo.org> -getmail-4.36.0.ebuild,
-getmail-4.39.1.ebuild, -getmail-4.40.1.ebuild, -getmail-4.40.3.ebuild:
diff --git a/net-mail/getmail/getmail-4.43.0-r1.ebuild b/net-mail/getmail/getmail-4.43.0-r1.ebuild
new file mode 100644
index 000000000000..eb83eabe4c28
--- /dev/null
+++ b/net-mail/getmail/getmail-4.43.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.43.0-r1.ebuild,v 1.1 2014/01/29 04:15:06 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x86-macos ~x64-solaris"
+IUSE="ssl"
+
+python_prepare_all() {
+ sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
+ -e "/docs\/COPYING/d" "${S}"/setup.py || die
+
+ distutils-r1_python_prepare_all
+}