summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-06-25 23:07:11 +0000
committerTim Harder <radhermit@gentoo.org>2011-06-25 23:07:11 +0000
commit8b6c67c6cc95bf9f7b802c0ffeb131232168c332 (patch)
treeece71378b93d9dd62cc0e89d2cac69a3f2c9a3b9 /net-mail
parentVersion bump. Add static-libs USE flag. Improve USE flag descriptions (diff)
downloadgentoo-2-8b6c67c6cc95bf9f7b802c0ffeb131232168c332.tar.gz
gentoo-2-8b6c67c6cc95bf9f7b802c0ffeb131232168c332.tar.bz2
gentoo-2-8b6c67c6cc95bf9f7b802c0ffeb131232168c332.zip
Version bump.
(Portage version: 2.2.0_alpha40/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/lbdb/ChangeLog7
-rw-r--r--net-mail/lbdb/lbdb-0.38.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/net-mail/lbdb/ChangeLog b/net-mail/lbdb/ChangeLog
index c9b404e702ff..e68d72959efe 100644
--- a/net-mail/lbdb/ChangeLog
+++ b/net-mail/lbdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/lbdb
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/ChangeLog,v 1.55 2011/03/27 23:37:00 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/ChangeLog,v 1.56 2011/06/25 23:07:11 radhermit Exp $
+
+*lbdb-0.38 (25 Jun 2011)
+
+ 25 Jun 2011; Tim Harder <radhermit@gentoo.org> +lbdb-0.38.ebuild:
+ Version bump.
27 Mar 2011; Tim Harder <radhermit@gentoo.org> -lbdb-0.36.ebuild,
-lbdb-0.36-r1.ebuild:
diff --git a/net-mail/lbdb/lbdb-0.38.ebuild b/net-mail/lbdb/lbdb-0.38.ebuild
new file mode 100644
index 000000000000..234f2af251b0
--- /dev/null
+++ b/net-mail/lbdb/lbdb-0.38.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/lbdb-0.38.ebuild,v 1.1 2011/06/25 23:07:11 radhermit Exp $
+
+EAPI=4
+
+inherit versionator eutils
+
+MY_P=${P/-/_}
+DESCRIPTION="Little Brother database"
+SRC_URI="http://www.spinnaker.de/debian/${MY_P}.tar.gz"
+HOMEPAGE="http://www.spinnaker.de/lbdb/"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+IUSE="pda ldap finger nis abook crypt evo"
+
+DEPEND="dev-libs/libvformat
+ evo? ( mail-client/evolution )
+ finger? ( net-misc/netkit-fingerd )
+ abook? ( app-misc/abook )
+ crypt? ( app-crypt/gnupg )
+ nis? ( net-nds/yp-tools )"
+RDEPEND="${DEPEND}
+ pda? ( dev-perl/p5-Palm )
+ ldap? ( dev-perl/perl-ldap )"
+
+src_configure() {
+ local evoversion
+ local evolution_addressbook_export
+
+ if use evo ; then
+ evoversion=$(best_version mail-client/evolution)
+ evoversion=${evoversion##mail-client/evolution-}
+ evolution_addressbook_export="/usr/libexec/evolution/$(get_version_component_range 1-2 ${evoversion})/evolution-addressbook-export"
+ fi
+
+ econf $(use_with finger) \
+ $(use_with abook) \
+ $(use_with nis ypcat) \
+ $(use_with crypt gpg) \
+ $(use_with evo evolution-addressbook-export "${evolution_addressbook_export}" ) \
+ --enable-lbdb-dotlock \
+ --without-pgp5 --without-pgp \
+ --without-niscat --without-addr-email --with-getent \
+ --libdir=/usr/$(get_libdir)/lbdb
+}
+
+src_install () {
+ emake install_prefix="${D}" install
+ dodoc README TODO debian/changelog
+}