summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-08-27 04:58:56 +0000
committerMike Frysinger <vapier@gentoo.org>2011-08-27 04:58:56 +0000
commit9f02b87b30abbac45c797583c8486440713ba9ec (patch)
tree23956e0b666ee8e201ead375a97de2dada4daea4 /net-misc/dhcp/dhcp-4.2.2.ebuild
parentDrop mask for xorg-server 1.11 prereleases (diff)
downloadgentoo-2-9f02b87b30abbac45c797583c8486440713ba9ec.tar.gz
gentoo-2-9f02b87b30abbac45c797583c8486440713ba9ec.tar.bz2
gentoo-2-9f02b87b30abbac45c797583c8486440713ba9ec.zip
Fix parallel build #380717 by Cédric Jeanneret, and clean up bind tweaks with patches.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/dhcp/dhcp-4.2.2.ebuild')
-rw-r--r--net-misc/dhcp/dhcp-4.2.2.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/net-misc/dhcp/dhcp-4.2.2.ebuild b/net-misc/dhcp/dhcp-4.2.2.ebuild
index d5ed3ba6c5bf..8aa447569557 100644
--- a/net-misc/dhcp/dhcp-4.2.2.ebuild
+++ b/net-misc/dhcp/dhcp-4.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-4.2.2.ebuild,v 1.2 2011/08/26 10:02:13 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-4.2.2.ebuild,v 1.3 2011/08/27 04:58:56 vapier Exp $
EAPI="2"
@@ -27,6 +27,7 @@ DEPEND="selinux? ( sec-policy/selinux-dhcp )
net-nds/openldap
ssl? ( dev-libs/openssl )
)"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -104,24 +105,21 @@ src_prepare() {
# make the bind build work
binddir=${S}/bind
- cat <<-EOF > "${binddir}"/bindvar.tmp
+ cd "${binddir}" || die
+ cat <<-EOF > bindvar.tmp
binddir=${binddir}
GMAKE=${MAKE:-gmake}
EOF
- sed -i '/^all:/s,$,\nfoo:,' "${binddir}"/Makefile || die
- # since the bind source is dynamic, sed it rather than patch
- sed -i -r \
- -e '/CC.*ALL_CFLAGS/{
- s:(CC):BUILD_\1:;
- s:ALL(_CFLAGS.):BUILD\1 $(CINCLUDES):;
- s:(LDFLAGS):BUILD_\1:
- }' \
- -e '/BUILD_CC/s:ISC_INCLUDES:CINCLUDES:' \
- "${binddir}"/bind-*/lib/export/dns/Makefile.in || die
+ epatch "${FILESDIR}"/${PN}-4.2.2-bind-disable.patch
+ cd bind-*/
+ epatch "${FILESDIR}"/${PN}-4.2.2-bind-parallel-build.patch #380717
+ epatch "${FILESDIR}"/${PN}-4.2.2-bind-build-flags.patch
}
src_configure() {
- tc-export BUILD_CC
+ # bind defaults to stupid `/usr/bin/ar`
+ tc-export AR BUILD_CC
+ export ac_cv_path_AR=${AR}
econf \
--enable-paranoia \
@@ -141,7 +139,9 @@ src_configure() {
# configure local bind cruft
cd bind/bind-*/ || die
- eval econf $(sed -n '/ [.].configure /{s:^[^-]*::;s:>.*::;p}' ../Makefile)
+ eval econf \
+ $(sed -n '/ [.].configure /{s:^[^-]*::;s:>.*::;p}' ../Makefile) \
+ --without-make-clean
}
src_compile() {