summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-09-06 08:34:13 +0000
committerNaohiro Aota <naota@gentoo.org>2013-09-06 08:34:13 +0000
commitd929d4bb76bd9f769216bc4fdf0200c6e909091a (patch)
tree33c667799efca3a5d26f1e02419cd6211522a75b /net-misc/mikutter
parentRemove old. (diff)
downloadgentoo-2-d929d4bb76bd9f769216bc4fdf0200c6e909091a.tar.gz
gentoo-2-d929d4bb76bd9f769216bc4fdf0200c6e909091a.tar.bz2
gentoo-2-d929d4bb76bd9f769216bc4fdf0200c6e909091a.zip
version bump
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'net-misc/mikutter')
-rw-r--r--net-misc/mikutter/ChangeLog7
-rw-r--r--net-misc/mikutter/mikutter-0.2.2.1328.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/net-misc/mikutter/ChangeLog b/net-misc/mikutter/ChangeLog
index 33e21d73aa98..bd2f63069bc5 100644
--- a/net-misc/mikutter/ChangeLog
+++ b/net-misc/mikutter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/mikutter
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mikutter/ChangeLog,v 1.35 2013/04/27 05:28:02 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mikutter/ChangeLog,v 1.36 2013/09/06 08:34:13 naota Exp $
+
+*mikutter-0.2.2.1328 (06 Sep 2013)
+
+ 06 Sep 2013; Naohiro Aota <naota@gentoo.org> +mikutter-0.2.2.1328.ebuild:
+ version bump
27 Apr 2013; Naohiro Aota <naota@gentoo.org> files/mikutter:
Specific to ruby1.9
diff --git a/net-misc/mikutter/mikutter-0.2.2.1328.ebuild b/net-misc/mikutter/mikutter-0.2.2.1328.ebuild
new file mode 100644
index 000000000000..c57a0a4ef417
--- /dev/null
+++ b/net-misc/mikutter/mikutter-0.2.2.1328.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mikutter/mikutter-0.2.2.1328.ebuild,v 1.1 2013/09/06 08:34:13 naota Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19"
+
+inherit ruby-ng eutils
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://toshia.dip.jp/mikutter.git"
+ inherit git-2
+ KEYWORDS=""
+ EGIT_SOURCEDIR="${WORKDIR}/all"
+else
+ MY_P="${PN}.${PV}"
+ SRC_URI="http://mikutter.hachune.net/bin/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RUBY_S="${PN}"
+fi
+
+DESCRIPTION="mikutter is simple, powerful and moeful twitter client"
+HOMEPAGE="http://mikutter.hachune.net/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+libnotify sound"
+
+DEPEND=""
+RDEPEND="libnotify? ( x11-libs/libnotify )
+ sound? ( media-sound/alsa-utils )"
+
+ruby_add_rdepend "dev-ruby/addressable
+ dev-ruby/bsearch
+ dev-ruby/json
+ dev-ruby/memoize
+ >=dev-ruby/oauth-0.4.7
+ dev-ruby/ruby-gtk2
+ dev-ruby/typed-array
+ virtual/ruby-ssl"
+
+all_ruby_unpack() {
+ if [ "${PV}" = "9999" ];then
+ git-2_src_unpack
+ else
+ default
+ fi
+}
+
+each_ruby_install() {
+ exeinto /usr/share/mikutter
+ doexe mikutter.rb
+ insinto /usr/share/mikutter
+ doins -r core plugin
+ exeinto /usr/bin
+ doexe "${FILESDIR}"/mikutter
+ dodoc README
+ make_desktop_entry mikutter Mikutter \
+ /usr/share/mikutter/core/skin/data/icon.png
+}