summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-09-10 08:08:32 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-09-10 08:08:32 +0000
commit5c963e254e6954f0aea10ee9148ab94aa0982df6 (patch)
tree0916264c3cb94ba997b613db64b2bbb3b07f4238 /net-misc/neon/neon-0.25.3.ebuild
parentStable on ppc and hppa (diff)
downloadgentoo-2-5c963e254e6954f0aea10ee9148ab94aa0982df6.tar.gz
gentoo-2-5c963e254e6954f0aea10ee9148ab94aa0982df6.tar.bz2
gentoo-2-5c963e254e6954f0aea10ee9148ab94aa0982df6.zip
version bump. remove old and security vulnerable versions
(Portage version: 2.0.52-r1)
Diffstat (limited to 'net-misc/neon/neon-0.25.3.ebuild')
-rw-r--r--net-misc/neon/neon-0.25.3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-misc/neon/neon-0.25.3.ebuild b/net-misc/neon/neon-0.25.3.ebuild
new file mode 100644
index 000000000000..1753b8751ee8
--- /dev/null
+++ b/net-misc/neon/neon-0.25.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.25.3.ebuild,v 1.1 2005/09/10 08:08:32 dragonheart Exp $
+
+DESCRIPTION="HTTP and WebDAV client library"
+HOMEPAGE="http://www.webdav.org/neon/"
+SRC_URI="http://www.webdav.org/neon/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ssl zlib expat"
+# socks5
+
+DEPEND="expat? ( dev-libs/expat )
+ !expat? ( dev-libs/libxml2 )
+ ssl? ( >=dev-libs/openssl-0.9.6f )
+ zlib? ( sys-libs/zlib )"
+
+# gnutls not supported yet
+# gnutls? ( net-libs/gnutls )
+# !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6f ) )
+
+src_unpack() {
+ unpack ${A}
+ if use userland_Darwin ; then
+ sed -i -e "s:GXX:GCC:g" ${S}/configure || die "sed failed"
+ fi
+}
+
+src_compile() {
+ local myc=""
+ use expat && myc="${myc} --with-expat" || myc="${myc} --with-xml2"
+
+# if use gnutls
+# then
+# myc="${myc} --with-ssl=gnutls"
+# else
+# myc="${myc} $(use_with ssl ssl openssl)"
+# fi
+
+# Socks5 not quite there yet
+# $(use_enable socks5 socks) \
+
+ econf \
+ --enable-shared \
+ $(use_with zlib) \
+ $(use_with ssl) \
+ ${myc} \
+ || die "econf failed"
+ emake || die 'make failed'
+}
+
+src_install() {
+ make DESTDIR=${D} install || die 'install failed'
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/*
+}