summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-01-11 06:03:13 +0000
committerMike Gilbert <floppym@gentoo.org>2015-01-11 06:03:13 +0000
commitbfb6bc622528cda2f8257f2bb6bb120a683cab4f (patch)
tree633fea995fd95a6b2506c7a812b343a3ec75bc8c /net-misc/netifrc
parentVersion bump; also remove the old version as GCal no longer offers the old AP... (diff)
downloadgentoo-2-bfb6bc622528cda2f8257f2bb6bb120a683cab4f.tar.gz
gentoo-2-bfb6bc622528cda2f8257f2bb6bb120a683cab4f.tar.bz2
gentoo-2-bfb6bc622528cda2f8257f2bb6bb120a683cab4f.zip
Fix sed of systemd unit.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'net-misc/netifrc')
-rw-r--r--net-misc/netifrc/ChangeLog6
-rw-r--r--net-misc/netifrc/netifrc-0.3.0.ebuild4
-rw-r--r--net-misc/netifrc/netifrc-9999.ebuild4
3 files changed, 9 insertions, 5 deletions
diff --git a/net-misc/netifrc/ChangeLog b/net-misc/netifrc/ChangeLog
index 8f0888a984a4..291d362bc58a 100644
--- a/net-misc/netifrc/ChangeLog
+++ b/net-misc/netifrc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/netifrc
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netifrc/ChangeLog,v 1.39 2015/01/09 22:53:15 vikraman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netifrc/ChangeLog,v 1.40 2015/01/11 06:03:13 floppym Exp $
+
+ 11 Jan 2015; Mike Gilbert <floppym@gentoo.org> netifrc-0.3.0.ebuild,
+ netifrc-9999.ebuild:
+ Fix sed of systemd unit.
09 Jan 2015; Vikraman Choudhury (vikraman) <vikraman@gentoo.org>
netifrc-0.3.0.ebuild:
diff --git a/net-misc/netifrc/netifrc-0.3.0.ebuild b/net-misc/netifrc/netifrc-0.3.0.ebuild
index 890c6c42d307..eed21dbc0777 100644
--- a/net-misc/netifrc/netifrc-0.3.0.ebuild
+++ b/net-misc/netifrc/netifrc-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netifrc/netifrc-0.3.0.ebuild,v 1.2 2015/01/09 22:53:15 vikraman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netifrc/netifrc-0.3.0.ebuild,v 1.3 2015/01/11 06:03:13 floppym Exp $
EAPI=5
@@ -54,7 +54,7 @@ src_install() {
# Install the service file
LIBEXECDIR=${EPREFIX}/lib/${PN}
UNIT_DIR="$(systemd_get_unitdir)"
- sed "s:@LIBEXECDIR@:${LIBEXECDIR}:" "${S}/systemd/net_at.service" > "${T}/net_at.service"
+ sed "s:@LIBEXECDIR@:${LIBEXECDIR}:" "${S}/systemd/net_at.service.in" > "${T}/net_at.service" || die
systemd_newunit "${T}/net_at.service" 'net@.service'
dosym "${UNIT_DIR}/net@.service" "${UNIT_DIR}/net@lo.service"
}
diff --git a/net-misc/netifrc/netifrc-9999.ebuild b/net-misc/netifrc/netifrc-9999.ebuild
index c78452cd227a..804663f296c9 100644
--- a/net-misc/netifrc/netifrc-9999.ebuild
+++ b/net-misc/netifrc/netifrc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netifrc/netifrc-9999.ebuild,v 1.9 2015/01/09 17:30:42 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netifrc/netifrc-9999.ebuild,v 1.10 2015/01/11 06:03:13 floppym Exp $
EAPI=5
@@ -54,7 +54,7 @@ src_install() {
# Install the service file
LIBEXECDIR=${EPREFIX}/lib/${PN}
UNIT_DIR="$(systemd_get_unitdir)"
- sed "s:@LIBEXECDIR@:${LIBEXECDIR}:" "${S}/systemd/net_at.service" > "${T}/net_at.service"
+ sed "s:@LIBEXECDIR@:${LIBEXECDIR}:" "${S}/systemd/net_at.service.in" > "${T}/net_at.service" || die
systemd_newunit "${T}/net_at.service" 'net@.service'
dosym "${UNIT_DIR}/net@.service" "${UNIT_DIR}/net@lo.service"
}