summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-04 20:22:42 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-04 20:22:42 +0000
commit9129050add55c72c29b024027ae45459bbdaee1e (patch)
treeff433e496bbb4b9610dffc7c22a8fa909dba1715 /net-misc/proxytunnel
parentStable on x86 (diff)
downloadgentoo-2-9129050add55c72c29b024027ae45459bbdaee1e.tar.gz
gentoo-2-9129050add55c72c29b024027ae45459bbdaee1e.tar.bz2
gentoo-2-9129050add55c72c29b024027ae45459bbdaee1e.zip
Version bump #121574 by Andrew Dorney.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'net-misc/proxytunnel')
-rw-r--r--net-misc/proxytunnel/ChangeLog11
-rw-r--r--net-misc/proxytunnel/files/digest-proxytunnel-1.5.03
-rw-r--r--net-misc/proxytunnel/files/proxytunnel-1.5.0-accept-takes-socklen_t.patch11
-rw-r--r--net-misc/proxytunnel/files/proxytunnel-1.5.0-build.patch27
-rw-r--r--net-misc/proxytunnel/proxytunnel-1.5.0.ebuild33
5 files changed, 83 insertions, 2 deletions
diff --git a/net-misc/proxytunnel/ChangeLog b/net-misc/proxytunnel/ChangeLog
index a898c62dbbce..f80e2fe48bd0 100644
--- a/net-misc/proxytunnel/ChangeLog
+++ b/net-misc/proxytunnel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/proxytunnel
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/proxytunnel/ChangeLog,v 1.7 2004/11/02 18:44:15 klieber Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/proxytunnel/ChangeLog,v 1.8 2006/02/04 20:22:42 vapier Exp $
+
+*proxytunnel-1.5.0 (04 Feb 2006)
+
+ 04 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/proxytunnel-1.5.0-accept-takes-socklen_t.patch,
+ +files/proxytunnel-1.5.0-build.patch, +proxytunnel-1.5.0.ebuild:
+ Version bump #121574 by Andrew Dorney.
02 Nov 2004; Kurt Lieber <klieber@gentoo.org> proxytunnel-1.2.3.ebuild:
tested/marked stable on x86
diff --git a/net-misc/proxytunnel/files/digest-proxytunnel-1.5.0 b/net-misc/proxytunnel/files/digest-proxytunnel-1.5.0
new file mode 100644
index 000000000000..7a9a47e07327
--- /dev/null
+++ b/net-misc/proxytunnel/files/digest-proxytunnel-1.5.0
@@ -0,0 +1,3 @@
+MD5 2a36409580391e25421fc06e82eed4ce proxytunnel-1.5.0.tgz 56775
+RMD160 5377c470365bb114ecca77557286615b2b0acb4a proxytunnel-1.5.0.tgz 56775
+SHA256 82f6e5ea8c425d5b3a86c0670cfbc3ebf6f805e4ceff5d4ab692dbf32cf600a6 proxytunnel-1.5.0.tgz 56775
diff --git a/net-misc/proxytunnel/files/proxytunnel-1.5.0-accept-takes-socklen_t.patch b/net-misc/proxytunnel/files/proxytunnel-1.5.0-accept-takes-socklen_t.patch
new file mode 100644
index 000000000000..80365fa97ab6
--- /dev/null
+++ b/net-misc/proxytunnel/files/proxytunnel-1.5.0-accept-takes-socklen_t.patch
@@ -0,0 +1,11 @@
+--- proxytunnel.c.orig 2006-02-04 15:20:47.000000000 -0500
++++ proxytunnel.c 2006-02-04 15:21:22.000000000 -0500
+@@ -149,7 +149,7 @@
+ int listen_sd;
+ struct sockaddr_in sa_serv;
+ struct sockaddr_in sa_cli;
+- size_t client_len;
++ socklen_t client_len;
+ int pid = 0;
+ int sd_client;
+ char buf[80];
diff --git a/net-misc/proxytunnel/files/proxytunnel-1.5.0-build.patch b/net-misc/proxytunnel/files/proxytunnel-1.5.0-build.patch
new file mode 100644
index 000000000000..01bf0d565f2c
--- /dev/null
+++ b/net-misc/proxytunnel/files/proxytunnel-1.5.0-build.patch
@@ -0,0 +1,27 @@
+--- Makefile
++++ Makefile
+@@ -2,11 +2,11 @@
+ #
+ # Please uncomment the appropriate settings
+
+-CC = gcc
+-CFLAGS = -Wall -DHAVE_GETOPT_LONG
+-LDFLAGS =
+-INSTALLPATH = $(DESTDIR)/usr/local/bin
+-MANPATH = $(DESTDIR)/usr/man/man1
++CC ?= gcc
++CFLAGS += -Wall -DHAVE_GETOPT_LONG
++LDFLAGS +=
++INSTALLPATH = $(DESTDIR)/usr/bin
++MANPATH = $(DESTDIR)/usr/share/man/man1
+
+ PROGNAME = proxytunnel
+ OBJ = proxytunnel.o \
+@@ -27,6 +27,6 @@
+ @rm -f $(PROGNAME) $(OBJ)
+
+ install:
+- mkdir -p $(INSTALLPATH)
++ mkdir -p $(INSTALLPATH) $(MANPATH)
+ install -g root -m755 -o root $(PROGNAME) $(INSTALLPATH)/$(PROGNAME)
+ install -g root -m644 -o root debian/$(PROGNAME).1 $(MANPATH)/$(PROGNAME).1
diff --git a/net-misc/proxytunnel/proxytunnel-1.5.0.ebuild b/net-misc/proxytunnel/proxytunnel-1.5.0.ebuild
new file mode 100644
index 000000000000..773b6502dfe3
--- /dev/null
+++ b/net-misc/proxytunnel/proxytunnel-1.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/proxytunnel/proxytunnel-1.5.0.ebuild,v 1.1 2006/02/04 20:22:42 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="program that connects stdin and stdout to a server somewhere on the network, through a standard HTTPS proxy"
+HOMEPAGE="http://proxytunnel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/proxytunnel/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="static"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-accept-takes-socklen_t.patch
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc CHANGES CREDITS README
+}