summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-11-27 14:43:07 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-11-27 14:43:07 +0000
commit9e5182e34a4cc53fc9b0642a6aba99816682d4b9 (patch)
tree2791537d5c4cb6ee4732350f86670938ef2614d3 /net-misc/pyhoca-gui
parentSupport python 3.4 (diff)
downloadgentoo-2-9e5182e34a4cc53fc9b0642a6aba99816682d4b9.tar.gz
gentoo-2-9e5182e34a4cc53fc9b0642a6aba99816682d4b9.tar.bz2
gentoo-2-9e5182e34a4cc53fc9b0642a6aba99816682d4b9.zip
Initial commit
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-misc/pyhoca-gui')
-rw-r--r--net-misc/pyhoca-gui/ChangeLog10
-rw-r--r--net-misc/pyhoca-gui/metadata.xml10
-rw-r--r--net-misc/pyhoca-gui/pyhoca-gui-0.5.0.3.ebuild35
3 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/pyhoca-gui/ChangeLog b/net-misc/pyhoca-gui/ChangeLog
new file mode 100644
index 000000000000..c89ee8fc71ff
--- /dev/null
+++ b/net-misc/pyhoca-gui/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/pyhoca-gui
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pyhoca-gui/ChangeLog,v 1.1 2014/11/27 14:43:07 voyageur Exp $
+
+*pyhoca-gui-0.5.0.3 (27 Nov 2014)
+
+ 27 Nov 2014; Bernard Cafarelli <voyageur@gentoo.org>
+ +pyhoca-gui-0.5.0.3.ebuild, +metadata.xml:
+ Initial commit
+
diff --git a/net-misc/pyhoca-gui/metadata.xml b/net-misc/pyhoca-gui/metadata.xml
new file mode 100644
index 000000000000..1edb00b503c0
--- /dev/null
+++ b/net-misc/pyhoca-gui/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>nx</herd>
+ <longdescription>
+PyHoca-GUI is a client implementation for X2Go using the project's Python X2Go client API (a Python module). PyHoca-GUI uses wxPython for rendering graphical desktop elements (menus, dialog boxes etc.).
+
+PyHoca-GUI is designed as a very minimal GUI that behaves very similar to GNOME's network manager applet (nm-applet). It appears as a small Phoca icon (a little seal) that docks to your systray panel (also called notification area) and allows you to manage multiple X2go sessions simultaneously.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.3.ebuild b/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.3.ebuild
new file mode 100644
index 000000000000..b5157bd90f2d
--- /dev/null
+++ b/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.3.ebuild,v 1.1 2014/11/27 14:43:07 voyageur Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="X2Go graphical client applet"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/notify-python[${PYTHON_USEDEP}]
+ dev-python/pycups[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ >=net-misc/python-x2go-0.5.0.0[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install
+ python_doexe ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/man1/*
+}