summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2013-03-06 21:37:48 +0000
committerChristian Birchinger <joker@gentoo.org>2013-03-06 21:37:48 +0000
commit0e794105cc71b052ac70267c9a6e1df5f7640db8 (patch)
treeb3b5ec48a211ce1c0e872f94ea07ee0ab1da61c5 /net-misc/r8168
parentFix test execution wrt bug#459174. Thanks to Alphat-PC for the patch. (diff)
downloadgentoo-2-0e794105cc71b052ac70267c9a6e1df5f7640db8.tar.gz
gentoo-2-0e794105cc71b052ac70267c9a6e1df5f7640db8.tar.bz2
gentoo-2-0e794105cc71b052ac70267c9a6e1df5f7640db8.zip
Added a patch for Linux 3.8 support
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0x0151863A67652900!)
Diffstat (limited to 'net-misc/r8168')
-rw-r--r--net-misc/r8168/ChangeLog8
-rw-r--r--net-misc/r8168/files/r8168-8.035.00-build-3.8.patch47
-rw-r--r--net-misc/r8168/r8168-8.035.00-r1.ebuild36
3 files changed, 90 insertions, 1 deletions
diff --git a/net-misc/r8168/ChangeLog b/net-misc/r8168/ChangeLog
index 2ea5b5aaa0cf..ef9df6c84a11 100644
--- a/net-misc/r8168/ChangeLog
+++ b/net-misc/r8168/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/r8168
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/r8168/ChangeLog,v 1.14 2013/01/12 14:48:24 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/r8168/ChangeLog,v 1.15 2013/03/06 21:37:48 joker Exp $
+
+*r8168-8.035.00-r1 (06 Mar 2013)
+
+ 06 Mar 2013; Christian Birchinger <joker@gentoo.org>
+ +r8168-8.035.00-r1.ebuild, +files/r8168-8.035.00-build-3.8.patch:
+ Added a patch for Linux 3.8 support
*r8168-8.035.00 (12 Jan 2013)
diff --git a/net-misc/r8168/files/r8168-8.035.00-build-3.8.patch b/net-misc/r8168/files/r8168-8.035.00-build-3.8.patch
new file mode 100644
index 000000000000..7865e8563921
--- /dev/null
+++ b/net-misc/r8168/files/r8168-8.035.00-build-3.8.patch
@@ -0,0 +1,47 @@
+--- src/r8168_n.c.orig 2013-02-20 05:14:51.408481092 +0000
++++ src/r8168_n.c 2013-02-20 05:17:55.212379684 +0000
+@@ -14541,7 +14541,7 @@
+ spin_unlock_irqrestore(&tp->phy_lock, flags);
+ }
+
+-static int __devinit
++static int
+ rtl8168_init_board(struct pci_dev *pdev,
+ struct net_device **dev_out,
+ void __iomem **ioaddr_out)
+@@ -14711,7 +14711,7 @@
+ goto out;
+ }
+
+-static void __devinit
++static void
+ rtl8168_init_sequence(struct rtl8168_private *tp)
+ {
+ void __iomem *ioaddr = tp->mmio_addr;
+@@ -14964,7 +14964,7 @@
+ };
+ #endif
+
+-static int __devinit
++static int
+ rtl8168_init_one(struct pci_dev *pdev,
+ const struct pci_device_id *ent)
+ {
+@@ -15128,7 +15128,7 @@
+ return 0;
+ }
+
+-static void __devexit
++static void
+ rtl8168_remove_one(struct pci_dev *pdev)
+ {
+ struct net_device *dev = pci_get_drvdata(pdev);
+@@ -17649,7 +17649,7 @@
+ .name = MODULENAME,
+ .id_table = rtl8168_pci_tbl,
+ .probe = rtl8168_init_one,
+- .remove = __devexit_p(rtl8168_remove_one),
++ .remove = rtl8168_remove_one,
+ #if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,11)
+ .shutdown = rtl8168_shutdown,
+ #endif
diff --git a/net-misc/r8168/r8168-8.035.00-r1.ebuild b/net-misc/r8168/r8168-8.035.00-r1.ebuild
new file mode 100644
index 000000000000..b9d74d7eda77
--- /dev/null
+++ b/net-misc/r8168/r8168-8.035.00-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/r8168/r8168-8.035.00-r1.ebuild,v 1.1 2013/03/06 21:37:48 joker Exp $
+
+EAPI=4
+
+inherit linux-mod eutils
+
+DESCRIPTION="r8168 driver for Realtek 8111/8168 PCI-E NICs"
+HOMEPAGE="http://www.realtek.com.tw"
+SRC_URI="http://r8168.googlecode.com/files/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+MODULE_NAMES="r8168(net:${S}/src)"
+BUILD_TARGETS="modules"
+CONFIG_CHECK="!R8169"
+
+ERROR_R8169="${P} requires Realtek 8169 PCI Gigabit Ethernet adapter (CONFIG_R8169) to be DISABLED"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build-3.8.patch"
+}
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README
+}