summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2005-10-02 18:53:22 +0000
committerLance Albertson <ramereth@gentoo.org>2005-10-02 18:53:22 +0000
commit24250dce6de8e65b6d625933964358f28cc754a0 (patch)
tree5a729f67567fe19ce80f5073cb2db687f5fd1c36 /net-misc/stunnel
parentVersion Bump Closes bug #107835. Removed old versions. (diff)
downloadgentoo-2-24250dce6de8e65b6d625933964358f28cc754a0.tar.gz
gentoo-2-24250dce6de8e65b6d625933964358f28cc754a0.tar.bz2
gentoo-2-24250dce6de8e65b6d625933964358f28cc754a0.zip
fix cert issue
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-misc/stunnel')
-rw-r--r--net-misc/stunnel/ChangeLog8
-rw-r--r--net-misc/stunnel/Manifest2
-rw-r--r--net-misc/stunnel/files/digest-stunnel-4.09-r11
-rw-r--r--net-misc/stunnel/stunnel-4.09-r1.ebuild76
4 files changed, 86 insertions, 1 deletions
diff --git a/net-misc/stunnel/ChangeLog b/net-misc/stunnel/ChangeLog
index a88197870612..774b0475a965 100644
--- a/net-misc/stunnel/ChangeLog
+++ b/net-misc/stunnel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/stunnel
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/ChangeLog,v 1.45 2005/06/25 00:45:38 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/ChangeLog,v 1.46 2005/10/02 18:53:22 ramereth Exp $
+
+*stunnel-4.09-r1 (02 Oct 2005)
+
+ 02 Oct 2005; Lance Albertson <ramereth@gentoo.org>
+ +stunnel-4.09-r1.ebuild:
+ * Cert fix
*stunnel-4.10-r1 (25 Jun 2005)
diff --git a/net-misc/stunnel/Manifest b/net-misc/stunnel/Manifest
index e44b85eab21c..26ab8f74bb79 100644
--- a/net-misc/stunnel/Manifest
+++ b/net-misc/stunnel/Manifest
@@ -4,6 +4,7 @@ MD5 3c7d56a1f6a95f21ceb95ddf5c76073c metadata.xml 703
MD5 b2b41fa38d0e49a159629341ba9f8f48 stunnel-4.05.ebuild 1755
MD5 1217dcb1ea077fa30403aa71cdaf7480 stunnel-4.09.ebuild 2127
MD5 3bd273c44186325bbd29a68101e43841 stunnel-4.10-r1.ebuild 2271
+MD5 f7c4f8973d65787348f780bb8655a9b8 stunnel-4.09-r1.ebuild 2226
MD5 9193cc027bed086a3852dc7189602f0b files/stunnel.conf 1423
MD5 f4879ffd6081bf6db14af6fac04f6b9e files/stunnel.rc6 933
MD5 c0fb8fc4f6d919edc9d76e0f423873eb files/digest-stunnel-4.05 64
@@ -18,3 +19,4 @@ MD5 093291f53a8df7fb48928a750c4074f5 files/digest-stunnel-4.10-r1 64
MD5 09f88a8e4bd6ae556b11c82d2c09de32 files/stunnel-4.10-inetd.patch 818
MD5 b42ca1fbeb5d6454de36aac4cb893294 files/stunnel-3.26-gentoo.diff 941
MD5 ea2086dcf69dddf6d075a7040d209335 files/digest-stunnel-3.26 64
+MD5 b562ecc7a9dab7e2e2582a0601b42569 files/digest-stunnel-4.09-r1 64
diff --git a/net-misc/stunnel/files/digest-stunnel-4.09-r1 b/net-misc/stunnel/files/digest-stunnel-4.09-r1
new file mode 100644
index 000000000000..f3ec67c1f42d
--- /dev/null
+++ b/net-misc/stunnel/files/digest-stunnel-4.09-r1
@@ -0,0 +1 @@
+MD5 2077669b04c36e4c0baa68348e8860a7 stunnel-4.09.tar.gz 484745
diff --git a/net-misc/stunnel/stunnel-4.09-r1.ebuild b/net-misc/stunnel/stunnel-4.09-r1.ebuild
new file mode 100644
index 000000000000..8079e6e9f69b
--- /dev/null
+++ b/net-misc/stunnel/stunnel-4.09-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-4.09-r1.ebuild,v 1.1 2005/10/02 18:53:22 ramereth Exp $
+
+inherit ssl-cert eutils flag-o-matic
+
+DESCRIPTION="TLS/SSL - Port Wrapper"
+HOMEPAGE="http://stunnel.mirt.net/"
+SRC_URI="http://www.stunnel.org/download/stunnel/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE="ipv6 selinux tcpd"
+
+DEPEND="virtual/libc
+ >=dev-libs/openssl-0.9.6j"
+RDEPEND=">=dev-libs/openssl-0.9.6j
+ selinux? ( sec-policy/selinux-stunnel )"
+
+src_unpack() {
+ unpack ${A}
+ # Hack away generation of certificate
+ sed -i s/^install-data-local:/do-not-run-this:/ "${S}"/tools/Makefile.in
+}
+
+src_compile() {
+ econf \
+ `use_enable ipv6`\
+ `use_with tcpd tcp-wrappers` \
+ || die "econf died"
+ emake || die "emake died"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ rm -rf ${D}/usr/share/doc/${PN}
+ rm -f ${D}/{etc/stunnel/stunnel.conf-sample,usr/sbin/stunnel3}
+ rm -f ${D}/usr/share/man/man8/{stunnel.fr.8,stunnel.pl.8}
+
+ dodoc AUTHORS BUGS CREDITS INSTALL NEWS PORTS README TODO ChangeLog \
+ doc/en/transproxy.txt
+ dohtml doc/stunnel.html doc/en/VNC_StunnelHOWTO.html tools/ca.html \
+ tools/importCA.html
+
+ insinto /etc/stunnel
+ donewins ${FILESDIR}/stunnel.conf stunnel.conf
+ newinitd ${FILESDIR}/stunnel.rc6 stunnel
+ # Check if there's currently an cert already there
+ if [ ! -f /etc/stunnel/stunnel.key ]; then
+ docert stunnel
+ fi
+
+ keepdir /var/run/stunnel
+}
+
+pkg_postinst() {
+ enewgroup stunnel
+ enewuser stunnel -1 -1 -1 stunnel
+
+ chown stunnel:stunnel ${ROOT}/var/run/stunnel
+ chown stunnel:stunnel ${ROOT}/etc/stunnel/stunnel.{conf,crt,csr,key,pem}
+ chmod 0640 ${ROOT}/etc/stunnel/stunnel.{conf,crt,csr,key,pem}
+
+ if [ ! -z "$(egrep '/etc/stunnel/stunnel.pid' \
+ ${ROOT}/etc/stunnel/stunnel.conf )" ] ; then
+
+ ewarn "As of stunnel-4.09, the pid file will be located in /var/run/stunnel."
+ ewarn "Please stop stunnel, etc-update, and start stunnel back up to ensure"
+ ewarn "the update takes place"
+ ewarn ""
+ ewarn "The new location will be /var/run/stunnel/stunnel.pid"
+ ebeep 3
+ epause 3
+ fi
+}