summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-04-26 05:34:23 +0000
committerTod Neidt <tod@gentoo.org>2002-04-26 05:34:23 +0000
commit00600fb5fce7b0485651618bfc36a2672e6a1638 (patch)
tree61ba10d483532843df2d347147ee5f66fce63bdf /net-misc/urlview/urlview-0.9.ebuild
parentAdded db-1 DEPENDency (diff)
downloadgentoo-2-00600fb5fce7b0485651618bfc36a2672e6a1638.tar.gz
gentoo-2-00600fb5fce7b0485651618bfc36a2672e6a1638.tar.bz2
gentoo-2-00600fb5fce7b0485651618bfc36a2672e6a1638.zip
Fixed sandbox violation. Updated syntax.
Diffstat (limited to 'net-misc/urlview/urlview-0.9.ebuild')
-rw-r--r--net-misc/urlview/urlview-0.9.ebuild30
1 files changed, 21 insertions, 9 deletions
diff --git a/net-misc/urlview/urlview-0.9.ebuild b/net-misc/urlview/urlview-0.9.ebuild
index 09951c37b0fa..2b432b47b8e4 100644
--- a/net-misc/urlview/urlview-0.9.ebuild
+++ b/net-misc/urlview/urlview-0.9.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Ben Lutgens <lamer@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/urlview/urlview-0.9.ebuild,v 1.1 2001/07/18 00:46:22 lamer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/urlview/urlview-0.9.ebuild,v 1.2 2002/04/26 05:34:23 tod Exp $
S=${WORKDIR}/${P}
DESCRIPTION="extracts urls from text and will send them to another app"
@@ -12,20 +12,32 @@ DEPEND=">=sys-libs/ncurses-5.2"
#RDEPEND=""
src_compile() {
- try ./configure --infodir=/usr/share/info --mandir=/usr/share/man \
- --prefix=/usr --sysconfdir=/etc --host=${CHOST}
+
+ ./configure \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --host=${CHOST} || die "Configure Failed"
- try emake
- #try make
+ emake || die "Parallel Make Failed"
+
}
src_install () {
- # try make prefix=${D}/usr install
- try make DESTDIR=${D} install
- dodoc README INSTALL ChangeLog AUTHORS COPYING sample.urlview
- dobin url_handler.sh
+ dodir /usr/share/man/man1
+
+ make infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ install || die "Installation Failed"
+
+ dodoc README INSTALL ChangeLog AUTHORS COPYING sample.urlview
+ dobin url_handler.sh
+
}
pkg_postinst() {