summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-05 14:06:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-05 14:06:49 +0000
commitf9be4baa5ae90df64ea2e68e30fa9858fdbdad00 (patch)
tree842f366c8f20ae784dc3b795fdf71537349a1ce8 /net-misc/xrdp
parentProposed enhancement from Arfrever included (diff)
downloadgentoo-2-f9be4baa5ae90df64ea2e68e30fa9858fdbdad00.tar.gz
gentoo-2-f9be4baa5ae90df64ea2e68e30fa9858fdbdad00.tar.bz2
gentoo-2-f9be4baa5ae90df64ea2e68e30fa9858fdbdad00.zip
Fix --as-needed patching to work on both x86 and amd64.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/xrdp')
-rw-r--r--net-misc/xrdp/ChangeLog6
-rw-r--r--net-misc/xrdp/files/xrdp-0.4.1-asneeded.patch12
-rw-r--r--net-misc/xrdp/xrdp-0.4.1.ebuild13
3 files changed, 17 insertions, 14 deletions
diff --git a/net-misc/xrdp/ChangeLog b/net-misc/xrdp/ChangeLog
index b9dea96a4396..f8768c86886c 100644
--- a/net-misc/xrdp/ChangeLog
+++ b/net-misc/xrdp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/xrdp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/xrdp/ChangeLog,v 1.6 2010/01/25 17:33:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/xrdp/ChangeLog,v 1.7 2010/04/05 14:06:49 flameeyes Exp $
+
+ 05 Apr 2010; Diego E. Pettenò <flameeyes@gentoo.org> xrdp-0.4.1.ebuild,
+ files/xrdp-0.4.1-asneeded.patch:
+ Fix --as-needed patching to work on both x86 and amd64.
25 Jan 2010; Raúl Porcel <armin76@gentoo.org> -xrdp-0.3.1.ebuild,
xrdp-0.4.1.ebuild:
diff --git a/net-misc/xrdp/files/xrdp-0.4.1-asneeded.patch b/net-misc/xrdp/files/xrdp-0.4.1-asneeded.patch
index 416b2f09d9ad..e44026a82133 100644
--- a/net-misc/xrdp/files/xrdp-0.4.1-asneeded.patch
+++ b/net-misc/xrdp/files/xrdp-0.4.1-asneeded.patch
@@ -3,9 +3,9 @@
@@ -14,17 +14,18 @@
DEFINES = -DLIBSCP_CLIENT
- CFLAGS += -I../../common -I../ -I/usr/include/nptl -I../libscp $(DEFINES)
--LDFLAGS = -L/usr/gnu/lib -L/usr/lib64/nptl -L../libscp -Wl,-rpath,/usr/lib64/xrdp -lpthread -ldl -lscp
-+LDFLAGS = -L/usr/gnu/lib -L/usr/lib64/nptl -L../libscp -Wl,-rpath,/usr/lib64/xrdp
+ CFLAGS = -Wall -O2 -I../../common -I../ -I/usr/include/nptl -I../libscp $(DEFINES)
+-LDFLAGS = -L/usr/gnu/lib -L/usr/lib/nptl -L../libscp -Wl,-rpath,. -lpthread -ldl -lscp
++LDFLAGS = -L/usr/gnu/lib -L/usr/lib/nptl -L../libscp -Wl,-rpath,.
+LIBS = -lpthread -ldl -lscp
C_OS_FLAGS = $(CFLAGS) -c
CC = gcc
@@ -27,9 +27,9 @@
@@ -18,7 +18,8 @@
-DSESMAN_DESTDIR=\"$(DESTDIR)\"
- CFLAGS += -I../common -I/usr/include/nptl -I./libscp $(DEFINES)
--LDFLAGS = -L/usr/gnu/lib -L/usr/lib64/nptl -L./libscp -Wl,-rpath,/usr/lib64/xrdp -lpthread -ldl -lscp
-+LDFLAGS = -L/usr/gnu/lib -L/usr/lib64/nptl -L./libscp -Wl,-rpath,/usr/lib64/xrdp
+ CFLAGS = -Wall -O2 -I../common -I/usr/include/nptl -I./libscp $(DEFINES)
+-LDFLAGS = -L/usr/gnu/lib -L/usr/lib/nptl -L./libscp -Wl,-rpath,. -lpthread -ldl -lscp
++LDFLAGS = -L/usr/gnu/lib -L/usr/lib/nptl -L./libscp -Wl,-rpath,.
+LIBS=-lpthread -ldl -lscp
C_OS_FLAGS = $(CFLAGS) -c
CC = gcc
diff --git a/net-misc/xrdp/xrdp-0.4.1.ebuild b/net-misc/xrdp/xrdp-0.4.1.ebuild
index b5dd15818731..bfe02c2afb97 100644
--- a/net-misc/xrdp/xrdp-0.4.1.ebuild
+++ b/net-misc/xrdp/xrdp-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/xrdp/xrdp-0.4.1.ebuild,v 1.3 2010/01/25 17:33:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/xrdp/xrdp-0.4.1.ebuild,v 1.4 2010/04/05 14:06:49 flameeyes Exp $
EAPI="2"
@@ -26,18 +26,17 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${P}-curdir.patch"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
# fix cflags, broken paths, multilib, and insecure rpath in all makefiles
- for MAKE in $(find . -name Makefile) ; do
- sed -i "s:CFLAGS = -Wall -O. :CFLAGS += :
+ find . -name Makefile -print0 | \
+ xargs -0 sed \
+ -i "s:CFLAGS = -Wall -O. :CFLAGS += :
s:/usr/xrdp:${DESTDIR}:g
s:/usr/lib/:/usr/$(get_libdir)/:g
- s:rpath,\.:rpath,${DESTDIR}:g" ${MAKE}
- done
+ s:rpath,\.:rpath,${DESTDIR}:g"
sed -i '/instfiles\/xrdp_control1.sh/ d' Makefile
-
- epatch "${FILESDIR}"/${P}-asneeded.patch
}
src_compile() {