summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-06-30 09:43:15 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-06-30 09:43:15 +0000
commit5ba3dba33c7fd52e0480797252798a178e9eb488 (patch)
tree9072b7bb38618bf856f0c2a55ac00a060ea45348 /net-misc
parentFix changelog, bug 275873 (diff)
downloadgentoo-2-5ba3dba33c7fd52e0480797252798a178e9eb488.tar.gz
gentoo-2-5ba3dba33c7fd52e0480797252798a178e9eb488.tar.bz2
gentoo-2-5ba3dba33c7fd52e0480797252798a178e9eb488.zip
Fix automagic dependency on libsamplerate, bug #275851. Also clean ebuild a bit
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rdesktop/ChangeLog11
-rw-r--r--net-misc/rdesktop/files/rdesktop-1.6.0-sound_configure.patch15
-rw-r--r--net-misc/rdesktop/rdesktop-1.6.0-r2.ebuild77
3 files changed, 101 insertions, 2 deletions
diff --git a/net-misc/rdesktop/ChangeLog b/net-misc/rdesktop/ChangeLog
index d5fe8221630a..b57f0a3ac0fd 100644
--- a/net-misc/rdesktop/ChangeLog
+++ b/net-misc/rdesktop/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/rdesktop
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rdesktop/ChangeLog,v 1.111 2008/05/21 14:13:19 voyageur Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rdesktop/ChangeLog,v 1.112 2009/06/30 09:43:15 voyageur Exp $
+
+*rdesktop-1.6.0-r2 (30 Jun 2009)
+
+ 30 Jun 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ +rdesktop-1.6.0-r2.ebuild, +files/rdesktop-1.6.0-sound_configure.patch:
+ Fix automagic dependency on libsamplerate, bug #275851. Also clean ebuild
+ a bit
*rdesktop-1.6.0-r1 (21 May 2008)
diff --git a/net-misc/rdesktop/files/rdesktop-1.6.0-sound_configure.patch b/net-misc/rdesktop/files/rdesktop-1.6.0-sound_configure.patch
new file mode 100644
index 000000000000..8e64ba8b48cb
--- /dev/null
+++ b/net-misc/rdesktop/files/rdesktop-1.6.0-sound_configure.patch
@@ -0,0 +1,15 @@
+--- configure.ac.orig 2009-06-30 10:35:14.000000000 +0200
++++ configure.ac 2009-06-30 11:35:10.000000000 +0200
+@@ -228,7 +228,11 @@
+ if test -n "$PKG_CONFIG"; then
+ PKG_CHECK_MODULES(LIBAO, ao, [HAVE_LIBAO=1], [HAVE_LIBAO=0])
+ PKG_CHECK_MODULES(ALSA, alsa, [HAVE_ALSA=1], [HAVE_ALSA=0])
+- PKG_CHECK_MODULES(LIBSAMPLERATE, samplerate, [HAVE_LIBSAMPLERATE=1], [HAVE_LIBSAMPLERATE=0])
++ AC_ARG_WITH(libsamplerate,
++ [ --without-libsamplerate disable libsamplerate support])
++ if test "x$with_libsamplerate" != "xno"; then
++ PKG_CHECK_MODULES(LIBSAMPLERATE, samplerate, [HAVE_LIBSAMPLERATE=1], [HAVE_LIBSAMPLERATE=0])
++ fi
+ if test x"$HAVE_LIBSAMPLERATE" = "x1"; then
+ AC_DEFINE(HAVE_LIBSAMPLERATE)
+ if test x"$static_libsamplerate" = "xyes"; then
diff --git a/net-misc/rdesktop/rdesktop-1.6.0-r2.ebuild b/net-misc/rdesktop/rdesktop-1.6.0-r2.ebuild
new file mode 100644
index 000000000000..9da6b3967419
--- /dev/null
+++ b/net-misc/rdesktop/rdesktop-1.6.0-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rdesktop/rdesktop-1.6.0-r2.ebuild,v 1.1 2009/06/30 09:43:15 voyageur Exp $
+
+EAPI=2
+
+inherit autotools eutils
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="A Remote Desktop Protocol Client"
+HOMEPAGE="http://rdesktop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa ao debug ipv6 libsamplerate oss pcsc-lite"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+RDEPEND=">=dev-libs/openssl-0.9.6b
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ alsa? ( media-libs/alsa-lib )
+ ao? ( >=media-libs/libao-0.8.6 )
+ libsamplerate? ( media-libs/libsamplerate )
+ pcsc-lite? ( sys-apps/pcsc-lite )"
+DEPEND="${RDEPEND}
+ x11-libs/libXt"
+
+src_prepare() {
+ # Prevent automatic stripping
+ local strip="$(echo '$(STRIP) $(DESTDIR)$(bindir)/rdesktop')"
+ sed -i -e "s:${strip}::" Makefile.in \
+ || die "sed failed in Makefile.in"
+
+ # Automagic dependency on libsamplerate
+ epatch "${FILESDIR}"/${P}-sound_configure.patch
+ eautoreconf
+}
+
+src_configure() {
+ if use ao; then
+ sound_conf=$(use_with ao sound libao)
+ else if use alsa; then
+ sound_conf=$(use_with alsa sound alsa)
+ else
+ sound_conf=$(use_with oss sound oss)
+ fi
+ fi
+
+ econf \
+ --with-openssl=/usr \
+ $(use_with debug) \
+ $(use_with ipv6) \
+ $(use_with libsamplerate) \
+ $(use_enable pcsc-lite smartcard) \
+ ${sound_conf} \
+ || die "configuration failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installation failed"
+ dodoc doc/HACKING doc/TODO doc/keymapping.txt
+
+ # For #180313 - applies to versions >= 1.5.0
+ # Fixes sf.net bug
+ # http://sourceforge.net/tracker/index.php?func=detail&aid=1725634&group_id=24366&atid=381349
+ # check for next version to see if this needs to be removed
+ insinto /usr/share/rdesktop/keymaps
+ newins "${FILESDIR}/rdesktop-keymap-additional" additional
+ newins "${FILESDIR}/rdesktop-keymap-cs" cs
+ newins "${FILESDIR}/rdesktop-keymap-sk" sk
+}