summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2014-04-20 18:21:09 +0000
committerVictor Ostorga <vostorga@gentoo.org>2014-04-20 18:21:09 +0000
commit34898cd725c157538abd2ce257d6840461a4ac63 (patch)
treef37d29642197e569fda538d7cf7ecbcce49ca17b /net-news
parentAdd back keywords to ruby20, ruby21 revision now that activesupport:3.2 is al... (diff)
downloadgentoo-2-34898cd725c157538abd2ce257d6840461a4ac63.tar.gz
gentoo-2-34898cd725c157538abd2ce257d6840461a4ac63.tar.bz2
gentoo-2-34898cd725c157538abd2ce257d6840461a4ac63.zip
Version bump bug 498358
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xE25EE336)
Diffstat (limited to 'net-news')
-rw-r--r--net-news/liferea/ChangeLog9
-rw-r--r--net-news/liferea/liferea-1.10.8.ebuild75
2 files changed, 82 insertions, 2 deletions
diff --git a/net-news/liferea/ChangeLog b/net-news/liferea/ChangeLog
index 005e82f41d05..a7c015e87fca 100644
--- a/net-news/liferea/ChangeLog
+++ b/net-news/liferea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-news/liferea
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/ChangeLog,v 1.240 2013/12/26 14:48:07 maekke Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/ChangeLog,v 1.241 2014/04/20 18:21:09 vostorga Exp $
+
+*liferea-1.10.8 (20 Apr 2014)
+
+ 20 Apr 2014; Victor Ostorga <vostorga@gentoo.org> +liferea-1.10.8.ebuild:
+ Version bump bug 498358
26 Dec 2013; Markus Meier <maekke@gentoo.org> liferea-1.10.3.ebuild:
add ~arm, bug #489108
diff --git a/net-news/liferea/liferea-1.10.8.ebuild b/net-news/liferea/liferea-1.10.8.ebuild
new file mode 100644
index 000000000000..6b8cfcd04113
--- /dev/null
+++ b/net-news/liferea/liferea-1.10.8.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/liferea-1.10.8.ebuild,v 1.1 2014/04/20 18:21:09 vostorga Exp $
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2 pax-utils
+
+MY_P=${P/_/-}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="News Aggregator for RDF/RSS/CDF/Atom/Echo feeds"
+HOMEPAGE="http://liferea.sourceforge.net/"
+SRC_URI="https://github.com/lwindolf/${PN}/releases/download/v${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+IUSE="ayatana libnotify"
+
+RDEPEND="x11-libs/gtk+:3
+ >=dev-libs/glib-2.26.0:2
+ dev-libs/json-glib
+ >=dev-libs/libpeas-1.0.0[gtk]
+ >=net-libs/libsoup-2.28.2:2.4
+ dev-libs/libunique:3
+ >=dev-libs/libxml2-2.6.27:2
+ >=dev-libs/libxslt-1.1.19
+ >=dev-db/sqlite-3.7.0:3
+ >=gnome-base/gconf-1.1.9:2
+ gnome-base/gsettings-desktop-schemas
+ >=net-libs/webkit-gtk-1.6.1:3
+ >=x11-libs/pango-1.4.0
+ ayatana? ( dev-libs/libindicate )
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog README"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-schemas-compile
+ $(use_enable ayatana libindicate)
+ $(use_enable libnotify)"
+}
+
+src_prepare() {
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+
+ # bug #338213
+ # Uses webkit's JIT. Needs mmap('rwx') to generate code in runtime.
+ # MPROTECT policy violation. Will sit here until webkit will
+ # get optional JIT.
+ pax-mark m "${D}"/usr/bin/liferea
+
+ einfo "If you want to enhance the functionality of this package,"
+ einfo "you should consider installing:"
+ einfo " dev-libs/dbus-glib"
+ einfo " net-misc/networkmanager"
+}