summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-05-19 21:33:41 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-05-19 21:33:41 +0000
commit5b09dd61e75f10732675e1d1c746774d989e0d29 (patch)
tree1905ed9876a237a8f697e52088184771b849b9e0 /net-nntp/inn
parentclean old ebuilds (diff)
downloadgentoo-2-5b09dd61e75f10732675e1d1c746774d989e0d29.tar.gz
gentoo-2-5b09dd61e75f10732675e1d1c746774d989e0d29.tar.bz2
gentoo-2-5b09dd61e75f10732675e1d1c746774d989e0d29.zip
Fixed multilib-strict issues and test failures.
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-nntp/inn')
-rw-r--r--net-nntp/inn/ChangeLog6
-rw-r--r--net-nntp/inn/files/inn-2.4.3-runtests.patch58
-rw-r--r--net-nntp/inn/inn-2.4.3.ebuild27
3 files changed, 79 insertions, 12 deletions
diff --git a/net-nntp/inn/ChangeLog b/net-nntp/inn/ChangeLog
index ab84862ccbcc..08ee6da3e8dc 100644
--- a/net-nntp/inn/ChangeLog
+++ b/net-nntp/inn/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-nntp/inn
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/inn/ChangeLog,v 1.13 2007/04/28 16:29:07 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/inn/ChangeLog,v 1.14 2007/05/19 21:33:41 philantrop Exp $
+
+ 19 May 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/inn-2.4.3-runtests.patch, inn-2.4.3.ebuild:
+ Fixed multilib-strict issues and test failures.
28 Apr 2007; Sven Wegener <swegener@gentoo.org> inn-2.4.1.ebuild,
inn-2.4.3.ebuild:
diff --git a/net-nntp/inn/files/inn-2.4.3-runtests.patch b/net-nntp/inn/files/inn-2.4.3-runtests.patch
new file mode 100644
index 000000000000..d614620bbd78
--- /dev/null
+++ b/net-nntp/inn/files/inn-2.4.3-runtests.patch
@@ -0,0 +1,58 @@
+diff -Nur inn-2.4.3.orig/tests/runtests.c inn-2.4.3/tests/runtests.c
+--- inn-2.4.3.orig/tests/runtests.c 2006-03-20 05:14:57.000000000 +0100
++++ inn-2.4.3/tests/runtests.c 2007-05-18 21:42:05.000000000 +0200
+@@ -126,13 +126,13 @@
+ static void sysdie(const char *format, ...);
+ static void *x_malloc(size_t, const char *file, int line);
+ static char *x_strdup(const char *, const char *file, int line);
+-static int test_analyze(const struct testset *);
++static int test_analyze(struct testset *);
+ static int test_batch(const char *testlist);
+ static void test_checkline(const char *line, struct testset *);
+ static void test_fail_summary(const struct testlist *);
+ static int test_init(const char *line, struct testset *);
+ static int test_print_range(int first, int last, int chars, int limit);
+-static void test_summarize(const struct testset *, int status);
++static void test_summarize(struct testset *, int status);
+ static pid_t test_start(const char *path, int *fd);
+ static double tv_diff(const struct timeval *, const struct timeval *);
+ static double tv_seconds(const struct timeval *);
+@@ -369,7 +369,7 @@
+ with a non-zero status, and a negative integer representing the signal
+ that terminated it if it was killed by a signal. */
+ static void
+-test_summarize(const struct testset *ts, int status)
++test_summarize(struct testset *ts, int status)
+ {
+ int i;
+ int missing = 0;
+@@ -436,7 +436,7 @@
+ few special error messages, and then pass it along to test_summarize()
+ for the regular output. */
+ static int
+-test_analyze(const struct testset *ts)
++test_analyze(struct testset *ts)
+ {
+ if (ts->reported) return 0;
+ if (WIFEXITED(ts->status) && WEXITSTATUS(ts->status) != 0) {
+@@ -522,7 +522,7 @@
+ static void
+ test_fail_summary(const struct testlist *fails)
+ {
+- const struct testset *ts;
++ struct testset *ts;
+ int i, chars, total, first, last;
+
+ puts(header);
+diff -Nur inn-2.4.3.orig/tests/lib/snprintf-t.c inn-2.4.3/tests/lib/snprintf-t.c
+--- inn-2.4.3.orig/tests/lib/snprintf-t.c 2006-03-20 05:14:57.000000000 +0100
++++ inn-2.4.3/tests/lib/snprintf-t.c 2007-05-19 12:33:14.000000000 +0200
+@@ -125,7 +125,7 @@
+ test_format(21, true, "abcdefghij4444", 14, "%.10s%n%d", string, &count,
+ 4444);
+ ok(22, count == 10);
+- test_format(23, true, "abcdefghijklmnopqrstuvwxyz01234", 36, "%ln%s%n",
++ test_format(23, true, "abcdefghijklmnopqrstuvwxyz01234", 36, "%n%s%ln",
+ &count, string, &lcount);
+ ok(24, count == 0);
+ ok(25, lcount == 31);
diff --git a/net-nntp/inn/inn-2.4.3.ebuild b/net-nntp/inn/inn-2.4.3.ebuild
index 2e5da35cc8c0..03f0dd27f494 100644
--- a/net-nntp/inn/inn-2.4.3.ebuild
+++ b/net-nntp/inn/inn-2.4.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/inn/inn-2.4.3.ebuild,v 1.7 2007/04/28 16:29:07 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/inn/inn-2.4.3.ebuild,v 1.8 2007/05/19 21:33:41 philantrop Exp $
WANT_AUTOCONF="2.1"
-inherit fixheadtails ssl-cert eutils libtool flag-o-matic autotools
+inherit fixheadtails ssl-cert eutils multilib libtool flag-o-matic autotools
DESCRIPTION="The Internet News daemon, fully featured NNTP server"
HOMEPAGE="http://www.isc.org/products/INN"
@@ -43,18 +43,23 @@ src_unpack() {
# Fixes compatibility problems with sys-libs/db-4.4 and 4.5,
# bug 174680.
epatch ${FILESDIR}/${P}-berkdb45.patch
+
+ # Fixes problems with the test suite.
+ epatch ${FILESDIR}/${P}-runtests.patch
}
src_compile() {
+ elibtoolize
+
append-ldflags $(bindnow-flags)
econf \
- --prefix=/usr/lib/news \
+ --prefix=/usr/$(get_libdir)/news \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --with-control-dir=/usr/lib/news/bin/control \
+ --with-control-dir=/usr/$(get_libdir)/news/bin/control \
--with-etc-dir=/etc/news \
- --with-filter-dir=/usr/lib/news/bin/filter \
+ --with-filter-dir=/usr/$(get_libdir)/news/bin/filter \
--with-db-dir=/var/spool/news/db \
--with-doc-dir=/usr/share/doc/${PF} \
--with-spool-dir=/var/spool/news \
@@ -82,7 +87,7 @@ src_compile() {
src_install() {
make DESTDIR="${D}/" P="" SPECIAL="" install || die "make install failed"
- chown -R root:0 "${D}"/usr/{lib/news/{lib,include},share/{doc,man}}
+ chown -R root:0 "${D}"/usr/{$(get_libdir)/news/{lib,include},share/{doc,man}}
chmod 644 "${D}"/etc/news/*
for file in control.ctl expire.ctl incoming.conf nntpsend.ctl passwd.nntp readers.conf
do
@@ -102,7 +107,7 @@ src_install() {
use ipv6 && dodoc doc/IPv6-info
# So other programs can build against INN. (eg. Suck)
- insinto /usr/lib/news/include
+ insinto /usr/$(get_libdir)/news/include
doins include/*.h
doinitd "${FILESDIR}"/innd innd
@@ -201,12 +206,12 @@ pkg_config() {
chown news:news "${NEWSSPOOL_DIR}"/db/history
chmod 644 "${NEWSSPOOL_DIR}"/db/history
- su - news -c "/usr/lib/news/bin/makedbz -i"
+ su - news -c "/usr/$(get_libdir)/news/bin/makedbz -i"
[[ -f ${NEWSSPOOL_DIR}/db/history.n.dir ]] && mv -f "${NEWSSPOOL_DIR}"/db/history.n.dir "${NEWSSPOOL_DIR}"/db/history.dir
[[ -f ${NEWSSPOOL_DIR}/db/history.n.pag ]] && mv -f "${NEWSSPOOL_DIR}"/db/history.n.pag "${NEWSSPOOL_DIR}"/db/history.pag
[[ -f ${NEWSSPOOL_DIR}/db/history.n.hash ]] && mv -f "${NEWSSPOOL_DIR}"/db/history.n.hash "${NEWSSPOOL_DIR}"/db/history.hash
[[ -f ${NEWSSPOOL_DIR}/db/history.n.index ]] && mv -f "${NEWSSPOOL_DIR}"/db/history.n.index "${NEWSSPOOL_DIR}"/db/history.index
- su - news -c /usr/lib/news/bin/makehistory
+ su - news -c /usr/$(get_libdir)/news/bin/makehistory
else
NEWS_ERRFLAG="1"
eerror
@@ -234,13 +239,13 @@ pkg_config() {
chmod 644 /etc/news/inn.conf
fi
- INNCHECK_LINES="$(su - news -c "/usr/lib/news/bin/inncheck | wc -l")"
+ INNCHECK_LINES="$(su - news -c "/usr/$(get_libdir)/news/bin/inncheck | wc -l")"
if [[ ${INNCHECK_LINES} -gt 0 ]]
then
NEWS_ERRFLAG="1"
ewarn "inncheck most certainly found an error."
ewarn "Please check its output:"
- eerror "`su - news -c /usr/lib/news/bin/inncheck`"
+ eerror "`su - news -c /usr/$(get_libdir)/news/bin/inncheck`"
fi
if [[ ${NEWS_ERRFLAG} -gt 0 ]]