summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-07-25 15:05:56 +0000
committerAlin Năstac <mrness@gentoo.org>2006-07-25 15:05:56 +0000
commit559e4384fd7a9825cdaa07bd5e1cbccc91d60e13 (patch)
treefa87fea21e818696cf69bd573ad316a415c54dca /net-proxy/wwwoffle
parentremove selinux-ethereal - bug #141156 (diff)
downloadgentoo-2-559e4384fd7a9825cdaa07bd5e1cbccc91d60e13.tar.gz
gentoo-2-559e4384fd7a9825cdaa07bd5e1cbccc91d60e13.tar.bz2
gentoo-2-559e4384fd7a9825cdaa07bd5e1cbccc91d60e13.zip
Add patch which fixes page reloads (#141697).
(Portage version: 2.1-r1)
Diffstat (limited to 'net-proxy/wwwoffle')
-rw-r--r--net-proxy/wwwoffle/ChangeLog8
-rw-r--r--net-proxy/wwwoffle/files/digest-wwwoffle-2.9-r13
-rw-r--r--net-proxy/wwwoffle/files/wwwoffle-2.9-reload.patch12
-rw-r--r--net-proxy/wwwoffle/wwwoffle-2.9-r1.ebuild161
4 files changed, 183 insertions, 1 deletions
diff --git a/net-proxy/wwwoffle/ChangeLog b/net-proxy/wwwoffle/ChangeLog
index 137ebb1d2903..1930c591e8ac 100644
--- a/net-proxy/wwwoffle/ChangeLog
+++ b/net-proxy/wwwoffle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/wwwoffle
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/ChangeLog,v 1.13 2006/07/06 06:29:09 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/ChangeLog,v 1.14 2006/07/25 15:05:56 mrness Exp $
+
+*wwwoffle-2.9-r1 (25 Jul 2006)
+
+ 25 Jul 2006; Alin Nastac <mrness@gentoo.org>
+ +files/wwwoffle-2.9-reload.patch, +wwwoffle-2.9-r1.ebuild:
+ Add patch which fixes page reloads (#141697).
06 Jul 2006; Markus Rothe <corsair@gentoo.org> wwwoffle-2.9.ebuild:
Stable on ppc64
diff --git a/net-proxy/wwwoffle/files/digest-wwwoffle-2.9-r1 b/net-proxy/wwwoffle/files/digest-wwwoffle-2.9-r1
new file mode 100644
index 000000000000..5b6f24397ad7
--- /dev/null
+++ b/net-proxy/wwwoffle/files/digest-wwwoffle-2.9-r1
@@ -0,0 +1,3 @@
+MD5 e8e7f3bdf1ff0a9baa26e5aebd6ad396 wwwoffle-2.9.tgz 1074108
+RMD160 f5cbe205c3d0b5ba0cdc23bfa51f185cb8ec1f6c wwwoffle-2.9.tgz 1074108
+SHA256 ac5e779beae963cf2f3b0dd44f7ed64114a1c15aa2fb6f41ad7db9bc0f096df3 wwwoffle-2.9.tgz 1074108
diff --git a/net-proxy/wwwoffle/files/wwwoffle-2.9-reload.patch b/net-proxy/wwwoffle/files/wwwoffle-2.9-reload.patch
new file mode 100644
index 000000000000..422f2b973237
--- /dev/null
+++ b/net-proxy/wwwoffle/files/wwwoffle-2.9-reload.patch
@@ -0,0 +1,12 @@
+diff -Nru wwwoffle-2.9.orig/src/parse.c wwwoffle-2.9/src/parse.c
+--- wwwoffle-2.9.orig/src/parse.c 2006-02-11 22:00:24.000000000 +0200
++++ wwwoffle-2.9/src/parse.c 2006-07-25 17:52:16.970260250 +0300
+@@ -317,7 +317,7 @@
+ }
+ }
+
+- return(0);
++ return(retval);
+ }
+
+
diff --git a/net-proxy/wwwoffle/wwwoffle-2.9-r1.ebuild b/net-proxy/wwwoffle/wwwoffle-2.9-r1.ebuild
new file mode 100644
index 000000000000..35d387f1ed3d
--- /dev/null
+++ b/net-proxy/wwwoffle/wwwoffle-2.9-r1.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/wwwoffle-2.9-r1.ebuild,v 1.1 2006/07/25 15:05:56 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="wwwoffle = WWW Offline Explorer, an adv. caching proxy especially suitable for nonpermanent (e.g. dialup) Internet connections"
+SRC_URI="http://www.gedanken.freeserve.co.uk/download-wwwoffle/${P}.tgz"
+HOMEPAGE="http://www.gedanken.demon.co.uk/wwwoffle"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="gnutls ipv6 zlib"
+
+RDEPEND="gnutls? ( net-libs/gnutls )
+ zlib? ( sys-libs/zlib )"
+DEPEND="dev-lang/perl
+ sys-devel/flex
+ ${RDEPEND}"
+
+# Unsure whether to depend on >=www-misc/htdig-3.1.6-r4 or not
+
+pkg_setup() {
+ # Add a wwwoffle user
+ enewgroup wwwoffle
+ enewuser wwwoffle -1 -1 /var/spool/wwwoffle wwwoffle
+}
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-gcc41.patch"
+ epatch "${FILESDIR}/${P}-reload.patch"
+ sed -i -e 's#$(TAR) xpf #$(TAR) --no-same-owner -xpf #' \
+ "${S}/cache/Makefile.in"
+}
+
+src_compile() {
+ # TODO confdir back to default /etc/wwwoffle
+ # allows to change config file using web interface.
+
+ econf $(use_with zlib) $(use_with gnutls) \
+ $(use_with ipv6) || die "econf failed"
+ emake || die "emake failed"
+
+ if [ -f "${ROOT}/etc/wwwoffle.conf" ] ; then
+ einfo "Upgrading current configuration file"
+ cp "${ROOT}/etc/wwwoffle.conf" conf/wwwoffle.conf
+ conf/upgrade-config.pl conf/wwwoffle.conf
+
+ # Hack to stop regeneration of config file
+ touch conf/conf-file
+
+ einfo "Changing the default user (and group) to wwwoffle"
+ sed -i -e 's/\(run-[gu]id\)[ \t]*=[ \t]*[a-zA-Z0-9]*[ \t]*$/\1 = wwwoffle/g' \
+ conf/wwwoffle.conf
+ else
+ einfo "Changing the default user (and group) to wwwoffle"
+ sed -i -e 's/#\(run-[gu]id\)[ \t]*=[ \t]*[a-zA-Z0-9]*[ \t]*$/\1 = wwwoffle/g' \
+ conf/wwwoffle.conf.template
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # documentation fix
+ # del empty doc dirs
+ rmdir "${D}/usr/doc/${PN}"/{it,nl,ru}
+ dodir /usr/share/doc
+ mv "${D}/usr/doc/wwwoffle" "${D}/usr/share/doc/${PF}"
+
+ #Updated configuration file
+ #if [ -f "${ROOT}/etc/wwwoffle.conf" ]; then
+ # mv "${D}/etc/wwwoffle.conf" "${D}/etc/wwwoffle.conf.updated"
+ #fi
+
+ # install the wwwoffled init script
+ newinitd "${FILESDIR}/${PN}.initd" wwwoffled
+ newinitd "${FILESDIR}/${PN}-online.initd" wwwoffled-online
+ newconfd "${FILESDIR}/${PN}-online.confd" wwwoffled-online
+
+ keepdir /var/spool/wwwoffle/{http,outgoing,monitor,lasttime,lastout,local}
+ for number in 1 2 3 4 5 6 7 8 9; do
+ keepdir "/var/spool/wwwoffle/prevtime${number}" "/var/spool/wwwoffle/prevout${number}"
+ done
+
+ # empty dirs are removed during update
+ keepdir \
+ /var/spool/wwwoffle/search/{mnogosearch/db,htdig/tmp,htdig/db-lasttime,htdig/db,namazu/db}
+
+ touch \
+ "${D}/var/spool/wwwoffle/search/htdig/wwwoffle-htdig.log" \
+ "${D}/var/spool/wwwoffle/search/mnogosearch/wwwoffle-mnogosearch.log" \
+ "${D}/var/spool/wwwoffle/search/namazu/wwwoffle-namazu.log"
+
+ chown -R wwwoffle:wwwoffle "${D}/var/spool/wwwoffle" "${D}/etc/wwwoffle"
+
+ # TODO htdig indexing as part of initscripts
+
+ # robots.txt modification - /var/spool/wwwoffle/html/en
+ # - remove Disallow: /index
+ sed -i -e "s|Disallow:.*/index|#Disallow: /index|" "${D}/var/spool/wwwoffle/html/en/robots.txt"
+
+ rmdir "${D}/usr/doc"
+ chmod -R o-w "${D}/var/spool/wwwoffle" #some file have w permission for world!
+}
+
+pkg_preinst() {
+ # Add a wwwoffle user - required here for binary packages
+ enewgroup wwwoffle
+ enewuser wwwoffle -1 -1 /var/spool/wwwoffle wwwoffle
+
+ # TODO maybe rootjail ${ROOT}
+ source /etc/init.d/functions.sh
+ if [ -L "${svcdir}/started/wwwoffled" ]; then
+ einfo "The wwwoffled init script is running. I'll stop it, merge the new files and
+ restart the script."
+ /etc/init.d/wwwoffled stop
+ # Just to be sure...
+ start-stop-daemon --stop --quiet --name wwwoffled
+ touch "${T}/stopped"
+ fi
+}
+
+pkg_postinst() {
+ # fix permissions for those upgrading
+
+ for number in 1 2 3 4 5 6 7 8 9;
+ do
+ [ ! -d "${ROOT}/var/spool/wwwoffle/prevtime${number}" ] && \
+ keepdir "${ROOT}/var/spool/wwwoffle/prevtime${number}"
+ [ ! -d "${ROOT}/var/spool/wwwoffle/prevout${number}" ] && \
+ keepdir "${ROOT}/var/spool/wwwoffle/prevout${number}"
+ done
+
+ chown -R wwwoffle:wwwoffle "${ROOT}/var/spool/wwwoffle" "${ROOT}/etc/wwwoffle"
+
+ # Need to sumbit patch upstream to allow this.
+ #fowners root:wwwoffle /var/spool/wwwoffle
+ #fowners wwwoffle:wwwoffle /var/spool/wwwoffle
+
+ [ -f "${T}/stopped" ] && \
+ ewarn "wwwoffled was stopped. /etc/init.d/wwwoffled start to restart AFTER etc-update"
+
+ einfo "wwwoffled should run as an ordinary user now. The run-uid and run-gid should be set"
+ einfo "to \"wwwoffle\" in your /etc/wwwoffle/wwwoffle.conf. Please uncomment this if it hasn't been already"
+
+ einfo "This is for your own security. Otherwise wwwoffle is run as root which is relay bad if"
+ einfo "there is an exploit in this program that allows remote/local users to execute arbitary"
+ einfo "commands as the root user."
+
+ if [ -f "${ROOT}/etc/wwwoffle.conf" ]; then
+ ewarn "Configuration file is /etc/wwwoffle/wwwoffle.conf now"
+ ewarn "Suggest you move ${ROOT}etc/wwwoffle.conf"
+ fi
+
+ # if htdig - run script for full database index
+ # TODO
+}