summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-21 20:09:06 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-21 20:09:06 +0000
commitacca85da9ecfc652ef8857d06d1c36a946bcd745 (patch)
tree466f538589c7855b1ee0c3194c99850d20cf34c9 /net-proxy
parentremove old versions (diff)
downloadgentoo-2-acca85da9ecfc652ef8857d06d1c36a946bcd745.tar.gz
gentoo-2-acca85da9ecfc652ef8857d06d1c36a946bcd745.tar.bz2
gentoo-2-acca85da9ecfc652ef8857d06d1c36a946bcd745.zip
use dobin instead of exeinto /usr/bin/ && doexe; fix new pyhton eclass usage
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/http-replicator/ChangeLog6
-rw-r--r--net-proxy/http-replicator/http-replicator-3.0-r4.ebuild7
-rw-r--r--net-proxy/http-replicator/http-replicator-4.0_alpha2-r4.ebuild22
3 files changed, 16 insertions, 19 deletions
diff --git a/net-proxy/http-replicator/ChangeLog b/net-proxy/http-replicator/ChangeLog
index 645670f4b091..9c961c443a83 100644
--- a/net-proxy/http-replicator/ChangeLog
+++ b/net-proxy/http-replicator/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-proxy/http-replicator
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/ChangeLog,v 1.46 2015/01/07 13:58:21 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/ChangeLog,v 1.47 2015/03/21 20:09:06 jlec Exp $
+
+ 21 Mar 2015; Justin Lecher <jlec@gentoo.org> http-replicator-3.0-r4.ebuild,
+ http-replicator-4.0_alpha2-r4.ebuild:
+ use dobin instead of exeinto /usr/bin/ && doexe; fix new pyhton eclass usage
07 Jan 2015; Pacho Ramos <pacho@gentoo.org> -http-replicator-3.0-r2.ebuild,
-http-replicator-3.0-r3.ebuild, -http-replicator-4.0_alpha2-r3.ebuild,
diff --git a/net-proxy/http-replicator/http-replicator-3.0-r4.ebuild b/net-proxy/http-replicator/http-replicator-3.0-r4.ebuild
index 026c3e4a2d3c..b51e8a277604 100644
--- a/net-proxy/http-replicator/http-replicator-3.0-r4.ebuild
+++ b/net-proxy/http-replicator/http-replicator-3.0-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/http-replicator-3.0-r4.ebuild,v 1.5 2014/04/05 07:05:35 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/http-replicator-3.0-r4.ebuild,v 1.6 2015/03/21 20:09:06 jlec Exp $
EAPI=4
PYTHON_DEPEND="2:2.7:2.7" # not 2.6 bug #33907, not 3.0 bug #411083
@@ -28,8 +28,7 @@ src_compile() {
src_install(){
# Daemon and repcacheman into /usr/bin
- exeinto /usr/bin
- doexe http-replicator
+ dobin http-replicator
newexe "${FILESDIR}/http-replicator-3.0-callrepcacheman-0.1" repcacheman
newexe "${FILESDIR}/http-replicator-3.0-repcacheman-0.44-r2" repcacheman.py
diff --git a/net-proxy/http-replicator/http-replicator-4.0_alpha2-r4.ebuild b/net-proxy/http-replicator/http-replicator-4.0_alpha2-r4.ebuild
index d370b71af71e..3e49aaa39c47 100644
--- a/net-proxy/http-replicator/http-replicator-4.0_alpha2-r4.ebuild
+++ b/net-proxy/http-replicator/http-replicator-4.0_alpha2-r4.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/http-replicator-4.0_alpha2-r4.ebuild,v 1.1 2013/12/22 11:07:28 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/http-replicator-4.0_alpha2-r4.ebuild,v 1.2 2015/03/21 20:09:06 jlec Exp $
EAPI="5"
-# Not 2.6, see bug #33907; not 3.0, see bug #411083.
PYTHON_COMPAT=( python2_7 )
inherit eutils python-r1 systemd
@@ -33,18 +32,13 @@ src_test() {
}
src_install(){
- python_export python2_7 EPYTHON PYTHON PYTHON_SITEDIR
+ python_foreach_impl python_doscript http-replicator
- python_scriptinto /usr/bin
- python_doscript http-replicator
+ newbin "${FILESDIR}"/${PN}-3.0-callrepcacheman-0.1 repcacheman
- exeinto /usr/bin
- newexe "${FILESDIR}"/${PN}-3.0-callrepcacheman-0.1 repcacheman
+ python_foreach_impl python_domodule *.py
- python_domodule *.py
-
- cp "${FILESDIR}"/${PN}-3.0-repcacheman-0.44-r2 repcacheman.py || die
- python_doscript repcacheman.py
+ python_foreach_impl python_newscript "${FILESDIR}"/${PN}-3.0-repcacheman-0.44-r2 repcacheman.py
newinitd "${FILESDIR}"/${PN}-4.0_alpha2-r3.init http-replicator
newconfd "${FILESDIR}"/${PN}-4.0_alpha2-r2.conf http-replicator
@@ -56,7 +50,7 @@ src_install(){
}
pkg_postinst() {
- einfo
+ echo
einfo "Before starting ${PN}, please follow the next few steps:"
einfo
einfo "- Modify /etc/conf.d/${PN} if required."
@@ -71,5 +65,5 @@ pkg_postinst() {
einfo " http://forums.gentoo.org/viewtopic-t-173226.html"
einfo
einfo "Starting with 4.x releases, the conf.d parameters have changed."
- einfo
+ echo
}