summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-04-26 02:48:20 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-04-26 02:48:20 +0000
commit882cb2e79d1c46e08b049b1d3a36d57591ecc201 (patch)
tree91a1e07bf03bfa2cf2234fcb301f906e3522708b /net-voip
parentmasking >=linphone-3.1.0 because depending on masked ortp-0.15.0_p1 (diff)
downloadgentoo-2-882cb2e79d1c46e08b049b1d3a36d57591ecc201.tar.gz
gentoo-2-882cb2e79d1c46e08b049b1d3a36d57591ecc201.tar.bz2
gentoo-2-882cb2e79d1c46e08b049b1d3a36d57591ecc201.zip
version bump to 3.1.0 and complete rewrite of the ebuild, bug 263420
(Portage version: 2.1.6.7/cvs/Linux ppc)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/linphone/ChangeLog10
-rw-r--r--net-voip/linphone/files/linphone-3.1.0-external-mstreamer.patch115
-rw-r--r--net-voip/linphone/files/linphone-3.1.0-nls.patch19
-rw-r--r--net-voip/linphone/files/linphone-3.1.0-novideo-preferences.patch13
-rw-r--r--net-voip/linphone/linphone-3.1.0.ebuild110
5 files changed, 266 insertions, 1 deletions
diff --git a/net-voip/linphone/ChangeLog b/net-voip/linphone/ChangeLog
index b324fb657f14..2b65dcce722c 100644
--- a/net-voip/linphone/ChangeLog
+++ b/net-voip/linphone/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-voip/linphone
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/ChangeLog,v 1.24 2009/04/24 04:12:34 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/ChangeLog,v 1.25 2009/04/26 02:48:20 volkmar Exp $
+
+*linphone-3.1.0 (26 Apr 2009)
+
+ 26 Apr 2009; Mounir Lamouri <volkmar@gentoo.org>
+ +files/linphone-3.1.0-external-mstreamer.patch,
+ +files/linphone-3.1.0-nls.patch,
+ +files/linphone-3.1.0-novideo-preferences.patch, +linphone-3.1.0.ebuild:
+ Version bump to 3.1.0 and complete rewrite of the ebuild. See bug 263420.
24 Apr 2009; Mounir Lamouri <volkmar@gentoo.org> linphone-2.1.1.ebuild,
linphone-3.0.0.ebuild:
diff --git a/net-voip/linphone/files/linphone-3.1.0-external-mstreamer.patch b/net-voip/linphone/files/linphone-3.1.0-external-mstreamer.patch
new file mode 100644
index 000000000000..4c4092209086
--- /dev/null
+++ b/net-voip/linphone/files/linphone-3.1.0-external-mstreamer.patch
@@ -0,0 +1,115 @@
+--- configure.in.old 2009-04-23 18:32:59.000000000 -0400
++++ configure.in 2009-04-23 18:49:01.000000000 -0400
+@@ -258,7 +258,26 @@
+
+ AC_SUBST(STRICT_OPTIONS)
+
+-AC_CONFIG_SUBDIRS( mediastreamer2 )
++AC_ARG_ENABLE(external-mediastreamer,
++ [ --enable-external-mediastreamer Use external mediastreamer library],
++ [case "${enableval}" in
++ yes) external_mediastreamer=true ;;
++ no) external_mediastreamer=false ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --enable-external-mediastreamer) ;;
++ esac],[external_mediastreamer=false])
++
++if test "$external_mediastreamer" = 'true'; then
++ LP_CHECK_MSTREAMER
++else
++ AC_CONFIG_SUBDIRS( mediastreamer2 )
++ MSTREAMER_CFLAGS="-I\$(top_srcdir)/mediastreamer2/include"
++ MSTREAMER_LIBS="\$(top_builddir)/mediastreamer2/src/libmediastreamer.la"
++fi
++
++AC_SUBST(MSTREAMER_CFLAGS)
++AC_SUBST(MSTREAMER_LIBS)
++
++AM_CONDITIONAL(EXTERNAL_MSTREAMER, [test "$external_mediastreamer" = 'true'])
+
+ dnl check for db2html (docbook) to generate html user manual
+ AC_CHECK_PROG(have_sgmltools,sgmltools, yes, no)
+--- console/Makefile.am.old 2009-04-23 18:38:26.000000000 -0400
++++ console/Makefile.am 2009-04-23 18:38:56.000000000 -0400
+@@ -7,7 +7,7 @@
+ -I$(top_srcdir)/coreapi\
+ $(ORTP_CFLAGS) \
+ -I$(top_srcdir)/exosip \
+- -I$(top_srcdir)/mediastreamer2/include
++ $(MSTREAMER_CFLAGS)
+
+
+
+@@ -16,7 +16,7 @@
+ linphonec_SOURCES = linphonec.c linphonec.h commands.c
+
+ linphonec_LDADD = $(top_builddir)/coreapi/liblinphone.la $(READLINE_LIBS) \
+- $(top_builddir)/mediastreamer2/src/libmediastreamer.la \
++ $(MSTREAMER_LIBS) \
+ $(ORTP_LIBS) \
+ $(SPEEX_LIBS) \
+ $(OSIP_LIBS)
+@@ -26,7 +26,7 @@
+
+ sipomatic_LDADD= $(INTLLIBS) \
+ $(top_builddir)/coreapi/liblinphone.la \
+- $(top_builddir)/mediastreamer2/src/libmediastreamer.la \
++ $(MSTREAMER_LIBS) \
+ $(ORTP_LIBS) \
+ $(SPEEX_LIBS) \
+ $(OSIP_LIBS)
+--- coreapi/Makefile.am.old 2009-04-23 18:41:10.000000000 -0400
++++ coreapi/Makefile.am 2009-04-23 18:41:32.000000000 -0400
+@@ -7,7 +7,7 @@
+
+ INCLUDES = \
+ -I$(top_srcdir)\
+- -I$(top_srcdir)/mediastreamer2/include
++ $(MSTREAMER_CFLAGS)
+
+
+ lib_LTLIBRARIES=liblinphone.la
+@@ -32,7 +32,7 @@
+
+ liblinphone_la_LIBADD= \
+ $(EXOSIP_LIBS) \
+- $(top_builddir)/mediastreamer2/src/libmediastreamer.la
++ $(MSTREAMER_LIBS)
+
+
+ AM_CFLAGS=$(STRICT_OPTIONS) -DIN_LINPHONE \
+--- gtk-glade/Makefile.am.old 2009-04-23 18:39:42.000000000 -0400
++++ gtk-glade/Makefile.am 2009-04-23 20:19:38.000000000 -0400
+@@ -34,8 +34,8 @@
+ buddylookup.c \
+ linphone.h
+
+-linphone_3_LDADD=$(top_builddir)/oRTP/src/libortp.la \
+- $(top_builddir)/mediastreamer2/src/libmediastreamer.la \
++linphone_3_LDADD=$(ORTP_LIBS) \
++ $(MSTREAMER_LIBS) \
+ $(top_builddir)/coreapi/liblinphone.la \
+ $(LIBGTK_LIBS) $(INTLLIBS) \
+ $(LIBGLADE_LIBS)
+@@ -54,7 +54,7 @@
+
+
+ AM_CFLAGS= -DIN_LINPHONE -I$(top_srcdir)/coreapi/ \
+- -I$(top_srcdir)/mediastreamer2/include/ \
++ $(MSTREAMER_CFLAGS) \
+ $(LIBGLADE_CFLAGS) $(STRICT_OPTIONS) $(LIBGTK_CFLAGS) $(IPV6_CFLAGS) \
+ $(ORTP_CFLAGS) $(OSIP_CFLAGS)
+
+--- m4/mstreamer.m4.old 1969-12-31 19:00:00.000000000 -0500
++++ m4/mstreamer.m4 2009-04-23 19:36:12.000000000 -0400
+@@ -0,0 +1,11 @@
++AC_DEFUN([LP_CHECK_MSTREAMER],[
++
++PKG_CHECK_MODULES([MSTREAMER], [mediastreamer >= 2.2.3], , [ms_failed=true])
++
++if test "$ms_failed" = "true"; then
++ AC_MSG_ERROR("External mediastreamer library not found")
++fi
++
++AC_SUBST([MSTREAMER_LIBS])
++AC_SUBST([MSTREAMER_CFLAGS])
++])
diff --git a/net-voip/linphone/files/linphone-3.1.0-nls.patch b/net-voip/linphone/files/linphone-3.1.0-nls.patch
new file mode 100644
index 000000000000..c6f031f9d558
--- /dev/null
+++ b/net-voip/linphone/files/linphone-3.1.0-nls.patch
@@ -0,0 +1,19 @@
+Allow to disable localization.
+
+Patch by Arfrever Frehtes Taifersar Arahesis
+
+--- configure.in
++++ configure.in
+@@ -30,7 +30,11 @@
+ AM_PROG_CC_STDC
+ AC_HEADER_STDC
+ dnl localization tools
+-ifdef([IT_PROG_INTLTOOL],[IT_PROG_INTLTOOL],[AC_PROG_INTLTOOL])
++AM_NLS
++if test "$USE_NLS" != "no"; then
++ m4_pattern_allow([AC_PROG_INTLTOOL])
++ ifdef([IT_PROG_INTLTOOL],[IT_PROG_INTLTOOL],[AC_PROG_INTLTOOL])
++fi
+ dnl Initialize libtool
+ AC_PROG_LIBTOOL
+ AM_PROG_LIBTOOL
diff --git a/net-voip/linphone/files/linphone-3.1.0-novideo-preferences.patch b/net-voip/linphone/files/linphone-3.1.0-novideo-preferences.patch
new file mode 100644
index 000000000000..671241c1d694
--- /dev/null
+++ b/net-voip/linphone/files/linphone-3.1.0-novideo-preferences.patch
@@ -0,0 +1,13 @@
+fix crash when compiled with --disable-video
+
+--- coreapi/linphonecore.c.old 2009-04-24 19:20:24.000000000 -0400
++++ coreapi/linphonecore.c 2009-04-24 19:21:10.000000000 -0400
+@@ -2108,7 +2108,7 @@
+ if (olddev!=NULL && olddev!=lc->video_conf.device){
+ toggle_video_preview(lc,FALSE);/*restart the video local preview*/
+ }
+- if (lc->ready){
++ if (lc->ready && lc->video_conf.device){
+ vd=ms_web_cam_get_string_id(lc->video_conf.device);
+ if (vd && strstr(vd,"Static picture")!=NULL){
+ vd=NULL;
diff --git a/net-voip/linphone/linphone-3.1.0.ebuild b/net-voip/linphone/linphone-3.1.0.ebuild
new file mode 100644
index 000000000000..83d016d469af
--- /dev/null
+++ b/net-voip/linphone/linphone-3.1.0.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/linphone-3.1.0.ebuild,v 1.1 2009/04/26 02:48:20 volkmar Exp $
+
+EAPI="2"
+
+inherit eutils autotools multilib
+
+DESCRIPTION="Video softphone based on the SIP protocol"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="http://download.savannah.nongnu.org/releases/${PN}/stable/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE="doc gtk ipv6 ncurses nls video"
+
+RDEPEND=">=media-libs/mediastreamer-2.2.3[video?]
+ >=net-libs/libeXosip-3.0.2
+ >=net-libs/libosip-3.0.0
+ >=net-libs/ortp-0.15.0_p1
+ gtk? ( dev-libs/glib:2
+ >=gnome-base/libglade-2.4.0:2.0
+ >=x11-libs/gtk+-2.4.0:2 )
+ ncurses? ( sys-libs/readline
+ sys-libs/ncurses )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ doc? ( app-text/sgmltools-lite )
+ nls? ( dev-util/intltool
+ dev-util/pkgconfig )"
+
+IUSE_LINGUAS="fr it de ja es pl cs nl sv pt_BR hu ru"
+
+for l in ${IUSE_LINGUAS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+# TODO:
+# run-time test for ipv6 : does it need mediastreamer[ipv6] ?
+
+pkg_setup() {
+ if ! use gtk && ! use ncurses; then
+ ewarn "gtk and ncurses are disabled."
+ ewarn "At least one of these use flags are needed to get a front-end."
+ ewarn "Only liblinphone is going to be installed."
+ fi
+
+ strip-linguas ${IUSE_LINGUAS}
+
+ if [[ -z "${LINGUAS}" ]]; then
+ # no linguas set, using the default one
+ LINGUAS=" "
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-external-mstreamer.patch
+
+ # this patch removes need to gettext and intltool
+ # but intltool was needed for eautoreconf so I add m4_pattern_allow
+ # which is probably not the best way but it's working
+ epatch "${FILESDIR}"/${P}-nls.patch
+
+ # remove speex check, avoid bug when mediastreamer[-speex]
+ sed -i -e '/SPEEX/d' configure.in || die "patching configure.in failed"
+
+ # fix path to use lib64
+ sed -i -e "s:lib\(/liblinphone\):$(get_libdir)\1:" configure.in \
+ || die "patching configure.in failed"
+
+ # removing bundled libs dir prevent them to be reconf
+ rm -rf mediastreamer2 oRTP || die "should not die"
+ # and references in Makefile.am
+ sed -i -e "s:oRTP::" -e "s:mediastreamer2::" Makefile.am \
+ || die "patching Makefile.am failed"
+
+ eautoreconf
+
+ # fix crash
+ epatch "${FILESDIR}"/${P}-novideo-preferences.patch
+}
+
+src_configure() {
+ # strict: we don't want -Werror
+ # external-ortp,external-mediastreamer: prefer external libs
+ # truespeech: seems not used, TODO: ask in ml
+ # rsvp: breaking the build (not maintained anymore) --disable = --enable
+ # alsa, artsc and portaudio are used for bundled mediastreamer
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --disable-strict \
+ --enable-external-ortp \
+ --enable-external-mediastreamer \
+ --disable-truespeech \
+ --disable-dependency-tracking \
+ $(use_enable doc manual) \
+ $(use_enable gtk gtk_ui) \
+ $(use_enable ipv6) \
+ $(use_enable ncurses console_ui) \
+ $(use_enable nls) \
+ $(use_enable video)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README README.arm TODO \
+ || die "dodoc failed"
+}