summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2003-10-20 22:28:56 +0000
committerWolfram Schlich <wschlich@gentoo.org>2003-10-20 22:28:56 +0000
commitf6532f54684041d90a5fc83347a0f973e1c928d0 (patch)
treed4980a1ee3c0ae790fb03c0e340aca1249d0334b /net-wireless/hostap-driver
parentnew package (diff)
downloadgentoo-2-f6532f54684041d90a5fc83347a0f973e1c928d0.tar.gz
gentoo-2-f6532f54684041d90a5fc83347a0f973e1c928d0.tar.bz2
gentoo-2-f6532f54684041d90a5fc83347a0f973e1c928d0.zip
new package
Diffstat (limited to 'net-wireless/hostap-driver')
-rw-r--r--net-wireless/hostap-driver/ChangeLog10
-rw-r--r--net-wireless/hostap-driver/Manifest4
-rw-r--r--net-wireless/hostap-driver/files/digest-hostap-driver-0.1.11
-rw-r--r--net-wireless/hostap-driver/hostap-driver-0.1.1.ebuild106
-rw-r--r--net-wireless/hostap-driver/metadata.xml15
5 files changed, 134 insertions, 2 deletions
diff --git a/net-wireless/hostap-driver/ChangeLog b/net-wireless/hostap-driver/ChangeLog
new file mode 100644
index 000000000000..0a4e78d05e7b
--- /dev/null
+++ b/net-wireless/hostap-driver/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-wireless/hostap-driver
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-driver/ChangeLog,v 1.1 2003/10/20 22:28:51 wschlich Exp $
+
+*hostap-driver-0.1.1 (21 Oct 2003)
+
+ 21 Oct 2003; Wolfram Schlich <wschlich@gentoo.org>
+ hostap-driver-0.1.1.ebuild, metadata.xml:
+ Initial import
+
diff --git a/net-wireless/hostap-driver/Manifest b/net-wireless/hostap-driver/Manifest
index fe4e17607283..7929e6845055 100644
--- a/net-wireless/hostap-driver/Manifest
+++ b/net-wireless/hostap-driver/Manifest
@@ -1,4 +1,4 @@
-MD5 3cd7faecea1718b05b8f9056ffe4d5ad hostap-driver-0.1.1.ebuild 3553
+MD5 1ba1f18ab87a5d25b8f61dc247015cbe hostap-driver-0.1.1.ebuild 3671
MD5 c8d062581aead1cc0fb7bd3b4331ff19 metadata.xml 722
-MD5 8f019d6dbd8ff4b5425e2a7c7e22171e ChangeLog 286
+MD5 fca9b16232147d6f1abe2838440744f2 ChangeLog 387
MD5 75dda0e477834ba5a6c5c88cfb402fe7 files/digest-hostap-driver-0.1.1 71
diff --git a/net-wireless/hostap-driver/files/digest-hostap-driver-0.1.1 b/net-wireless/hostap-driver/files/digest-hostap-driver-0.1.1
new file mode 100644
index 000000000000..0b39ecb78a6a
--- /dev/null
+++ b/net-wireless/hostap-driver/files/digest-hostap-driver-0.1.1
@@ -0,0 +1 @@
+MD5 ad7359ce5e749c1449acbcb10c2ee90c hostap-driver-0.1.1.tar.gz 167690
diff --git a/net-wireless/hostap-driver/hostap-driver-0.1.1.ebuild b/net-wireless/hostap-driver/hostap-driver-0.1.1.ebuild
new file mode 100644
index 000000000000..9cd1fca424c7
--- /dev/null
+++ b/net-wireless/hostap-driver/hostap-driver-0.1.1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-driver/hostap-driver-0.1.1.ebuild,v 1.1 2003/10/20 22:28:51 wschlich Exp $
+
+inherit eutils
+
+DESCRIPTION="HostAP wireless drivers"
+HOMEPAGE="http://hostap.epitest.fi/"
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="pcmcia hostap-nopci hostap-noplx"
+DEPEND=">=net-wireless/wireless-tools-25
+ pcmcia? ( >=sys-apps/pcmcia-cs-3.2.1 )"
+RDEPEND="!net-wireless/hostap"
+S="${WORKDIR}/${P}"
+LIB_PATH="/lib/modules/${KV}"
+
+src_unpack() {
+ check_KV
+ unpack ${A}
+ cd "${S}"
+
+ ## set compiler options
+ sed -i -e "s:gcc:${CC}:" "${S}/Makefile"
+ # sed -i -e "s:-O2:${CFLAGS}:" "${S}/Makefile" # improper CFLAGS could cause unresolved symbols in the modules
+
+ ## use pcmcia-cs sources if kernel tree pcmcia support is disabled and USE=pcmcia is set
+ if use pcmcia >&/dev/null; then
+ if egrep '^CONFIG_PCMCIA=[ym]' /usr/src/linux/.config >&/dev/null; then
+ einfo "Kernel PCMCIA is enabled, skipping external pcmcia-cs sources"
+ else
+ einfo "Kernel PCMCIA is disabled, using external pcmcia-cs sources"
+ ## get ebuild of currently installed pcmcia-cs package
+ PCMCIA_CS_EBUILD=(/var/db/pkg/sys-apps/pcmcia-cs-*/pcmcia-cs-*.ebuild) ## use bash globbing
+ if [ ! -f "${PCMCIA_CS_EBUILD}" ]; then
+ die "ERROR: pcmcia-cs ebuild (${PCMCIA_CS_EBUILD}) not found - are you sure pcmcia-cs is installed?"
+ fi
+ PCMCIA_CS_VER="${PCMCIA_CS_EBUILD##*/}" ## -> pcmcia-cs-VER.ebuild
+ PCMCIA_CS_VER="${PCMCIA_CS_VER/pcmcia-cs-/}" ## strip 'pcmcia-cs-'
+ PCMCIA_CS_VER="${PCMCIA_CS_VER/.ebuild/}" ## strip '.ebuild'
+ PCMCIA_PATH="${WORKDIR}/pcmcia-cs-${PCMCIA_CS_VER}"
+ sed -i -e "s:^PCMCIA_PATH=:PCMCIA_PATH=${PCMCIA_PATH}:" "${S}/Makefile"
+ ## unpack external pcmcia-cs sources
+ cd "${WORKDIR}"
+ unpack pcmcia-cs-${PCMCIA_CS_VER}.tar.gz ## unpack the pcmcia-cs sources to PCMCIA_PATH
+ cd pcmcia-cs-${PCMCIA_CS_VER}
+ ## when not configured, pcmcia-cs spits out lots of errors (since 3.2.5)
+ if ! ./Configure -n --srctree --kernel=/usr/src/linux >&/dev/null; then
+ eerror "External pcmcia-cs configuration failed"
+ die
+ fi
+ fi
+ fi
+}
+
+src_compile() {
+
+ local mydrivers
+
+ use pcmcia && mydrivers="${mydrivers} pccard"
+ use hostap-nopci || mydrivers="${mydrivers} pci"
+ use hostap-noplx || mydrivers="${mydrivers} plx"
+
+ einfo "Building the following drivers: ${mydrivers}"
+ emake EXTRA_CFLAGS="-DPRISM2_DOWNLOAD_SUPPORT" ${mydrivers} || die
+}
+
+src_install() {
+ dodir ${LIB_PATH}/net
+ cp ${S}/driver/modules/{hostap.o,hostap_crypt_wep.o} \
+ ${D}${LIB_PATH}/net/
+# local myinstall="install_hostap install_crypt"
+
+ if use pcmcia >&/dev/null; then
+ dodir ${LIB_PATH}/pcmcia
+ dodir /etc/pcmcia
+ cp ${S}/driver/modules/hostap_cs.o ${D}/${LIB_PATH}/pcmcia/
+ cp ${S}/driver/etc/hostap_cs.conf ${D}/etc/pcmcia/
+ if [ -r /etc/pcmcia/prism2.conf ]; then
+ einfo "You may need to edit or remove /etc/pcmcia/prism2.conf"
+ einfo "This is usually a result of conflicts with the"
+ einfo "linux-wlan-ng drivers."
+ fi
+# myinstall="${myinstall} install_pccard"
+ fi
+
+ if ! use hostap-nopci >&/dev/null; then
+ cp ${S}/driver/modules/hostap_pci.o \
+ ${D}${LIB_PATH}/net/
+# myinstall="${myinstall} install_pci"
+ fi
+
+ if ! use hostap-noplx >&/dev/null; then
+ cp ${S}/driver/modules/hostap_plx.o \
+ ${D}${LIB_PATH}/net/
+# myinstall="${myinstall} install_plx"
+ fi
+# emake DESTDIR="${D}" ${myinstall}
+ dodoc README ChangeLog
+}
+pkg_postinst(){
+ einfo "Checking kernel module dependancies"
+ cd /usr/src/linux && make _modinst_post ## depmod
+}
diff --git a/net-wireless/hostap-driver/metadata.xml b/net-wireless/hostap-driver/metadata.xml
new file mode 100644
index 000000000000..408a0e82cc0c
--- /dev/null
+++ b/net-wireless/hostap-driver/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ </maintainer>
+ <longdescription>This is a Linux driver for wireless LAN cards based on
+ Intersil's Prism2/2.5/3 chipset. The driver supports a so called Host AP mode,
+ i.e., it takes care of IEEE 802.11 management functions in the host computer
+ and acts as an access point. This does not require any special firmware for
+ the wireless LAN card. In addition to this, it has support for normal station
+ operations in BSS and possible also in IBSS.</longdescription>
+</pkgmetadata>