summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2008-03-10 20:57:06 +0000
committerLuca Barbato <lu_zero@gentoo.org>2008-03-10 20:57:06 +0000
commitb028c68d0bb2011bed7f5fb430b2671782e2e150 (patch)
tree273e435e5c203d8b613b5a2765edb422d0b3d7a5 /net-wireless
parentwpa_supplicant supports the ps3 (diff)
downloadgentoo-2-b028c68d0bb2011bed7f5fb430b2671782e2e150.tar.gz
gentoo-2-b028c68d0bb2011bed7f5fb430b2671782e2e150.tar.bz2
gentoo-2-b028c68d0bb2011bed7f5fb430b2671782e2e150.zip
New version
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/wpa_supplicant/ChangeLog9
-rw-r--r--net-wireless/wpa_supplicant/files/wpa_supplicant-0.6.3-ps3_support.patch385
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-0.6.3.ebuild225
3 files changed, 618 insertions, 1 deletions
diff --git a/net-wireless/wpa_supplicant/ChangeLog b/net-wireless/wpa_supplicant/ChangeLog
index 069b03fbc28a..3910fd1a29e9 100644
--- a/net-wireless/wpa_supplicant/ChangeLog
+++ b/net-wireless/wpa_supplicant/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-wireless/wpa_supplicant
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.104 2008/03/09 04:31:46 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.105 2008/03/10 20:57:05 lu_zero Exp $
+
+*wpa_supplicant-0.6.3 (10 Mar 2008)
+
+ 10 Mar 2008; Luca Barbato <lu_zero@gentoo.org>
+ +files/wpa_supplicant-0.6.3-ps3_support.patch,
+ +wpa_supplicant-0.6.3.ebuild:
+ New revision, with ps3 support
09 Mar 2008; Ryan Hill <dirtyepic@gentoo.org>
+files/wpa_supplicant-0.5.10-gcc-4.3.patch, wpa_supplicant-0.5.10.ebuild:
diff --git a/net-wireless/wpa_supplicant/files/wpa_supplicant-0.6.3-ps3_support.patch b/net-wireless/wpa_supplicant/files/wpa_supplicant-0.6.3-ps3_support.patch
new file mode 100644
index 000000000000..1c0199afcfce
--- /dev/null
+++ b/net-wireless/wpa_supplicant/files/wpa_supplicant-0.6.3-ps3_support.patch
@@ -0,0 +1,385 @@
+This adds support for PS3 wireless to wpa_supplicant.
+
+Although PS3 wireless driver is designed to conform the WEXT standard
+as much as possible, unfortunately the wext driver wrapper of
+wpa_supplicant can not support PS3 wireless fully because:
+
+ - PS3 wireless driver uses private WEXT ioctls for accepting PSK of
+ WPA-Personal from the userland.
+ WEXT does not specify the way to do it.
+
+ - The association and 4-way handshake are done by PS3 virtual
+ wireless device. The guest OSes can not interfere it.
+
+ - No EAPOL frames are allowed to go outside of the
+ hypervisor/firmware nor come from. They are eaten by the firmware.
+
+Thus I needed to make a new driver wrapper for PS3 wireless.
+
+This patch can be applied against the latest 0.6.x tree.
+Please review!
+
+Thanks in advance.
+
+Signed-off-by: Masakazu Mokuno <mokuno@sm.sony.co.jp>
+---
+ src/drivers/driver_ps3.c | 181 ++++++++++++++++++++++++++++++++++++++++++++++
+ src/drivers/driver_wext.c | 39 +--------
+ src/drivers/driver_wext.h | 34 ++++++++
+ src/drivers/drivers.c | 6 +
+ wpa_supplicant/Makefile | 6 +
+ 5 files changed, 232 insertions(+), 34 deletions(-)
+
+--- /dev/null
++++ b/src/drivers/driver_ps3.c
+@@ -0,0 +1,181 @@
++/*
++ * WPA Supplicant - PS3 Linux wireless extension driver interface
++ * Copyright 2007, 2008 Sony Corporation
++ *
++ * This program is free software; you can redistribute it and/or modify
++ * it under the terms of the GNU General Public License version 2 as
++ * published by the Free Software Foundation.
++ *
++ */
++
++#include "includes.h"
++#include <sys/ioctl.h>
++#include "wireless_copy.h"
++#include "common.h"
++#include "wpa_common.h"
++#include "driver.h"
++#include "eloop.h"
++#include "driver_wext.h"
++#include "ieee802_11_defs.h"
++
++static int wpa_driver_ps3_set_wpa_key(struct wpa_driver_wext_data *drv,
++ struct wpa_driver_associate_params *params)
++{
++ int ret, i;
++ struct iwreq iwr;
++ char *buf, *str;
++
++ if (!params->psk && !params->passphrase) {
++ wpa_printf(MSG_INFO, "%s:no PSK error\n", __FUNCTION__);
++ return -EINVAL;
++ }
++
++ os_memset(&iwr, 0, sizeof(iwr));
++ if (params->psk) {
++ /* includes null */
++ iwr.u.data.length = PMK_LEN * 2 + 1;
++ buf = os_malloc(iwr.u.data.length);
++ if (!buf)
++ return -ENOMEM;
++ str = buf;
++ for (i = 0; i < PMK_LEN; i++) {
++ str += snprintf(str, iwr.u.data.length - (str - buf),
++ "%02x", params->psk[i]);
++ }
++ } else if (params->passphrase) {
++ /* including quotations and null */
++ iwr.u.data.length = strlen(params->passphrase) + 3;
++ if (!buf)
++ return -ENOMEM;
++ buf[0] = '"';
++ os_memcpy(buf + 1, params->passphrase, iwr.u.data.length - 3);
++ buf[iwr.u.data.length - 2] = '"';
++ buf[iwr.u.data.length - 1] = '\0';
++ }
++ iwr.u.data.pointer = (caddr_t)buf;
++ os_strlcpy(iwr.ifr_name, drv->ifname, IFNAMSIZ);
++ ret = ioctl(drv->ioctl_sock, SIOCIWFIRSTPRIV, &iwr);
++ os_free(buf);
++
++ return ret;
++}
++
++static int wpa_driver_ps3_set_wep_keys(struct wpa_driver_wext_data *drv,
++ struct wpa_driver_associate_params *params)
++{
++ int ret, i;
++ struct iwreq iwr;
++
++ for (i = 0; i < 4; i++) {
++ os_memset(&iwr, 0, sizeof(iwr));
++ os_strlcpy(iwr.ifr_name, drv->ifname, IFNAMSIZ);
++ iwr.u.encoding.flags = i + 1;
++ if (params->wep_key_len[i]) {
++ iwr.u.encoding.pointer = (caddr_t) params->wep_key[i];
++ iwr.u.encoding.length = params->wep_key_len[i];
++ } else
++ iwr.u.encoding.flags = IW_ENCODE_NOKEY |
++ IW_ENCODE_DISABLED;
++
++ if (ioctl(drv->ioctl_sock, SIOCSIWENCODE, &iwr) < 0) {
++ perror("ioctl[SIOCSIWENCODE]");
++ ret = -1;
++ }
++ }
++ return ret;
++}
++
++static int wpa_driver_ps3_associate(void *priv,
++ struct wpa_driver_associate_params *params)
++{
++ struct wpa_driver_wext_data *drv = priv;
++ int ret, i, value;
++
++ wpa_printf(MSG_DEBUG, "%s: <-\n", __func__);
++
++ /* clear BSSID */
++ if (!params->bssid &&
++ wpa_driver_wext_set_bssid(drv, NULL) < 0)
++ ret = -1;
++
++ if (wpa_driver_wext_set_mode(drv, params->mode) < 0)
++ ret = -1;
++
++ if (params->wpa_ie == NULL || params->wpa_ie_len == 0)
++ value = IW_AUTH_WPA_VERSION_DISABLED;
++ else if (params->wpa_ie[0] == WLAN_EID_RSN)
++ value = IW_AUTH_WPA_VERSION_WPA2;
++ else
++ value = IW_AUTH_WPA_VERSION_WPA;
++ if (wpa_driver_wext_set_auth_param(drv,
++ IW_AUTH_WPA_VERSION, value) < 0)
++ ret = -1;
++ value = wpa_driver_wext_cipher2wext(params->pairwise_suite);
++ if (wpa_driver_wext_set_auth_param(drv,
++ IW_AUTH_CIPHER_PAIRWISE, value) < 0)
++ ret = -1;
++ value = wpa_driver_wext_cipher2wext(params->group_suite);
++ if (wpa_driver_wext_set_auth_param(drv,
++ IW_AUTH_CIPHER_GROUP, value) < 0)
++ ret = -1;
++ value = wpa_driver_wext_keymgmt2wext(params->key_mgmt_suite);
++ if (wpa_driver_wext_set_auth_param(drv,
++ IW_AUTH_KEY_MGMT, value) < 0)
++ ret = -1;
++
++ /* set selected BSSID */
++ if (params->bssid &&
++ wpa_driver_wext_set_bssid(drv, params->bssid) < 0)
++ ret = -1;
++
++ switch (params->group_suite) {
++ case CIPHER_NONE:
++ ret = 0;
++ break;
++ case CIPHER_WEP40:
++ case CIPHER_WEP104:
++ ret = wpa_driver_ps3_set_wep_keys(drv, params);
++ break;
++ case CIPHER_TKIP:
++ case CIPHER_CCMP:
++ ret = wpa_driver_ps3_set_wpa_key(drv, params);
++ break;
++ }
++
++ /* start to associate */
++ ret = wpa_driver_wext_set_ssid(drv, params->ssid, params->ssid_len);
++
++ wpa_printf(MSG_DEBUG, "%s: ->\n", __func__);
++
++ return ret;
++}
++
++static int wpa_driver_ps3_get_capa(void *priv, struct wpa_driver_capa *capa)
++{
++ int ret;
++ wpa_printf(MSG_DEBUG, "%s:<-\n", __func__);
++
++ ret = wpa_driver_wext_get_capa(priv, capa);
++ if (ret) {
++ wpa_printf(MSG_INFO, "%s: base wext returns error %d\n", __func__,
++ ret);
++ return ret;
++ }
++ /* PS3 hypervisor does association and 4way handshake by itself */
++ capa->flags |= WPA_DRIVER_FLAGS_4WAY_HANDSHAKE;
++ wpa_printf(MSG_DEBUG, "%s:->\n", __func__);
++ return 0;
++}
++
++const struct wpa_driver_ops wpa_driver_ps3_ops = {
++ .name = "ps3",
++ .desc = "PLAYSTATION3 Linux wireless extension driver",
++ .get_bssid = wpa_driver_wext_get_bssid,
++ .get_ssid = wpa_driver_wext_get_ssid,
++ .scan = wpa_driver_wext_scan,
++ .get_scan_results2 = wpa_driver_wext_get_scan_results,
++ .associate = wpa_driver_ps3_associate, /* PS3 */
++ .init = wpa_driver_wext_init,
++ .deinit = wpa_driver_wext_deinit,
++ .get_capa = wpa_driver_ps3_get_capa, /* PS3 */
++};
+--- a/src/drivers/driver_wext.c
++++ b/src/drivers/driver_wext.c
+@@ -149,32 +149,6 @@ enum {
+ #endif /* CONFIG_CLIENT_MLME */
+
+
+-struct wpa_driver_wext_data {
+- void *ctx;
+- int event_sock;
+- int ioctl_sock;
+- int mlme_sock;
+- char ifname[IFNAMSIZ + 1];
+- int ifindex;
+- int ifindex2;
+- u8 *assoc_req_ies;
+- size_t assoc_req_ies_len;
+- u8 *assoc_resp_ies;
+- size_t assoc_resp_ies_len;
+- struct wpa_driver_capa capa;
+- int has_capability;
+- int we_version_compiled;
+-
+- /* for set_auth_alg fallback */
+- int use_crypt;
+- int auth_alg_fallback;
+-
+- int operstate;
+-
+- char mlmedev[IFNAMSIZ + 1];
+-
+- int scan_complete_events;
+-};
+
+
+ static int wpa_driver_wext_flush_pmkid(void *priv);
+@@ -239,8 +213,8 @@ static int wpa_driver_wext_send_oper_ifl
+ }
+
+
+-static int wpa_driver_wext_set_auth_param(struct wpa_driver_wext_data *drv,
+- int idx, u32 value)
++int wpa_driver_wext_set_auth_param(struct wpa_driver_wext_data *drv,
++ int idx, u32 value)
+ {
+ struct iwreq iwr;
+ int ret = 0;
+@@ -1977,7 +1951,7 @@ static int wpa_driver_wext_set_gen_ie(vo
+ }
+
+
+-static int wpa_driver_wext_cipher2wext(int cipher)
++int wpa_driver_wext_cipher2wext(int cipher)
+ {
+ switch (cipher) {
+ case CIPHER_NONE:
+@@ -1996,7 +1970,7 @@ static int wpa_driver_wext_cipher2wext(i
+ }
+
+
+-static int wpa_driver_wext_keymgmt2wext(int keymgmt)
++int wpa_driver_wext_keymgmt2wext(int keymgmt)
+ {
+ switch (keymgmt) {
+ case KEY_MGMT_802_1X:
+@@ -2054,8 +2028,7 @@ wpa_driver_wext_auth_alg_fallback(struct
+ }
+
+
+-static int
+-wpa_driver_wext_associate(void *priv,
++int wpa_driver_wext_associate(void *priv,
+ struct wpa_driver_associate_params *params)
+ {
+ struct wpa_driver_wext_data *drv = priv;
+@@ -2239,7 +2212,7 @@ static int wpa_driver_wext_flush_pmkid(v
+ }
+
+
+-static int wpa_driver_wext_get_capa(void *priv, struct wpa_driver_capa *capa)
++int wpa_driver_wext_get_capa(void *priv, struct wpa_driver_capa *capa)
+ {
+ struct wpa_driver_wext_data *drv = priv;
+ if (!drv->has_capability)
+--- a/src/drivers/driver_wext.h
++++ b/src/drivers/driver_wext.h
+@@ -14,8 +14,32 @@
+
+ #ifndef DRIVER_WEXT_H
+ #define DRIVER_WEXT_H
++struct wpa_driver_wext_data {
++ void *ctx;
++ int event_sock;
++ int ioctl_sock;
++ int mlme_sock;
++ char ifname[IFNAMSIZ + 1];
++ int ifindex;
++ int ifindex2;
++ u8 *assoc_req_ies;
++ size_t assoc_req_ies_len;
++ u8 *assoc_resp_ies;
++ size_t assoc_resp_ies_len;
++ struct wpa_driver_capa capa;
++ int has_capability;
++ int we_version_compiled;
++
++ /* for set_auth_alg fallback */
++ int use_crypt;
++ int auth_alg_fallback;
+
+-struct wpa_driver_wext_data;
++ int operstate;
++
++ char mlmedev[IFNAMSIZ + 1];
++
++ int scan_complete_events;
++};
+
+ int wpa_driver_wext_get_ifflags(struct wpa_driver_wext_data *drv, int *flags);
+ int wpa_driver_wext_set_ifflags(struct wpa_driver_wext_data *drv, int flags);
+@@ -43,4 +67,12 @@ void wpa_driver_wext_deinit(void *priv);
+ int wpa_driver_wext_set_operstate(void *priv, int state);
+ int wpa_driver_wext_get_version(struct wpa_driver_wext_data *drv);
+
++int wpa_driver_wext_associate(void *priv,
++ struct wpa_driver_associate_params *params);
++int wpa_driver_wext_get_capa(void *priv, struct wpa_driver_capa *capa);
++int wpa_driver_wext_set_auth_param(struct wpa_driver_wext_data *drv,
++ int idx, u32 value);
++int wpa_driver_wext_cipher2wext(int cipher);
++int wpa_driver_wext_keymgmt2wext(int keymgmt);
++
+ #endif /* DRIVER_WEXT_H */
+--- a/src/drivers/drivers.c
++++ b/src/drivers/drivers.c
+@@ -61,6 +61,9 @@ extern struct wpa_driver_ops wpa_driver_
+ #ifdef CONFIG_DRIVER_OSX
+ extern struct wpa_driver_ops wpa_driver_osx_ops; /* driver_osx.m */
+ #endif /* CONFIG_DRIVER_OSX */
++#ifdef CONFIG_DRIVER_PS3
++extern struct wpa_driver_ops wpa_driver_ps3_ops; /* driver_ps3.c */
++#endif /* CONFIG_DRIVER_PS3 */
+ #ifdef CONFIG_DRIVER_IPHONE
+ extern struct wpa_driver_ops wpa_driver_iphone_ops; /* driver_iphone.m */
+ #endif /* CONFIG_DRIVER_IPHONE */
+@@ -113,6 +116,9 @@ struct wpa_driver_ops *wpa_supplicant_dr
+ #ifdef CONFIG_DRIVER_OSX
+ &wpa_driver_osx_ops,
+ #endif /* CONFIG_DRIVER_OSX */
++#ifdef CONFIG_DRIVER_PS3
++ &wpa_driver_ps3_ops,
++#endif /* CONFIG_DRIVER_PS3 */
+ #ifdef CONFIG_DRIVER_IPHONE
+ &wpa_driver_iphone_ops,
+ #endif /* CONFIG_DRIVER_IPHONE */
+--- a/wpa_supplicant/Makefile
++++ b/wpa_supplicant/Makefile
+@@ -210,6 +210,12 @@ LDFLAGS += -framework CoreFoundation
+ LDFLAGS += -F/System/Library/PrivateFrameworks -framework Apple80211
+ endif
+
++ifdef CONFIG_DRIVER_PS3
++CFLAGS += -DCONFIG_DRIVER_PS3 -m64
++OBJS_d += ../src/drivers/driver_ps3.o
++LDFLAGS += -m64
++endif
++
+ ifdef CONFIG_DRIVER_IPHONE
+ CFLAGS += -DCONFIG_DRIVER_IPHONE
+ OBJS_d += ../src/drivers/driver_iphone.o
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.6.3.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.6.3.ebuild
new file mode 100644
index 000000000000..399eff70db72
--- /dev/null
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-0.6.3.ebuild
@@ -0,0 +1,225 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.6.3.ebuild,v 1.1 2008/03/10 20:57:05 lu_zero Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="IEEE 802.1X/WPA supplicant for secure wireless transfers"
+HOMEPAGE="http://hostap.epitest.fi/wpa_supplicant/"
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
+LICENSE="|| ( GPL-2 BSD )"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="dbus gnutls gsm madwifi qt3 qt4 readline ssl kernel_linux kernel_FreeBSD
+ ps3"
+
+RDEPEND="dbus? ( sys-apps/dbus )
+ kernel_linux? (
+ gsm? ( sys-apps/pcsc-lite )
+ madwifi? ( ||
+ ( >net-wireless/madwifi-ng-tools-0.9.3
+ <net-wireless/madwifi-ng-0.9.3-r4
+ net-wireless/madwifi-old )
+ )
+ )
+ !kernel_linux? ( net-libs/libpcap )
+ qt4? ( =x11-libs/qt-4* )
+ !qt4? ( qt3? ( =x11-libs/qt-3* ) )
+ readline? ( sys-libs/ncurses sys-libs/readline )
+ ssl? ( dev-libs/openssl )
+ gnutls? ( net-libs/gnutls )
+ !ssl? ( !gnutls? ( dev-libs/libtommath ) )"
+
+S="${WORKDIR}/${P}/${PN}"
+
+pkg_setup() {
+ if use qt3 && use qt4; then
+ einfo "You have USE=\"qt3 qt4\" selected, defaulting to USE=\"qt4\""
+ fi
+
+ if use qt4 && has_version ">=x11-libs/qt-4.2.2" ; then
+ if ! built_with_use x11-libs/qt qt3support ; then
+ eerror ">=qt4.2.2 requires qt3support"
+ die "rebuild >=x11-libs/qt-4.2.2 with the qt3support USE flag"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${WORKDIR}/${P}"
+ epatch "${FILESDIR}/${P}-ps3_support.patch"
+
+ cd "${S}"
+
+ # net/bpf.h needed for net-libs/libpcap on Gentoo FreeBSD
+ sed -i \
+ -e "s:\(#include <pcap\.h>\):#include <net/bpf.h>\n\1:" \
+ ../src/l2_packet/l2_packet_freebsd.c || die
+
+ # toolchain setup
+ echo "CC = $(tc-getCC)" > .config
+
+ # basic setup
+ echo "CONFIG_CTRL_IFACE=y" >> .config
+ echo "CONFIG_BACKEND=file" >> .config
+
+ # basic authentication methods
+ # NOTE: we don't set GPSK or SAKE as they conflict
+ # with the below options
+ echo "CONFIG_EAP_GTC=y" >> .config
+ echo "CONFIG_EAP_MD5=y" >> .config
+ echo "CONFIG_EAP_OTP=y" >> .config
+ echo "CONFIG_EAP_PAX=y" >> .config
+ echo "CONFIG_EAP_PSK=y" >> .config
+ echo "CONFIG_EAP_TLV=y" >> .config
+ echo "CONFIG_IEEE8021X_EAPOL=y" >> .config
+ echo "CONFIG_PKCS12=y" >> .config
+ echo "CONFIG_PEERKEY=y" >> .config
+ echo "CONFIG_EAP_LEAP=y" >> .config
+ echo "CONFIG_EAP_MSCHAPV2=y" >> .config
+ echo "CONFIG_EAP_PEAP=y" >> .config
+ echo "CONFIG_EAP_TLS=y" >> .config
+ echo "CONFIG_EAP_TTLS=y" >> .config
+
+ if use dbus ; then
+ echo "CONFIG_CTRL_IFACE_DBUS=y" >> .config
+ fi
+
+ if use gsm ; then
+ # smart card authentication
+ echo "CONFIG_EAP_SIM=y" >> .config
+ echo "CONFIG_EAP_AKA=y" >> .config
+ echo "CONFIG_PCSC=y" >> .config
+ fi
+
+ if use readline ; then
+ # readline/history support for wpa_cli
+ echo "CONFIG_READLINE=y" >> .config
+ fi
+
+ # SSL authentication methods
+ if use gnutls ; then
+ echo "CONFIG_TLS=gnutls" >> .config
+ echo "CONFIG_GNUTLS_EXTRA=y" >> .config
+ elif use ssl ; then
+ echo "CONFIG_TLS=openssl" >> .config
+ echo "CONFIG_SMARTCARD=y" >> .config
+ else
+ echo "CONFIG_TLS=internal" >> .config
+ fi
+
+ if use kernel_linux ; then
+ # Linux specific drivers
+ echo "CONFIG_DRIVER_ATMEL=y" >> .config
+ #echo "CONFIG_DRIVER_BROADCOM=y" >> .config
+ #echo "CONFIG_DRIVER_HERMES=y" >> .config
+ echo "CONFIG_DRIVER_HOSTAP=y" >> .config
+ echo "CONFIG_DRIVER_IPW=y" >> .config
+ echo "CONFIG_DRIVER_NDISWRAPPER=y" >> .config
+ echo "CONFIG_DRIVER_PRISM54=y" >> .config
+ echo "CONFIG_DRIVER_WEXT=y" >> .config
+ echo "CONFIG_DRIVER_WIRED=y" >> .config
+
+ if use madwifi ; then
+ # Add include path for madwifi-driver headers
+ echo "CFLAGS += -I/usr/include/madwifi" >> .config
+ echo "CONFIG_DRIVER_MADWIFI=y" >> .config
+ fi
+ if use ps3 ; then
+ echo "CONFIG_DRIVER_PS3=y" >> .config
+ fi
+ elif use kernel_FreeBSD ; then
+ # FreeBSD specific driver
+ echo "CONFIG_DRIVER_BSD=y" >> .config
+ fi
+
+ # people seem to take the example configuration file too literally
+ # bug #102361
+ sed -i \
+ -e "s:^\(opensc_engine_path\):#\1:" \
+ -e "s:^\(pkcs11_engine_path\):#\1:" \
+ -e "s:^\(pkcs11_module_path\):#\1:" \
+ wpa_supplicant.conf || die
+
+ # Change configuration to match Gentoo locations, #143750
+ sed -i \
+ -e "s:/usr/lib/opensc:/usr/$(get_libdir):" \
+ -e "s:/usr/lib/pkcs11:/usr/$(get_libdir):" \
+ wpa_supplicant.conf || die
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use qt4 ; then
+ qmake -o "${S}"/wpa_gui-qt4/Makefile "${S}"/wpa_gui-qt4/wpa_gui.pro
+ cd "${S}"/wpa_gui-qt4
+ emake || die "emake wpa_gui-qt4 failed"
+ elif use qt3 ; then
+ [[ -d "${QTDIR}"/etc/settings ]] && addwrite "${QTDIR}"/etc/settings
+ "${QTDIR}"/bin/qmake -o "${S}"/wpa_gui/Makefile "${S}"/wpa_gui/wpa_gui.pro
+ cd "${S}"/wpa_gui
+ emake || die "emake wpa_gui failed"
+ fi
+}
+
+src_install() {
+ dosbin wpa_supplicant
+ dobin wpa_cli wpa_passphrase
+
+ # baselayout-1 compat
+ dosym /usr/sbin/wpa_supplicant /sbin/wpa_supplicant
+ dosym /usr/bin/wpa_cli /bin/wpa_cli
+
+ exeinto /etc/wpa_supplicant/
+ newexe "${FILESDIR}"/wpa_cli.sh wpa_cli.sh
+ insinto /etc/wpa_supplicant/
+ newins "${FILESDIR}"/wpa_supplicant.conf wpa_supplicant.conf
+
+ dodoc ChangeLog ../COPYING eap_testing.txt README todo.txt
+ newdoc wpa_supplicant.conf wpa_supplicant.conf
+
+ doman doc/docbook/*.8
+ doman doc/docbook/*.5
+
+ if use qt4 ; then
+ into /usr
+ dobin wpa_gui-qt4/wpa_gui
+ elif use qt3 ; then
+ into /usr
+ dobin wpa_gui/wpa_gui
+ fi
+
+ if use qt3 || use qt4; then
+ make_desktop_entry wpa_gui "WPA_Supplicant Administration GUI"
+ fi
+
+ if use dbus ; then
+ insinto /etc/dbus-1/system.d
+ newins dbus-wpa_supplicant.conf wpa_supplicant.conf
+ fi
+}
+
+pkg_postinst() {
+ einfo "A default configuration file has been installed to"
+ einfo "/etc/wpa_supplicant/wpa_supplicant.conf"
+ einfo
+ einfo "An example configuration file is available as"
+ einfo "/usr/share/doc/${PF}/wpa_supplicant.conf.gz"
+
+ if [[ -e ${ROOT}etc/wpa_supplicant.conf ]] ; then
+ echo
+ ewarn "WARNING: your old configuration file ${ROOT}etc/wpa_supplicant.conf"
+ ewarn "needs to be moved to ${ROOT}etc/wpa_supplicant/wpa_supplicant.conf"
+ fi
+
+ if use madwifi; then
+ echo
+ einfo "This package compiles against the headers installed by"
+ einfo "madwifi-old, madwifi-ng or madwifi-ng-tools."
+ einfo "You should remerge ${PN} after upgrading these packages."
+ fi
+}