summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-09-11 15:06:58 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-09-11 15:06:58 +0000
commitdc90da458c3481a1ca94f1a26524ba544201ae06 (patch)
treeb36be92d6b564515513efe298ce9df355db30bd0 /sci-astronomy/predict
parentnew 0.20 rev for xmltv fixes. new 0.21 for upstream trunk fixes. remove old v... (diff)
downloadgentoo-2-dc90da458c3481a1ca94f1a26524ba544201ae06.tar.gz
gentoo-2-dc90da458c3481a1ca94f1a26524ba544201ae06.tar.bz2
gentoo-2-dc90da458c3481a1ca94f1a26524ba544201ae06.zip
Removed old versions, added longdescription, added a patch for xforms.
(Portage version: 2.1.2.12)
Diffstat (limited to 'sci-astronomy/predict')
-rw-r--r--sci-astronomy/predict/ChangeLog7
-rw-r--r--sci-astronomy/predict/files/digest-predict-2.2.2-r33
-rw-r--r--sci-astronomy/predict/files/predict-2.2.3-xforms.patch79
-rw-r--r--sci-astronomy/predict/metadata.xml6
-rw-r--r--sci-astronomy/predict/predict-2.2.2-r3.ebuild170
-rw-r--r--sci-astronomy/predict/predict-2.2.3.ebuild36
6 files changed, 112 insertions, 189 deletions
diff --git a/sci-astronomy/predict/ChangeLog b/sci-astronomy/predict/ChangeLog
index 0ad50eafc81c..248e02c361ed 100644
--- a/sci-astronomy/predict/ChangeLog
+++ b/sci-astronomy/predict/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/predict
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/ChangeLog,v 1.9 2007/01/26 14:43:43 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/ChangeLog,v 1.10 2007/09/11 15:06:57 bicatali Exp $
+
+ 11 Sep 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ -predict-2.2.2-r3.ebuild, predict-2.2.3.ebuild, +files/predict-2.2.3-xforms.patch
+ Removed old versions, added longdescription, added a patch for
+ xforms. Should fix bug #140991.
26 Jan 2007; Steve Dibb <beandog@gentoo.org> predict-2.2.3.ebuild:
amd64 stable, bug 160130
diff --git a/sci-astronomy/predict/files/digest-predict-2.2.2-r3 b/sci-astronomy/predict/files/digest-predict-2.2.2-r3
deleted file mode 100644
index 4e4d2c185c83..000000000000
--- a/sci-astronomy/predict/files/digest-predict-2.2.2-r3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 2512bc6b584ece66de027e46f114ab53 predict-2.2.2.tar.gz 1637893
-RMD160 555db99142521408d2c24065972eaba16d8541e2 predict-2.2.2.tar.gz 1637893
-SHA256 6996bc4219483fb3bb0e33de5bd58bc7a921fad4298a951b5a6a3c97f8d95d7f predict-2.2.2.tar.gz 1637893
diff --git a/sci-astronomy/predict/files/predict-2.2.3-xforms.patch b/sci-astronomy/predict/files/predict-2.2.3-xforms.patch
new file mode 100644
index 000000000000..49bce1b14e36
--- /dev/null
+++ b/sci-astronomy/predict/files/predict-2.2.3-xforms.patch
@@ -0,0 +1,79 @@
+diff -Nur clients/map.orig/map.c clients/map/map.c
+--- clients/map.orig/map.c 2007-09-11 15:56:24.838414157 +0100
++++ clients/map/map.c 2007-09-11 15:52:24.148698032 +0100
+@@ -18,7 +18,7 @@
+ *****************************************************************************/
+ /* Form definition file generated with fdesign. */
+
+-#include "forms.h"
++#include <forms.h>
+ #include <stdlib.h>
+ #include "map.h"
+ #include "world_fill.h"
+diff -Nur clients/map.orig/map_cb.c clients/map/map_cb.c
+--- clients/map.orig/map_cb.c 2007-09-11 15:56:24.838414157 +0100
++++ clients/map/map_cb.c 2007-09-11 15:54:05.190456074 +0100
+@@ -18,9 +18,11 @@
+ *****************************************************************************/
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <netdb.h>
+ #include <signal.h>
+ #include <time.h>
+@@ -39,7 +41,7 @@
+ /* This function implements the arccosine function,
+ returning a value between 0 and two pi. */
+
+- double result, fraction;
++ double result=0.0, fraction;
+
+ fraction=x/y;
+
+@@ -76,7 +78,7 @@
+ bzero((char *)&sin,sizeof(struct sockaddr_in));
+ sin.sin_family = AF_INET;
+
+- if (pse=getservbyname(service,protocol))
++ if ((pse=getservbyname(service,protocol)))
+ sin.sin_port=pse->s_port;
+
+ else if ((sin.sin_port=htons((unsigned short)atoi(service)))==0)
+@@ -85,7 +87,7 @@
+ return -1;
+ }
+
+- if (phe=gethostbyname(host))
++ if ((phe=gethostbyname(host)))
+ bcopy(phe->h_addr,(char *)&sin.sin_addr,phe->h_length);
+
+ else if ((sin.sin_addr.s_addr = inet_addr(host))==INADDR_NONE)
+diff -Nur clients/map.orig/map_main.c clients/map/map_main.c
+--- clients/map.orig/map_main.c 2007-09-11 15:56:24.838414157 +0100
++++ clients/map/map_main.c 2007-09-11 15:55:58.208896628 +0100
+@@ -16,9 +16,11 @@
+ * for more details. *
+ * *
+ *****************************************************************************/
+-#include "forms.h"
++#include <forms.h>
+ #include "map.h"
+ #include <sys/timeb.h>
++#include <unistd.h>
++#include <stdlib.h>
+
+ extern int connectsock();
+ extern void handler();
+@@ -29,7 +31,7 @@
+ int main(int argc, char *argv[])
+ {
+ int i, skt, x, y, z;
+- char cmd[16], bufr[625], satnamelist[26][26];
++ char bufr[625], satnamelist[26][26];
+ const char *ptrsat;
+ FD_map *fd_map;
+ struct timeb tptr;
diff --git a/sci-astronomy/predict/metadata.xml b/sci-astronomy/predict/metadata.xml
index b229aec85b8f..c73af199f515 100644
--- a/sci-astronomy/predict/metadata.xml
+++ b/sci-astronomy/predict/metadata.xml
@@ -2,4 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci</herd>
+<longdescription lang="en">
+Predict is a satellite tracking program. It is probably mostly of interest
+to users of amateur satellites, but includes support for optionally
+announcing azimuth and elevation to help in manual antenna pointing,
+or optical observation of satellites.
+</longdescription>
</pkgmetadata>
diff --git a/sci-astronomy/predict/predict-2.2.2-r3.ebuild b/sci-astronomy/predict/predict-2.2.2-r3.ebuild
deleted file mode 100644
index ab928ed04c58..000000000000
--- a/sci-astronomy/predict/predict-2.2.2-r3.ebuild
+++ /dev/null
@@ -1,170 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/predict-2.2.2-r3.ebuild,v 1.4 2005/12/08 00:53:27 cryos Exp $
-
-inherit multilib
-
-DESCRIPTION="Satellite tracking and orbital prediction."
-HOMEPAGE="http://www.qsl.net/kd2bd/predict.html"
-SRC_URI="http://www.amsat.org/amsat/ftp/software/Linux/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="xforms gtk nls"
-KEYWORDS="amd64 ~ppc x86"
-
-DEPEND="sys-libs/ncurses
- gtk? ( =x11-libs/gtk+-1.2* )
- xforms? ( x11-libs/xforms )"
-RDEPEND="gtk? ( =x11-libs/gtk+-1.2* )
- xforms? ( x11-libs/xforms )"
-
-if [ -x /usr/bin/xearth ]; then
- EARTHTRACKOK="yes"
-elif [ -x /usr/bin/xplanet ]; then
- EARTHTRACKOK="yes"
-fi
-
-src_compile() {
- # predict uses a ncurses based configure script
- # this is what it does if it was bash based ;)
-
- # set compiler string to a var so if compiler checks
- # can be added at a later date
- COMPILER="cc ${CFLAGS} -fomit-frame-pointer"
-
- # write predict.h
- echo "char *predictpath=\"/usr/share/predict/\";" > predict.h
- echo "char soundcard=1;" >> predict.h
- echo "char *version=\"${PV}\";" >> predict.h
-
- # compile predict
- einfo "compiling predict"
- ${COMPILER} -L/$(get_libdir) -lm -lncurses -lpthread predict.c -o predict
-
- # write vocalizer.h
- cd vocalizer
- echo "char *path={\"/usr/share/predict/vocalizer/\"};" > vocalizer.h
-
- # compile vocalizer
- einfo "compiling vocalizer"
- ${COMPILER} vocalizer.c -o vocalizer
-
- einfo "compiling clients"
-
- # earthtrack
- if test "${EARTHTRACKOK}" = "yes"; then
- einfo "compiling earthtrack"
- cd ${S}/clients/earthtrack
- ${COMPILER} -lm earthtrack.c -o earthtrack
- fi
-
- # kep_reload
- einfo "compiling kep_reload"
- cd ${S}/clients/kep_reload
- ${COMPILER} kep_reload.c -o kep_reload
-
- # map
- if use xforms; then
- einfo "compiling map"
- cd ${S}/clients/map
- TCOMP="${COMPILER} -I/usr/X11R6/include -L/usr/X11R6/$(get_libdir) -lforms -lX11 -lm map.c map_cb.c map_main.c -o map"
- ${TCOMP}
- fi
-
- # gsat
- if use gtk; then
- # note there are plugins for gsat but they are missing header files and wont compile
- use nls || myconf="--disable-nls"
- einfo "compiling gsat"
- cd ${S}/clients/gsat-*
- ./configure --prefix=/usr ${myconf}
- cd src
- sed -e "s:#define DEFAULTPLUGINSDIR .*:#define DEFAULTPLUGINSDIR \"/usr/$(get_libdir)/gsat/plugins/\":" -i globals.h
- sed -e 's:int errno;::' -i globals.h
- cd ..
- emake
- fi
-}
-
-src_install() {
- # install predict
- cd ${S}
- dobin predict ${FILESDIR}/predict-update
- dodoc CHANGES COPYING CREDITS HISTORY README
- dodoc docs/pdf/predict.pdf
- dodoc docs/postscript/predict.ps
- doman docs/man/predict.1
-
- insinto /usr/share/${PN}/default
- doins default/predict.*
-
- #install vocalizer
- exeinto /usr/bin
- cd vocalizer
- doexe vocalizer
- dodir /usr/share/predict/vocalizer
- insinto /usr/share/predict/vocalizer
- dosym /usr/bin/vocalizer /usr/share/predict/vocalizer/vocalizer
- doins *.wav
-
- mv README README.vocalizer
- dodoc README.vocalizer
-
- # install clients
-
- # earthtrack
- if test "${EARTHTRACKOK}" = "yes"; then
- cd ${S}/clients/earthtrack
- ln -s earthtrack earthtrack2
- dobin earthtrack earthtrack2
- mv README_FIRST README_FIRST.earthtrack
- mv README README.earthtrack
- dodoc README_FIRST.earthtrack README.earthtrack
- fi
-
- # kep_reload
- cd ${S}/clients/kep_reload
- dobin kep_reload
- mv INSTALL INSTALL.kep_reload
- mv README README.kep_reload
- dodoc INSTALL.kep_reload README.kep_reload
-
- # map
- if use xforms; then
- cd ${S}/clients/map
- dobin map
- for i in CHANGES README COPYING; do
- mv ${i} ${i}.map
- dodoc ${i}.map
- done
- fi
-
- # gsat
- if use gtk; then
- # the install seems broken so do manually...
- cd ${S}/clients/gsat-*
- dodir /usr/$(get_libdir)/gsat/plugins
- keepdir /usr/$(get_libdir)/gsat/plugins
- cd src
- dobin gsat
- cd ..
- for i in AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL NEWS README Plugin_API; do
- mv ${i} ${i}.gsat
- dodoc ${i}.gsat
- done
- fi
-}
-
-pkg_postinst() {
- einfo "to use the clients the following line will"
- einfo "have to be inserted into /etc/services"
- einfo "predict 1210/udp"
- einfo "the port can be changed to anything"
- einfo "the name predict is what is needed to work"
- einfo "after that is set run 'predict -s'"
- einfo ""
- einfo "to get list of satellites run 'predict-update'"
- einfo "before running predict this script will also update"
- einfo "the list of satellites so they are up to date."
-}
diff --git a/sci-astronomy/predict/predict-2.2.3.ebuild b/sci-astronomy/predict/predict-2.2.3.ebuild
index 37be9bb4f47f..fb731b217616 100644
--- a/sci-astronomy/predict/predict-2.2.3.ebuild
+++ b/sci-astronomy/predict/predict-2.2.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/predict-2.2.3.ebuild,v 1.3 2007/01/26 14:43:43 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/predict-2.2.3.ebuild,v 1.4 2007/09/11 15:06:57 bicatali Exp $
-inherit toolchain-funcs
+inherit toolchain-funcs eutils
DESCRIPTION="Satellite tracking and orbital prediction."
HOMEPAGE="http://www.qsl.net/kd2bd/predict.html"
@@ -18,6 +18,12 @@ DEPEND="sys-libs/ncurses
xforms? ( x11-libs/xforms )
xplanet? ( || ( x11-misc/xplanet x11-misc/xearth ) )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-xforms.patch
+}
+
src_compile() {
# predict uses a ncurses based configure script
# this is what it does if it was bash based ;)
@@ -50,7 +56,7 @@ src_compile() {
# earthtrack
if use xplanet; then
einfo "compiling earthtrack"
- cd ${S}/clients/earthtrack
+ cd "${S}"/clients/earthtrack
# fix include path
sed -e "s:/usr/local/share/xplanet:/usr/share/xplanet:" \
-i earthtrack.c || die "Failed to fix xplanet paths"
@@ -60,14 +66,14 @@ src_compile() {
# kep_reload
einfo "compiling kep_reload"
- cd ${S}/clients/kep_reload
+ cd "${S}"/clients/kep_reload
${COMPILER} kep_reload.c -o kep_reload || \
die "Failed compiling kep_reload"
# map
if use xforms; then
einfo "compiling map"
- cd ${S}/clients/map
+ cd "${S}"/clients/map
TCOMP="${COMPILER} -I/usr/X11R6/include -L/usr/X11R6/$(get_libdir) -lforms -lX11 -lm map.c map_cb.c map_main.c -o map"
${TCOMP} || die "Failed compiling map"
fi
@@ -77,7 +83,7 @@ src_compile() {
# note there are plugins for gsat but they are missing header files and wont compile
use nls || myconf="--disable-nls"
einfo "compiling gsat"
- cd ${S}/clients/gsat-*
+ cd "${S}"/clients/gsat-*
./configure --prefix=/usr ${myconf}
cd src
sed -e "s:#define DEFAULTPLUGINSDIR .*:#define DEFAULTPLUGINSDIR \"/usr/$(get_libdir)/gsat/plugins/\":" -i globals.h
@@ -89,9 +95,9 @@ src_compile() {
src_install() {
# install predict
- cd ${S}
- dobin predict ${FILESDIR}/predict-update
- dodoc CHANGES COPYING CREDITS HISTORY README NEWS
+ cd "${S}"
+ dobin predict "${FILESDIR}"/predict-update
+ dodoc CHANGES CREDITS HISTORY README NEWS
dodoc docs/pdf/predict.pdf
dodoc docs/postscript/predict.ps
doman docs/man/predict.1
@@ -112,7 +118,7 @@ src_install() {
# earthtrack
if use xplanet; then
- cd ${S}/clients/earthtrack
+ cd "${S}"/clients/earthtrack
ln -s earthtrack earthtrack2
dobin earthtrack earthtrack2
mv README README.earthtrack && \
@@ -121,7 +127,7 @@ src_install() {
fi
# kep_reload
- cd ${S}/clients/kep_reload
+ cd "${S}"/clients/kep_reload
dobin kep_reload
mv INSTALL INSTALL.kep_reload && \
mv README README.kep_reload && \
@@ -130,9 +136,9 @@ src_install() {
# map
if use xforms; then
- cd ${S}/clients/map
+ cd "${S}"/clients/map
dobin map
- for i in CHANGES README COPYING; do
+ for i in CHANGES README; do
mv ${i} ${i}.map && dodoc ${i}.map || \
die "Failed to install xforms docs"
done
@@ -141,13 +147,13 @@ src_install() {
# gsat
if use gtk; then
# the install seems broken so do manually...
- cd ${S}/clients/gsat-*
+ cd "${S}"/clients/gsat-*
dodir /usr/$(get_libdir)/gsat/plugins
keepdir /usr/$(get_libdir)/gsat/plugins
cd src
dobin gsat
cd ..
- for i in AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL NEWS README Plugin_API; do
+ for i in AUTHORS ABOUT-NLS ChangeLog INSTALL NEWS README Plugin_API; do
mv ${i} ${i}.gsat && dodoc ${i}.gsat || \
die "Failed to install gsat docs"
done