summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-07-28 16:31:20 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-07-28 16:31:20 +0000
commit72ceff9e7ad16b2f3d2c5d8458ce86cb3d8b8973 (patch)
treec456ecc7e3e96d86f7229331742c85e05b20696a /sci-astronomy/stiff/stiff-1.12.ebuild
parentAdd "python3" USE flag. (diff)
downloadgentoo-2-72ceff9e7ad16b2f3d2c5d8458ce86cb3d8b8973.tar.gz
gentoo-2-72ceff9e7ad16b2f3d2c5d8458ce86cb3d8b8973.tar.bz2
gentoo-2-72ceff9e7ad16b2f3d2c5d8458ce86cb3d8b8973.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/stiff/stiff-1.12.ebuild')
-rw-r--r--sci-astronomy/stiff/stiff-1.12.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-astronomy/stiff/stiff-1.12.ebuild b/sci-astronomy/stiff/stiff-1.12.ebuild
new file mode 100644
index 000000000000..75bdb42450cb
--- /dev/null
+++ b/sci-astronomy/stiff/stiff-1.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stiff/stiff-1.12.ebuild,v 1.1 2009/07/28 16:31:19 bicatali Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="Converts astronomical FITS images to the TIFF format for illustration purposes."
+HOMEPAGE="http://astromatic.iap.fr/software/stiff"
+SRC_URI="ftp://ftp.iap.fr/pub/from_users/bertin/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-configure.patch
+ eautoreconf
+}
+
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS BUGS ChangeLog HISTORY README THANKS
+ use doc && dodoc doc/*
+}